English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

65 Posts

09-26-2010

sacramento

77 Signins

844 Page Views

  • Posts: 65
  • Registered: ‎09-26-2010
  • Location: sacramento
  • Views: 844
  • Message 1 of 4

W510 problems being sent to service 2nd Time..worse then W500

2010-10-03, 23:36 PM

I have a few months old new w510. Right off the bet I had problems.. Speaker didn't work the right side.. First time I sent it in for the right speaker replacement.. and keyboard left click was having some problems. The screen also makes a cracking nose randmoly when opening and closing. They didn't fix the speaker but replaced the Bezel..something do with mother board..and sound..when I got it back I still had the same problems..I am very dissapointed with the new 510s..seems like everything is pos. The screen is still making a cracking noise while closing or opening.. I heard others having problems with the speakers etc..

 

I am venting..stupid computers and stupid people cannot fix anything right..now Monday I am sending it in for a 2nd time..here is the pic of what they replaced..

 

Link to picture

 

Note from Moderator:  Image(s) >50k converted to link(s).

 

 

Reply
Options

25 Posts

08-24-2010

Durham, NC, USA

48 Signins

589 Page Views

  • Posts: 25
  • Registered: ‎08-24-2010
  • Location: Durham, NC, USA
  • Views: 589
  • Message 2 of 4

Re: W510 problems being sent to service 2nd Time..worse then W500

2010-10-06, 12:24 PM

More  examples of HIGH Quality (NOT)!

Reply
Options

288 Posts

04-20-2010

Ottawa

2936 Signins

4886 Page Views

  • Posts: 288
  • Registered: ‎04-20-2010
  • Location: Ottawa
  • Views: 4886
  • Message 3 of 4

Re: W510 problems being sent to service 2nd Time..worse then W500

2010-10-06, 20:55 PM
Note TO Moderator: You broke the link, can't see the image now. How ironic, given the nature of the post ;)
Reply
Options

9380 Posts

11-27-2007

Slovakia

15518 Signins

2040239 Page Views

  • Posts: 9380
  • Registered: ‎11-27-2007
  • Location: Slovakia
  • Views: 2040239
  • Message 4 of 4

Re: W510 problems being sent to service 2nd Time..worse then W500

2010-10-06, 21:04 PM

 


wrote:
Note TO Moderator: You broke the link, can't see the image now. How ironic, given the nature of the post ;)

Thanks for pointing this out, link fixed.

 

Andy  

______________________________________


Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points

Did you find a post helpfull? You can thank the member by clicking on the star to the left awarding them Kudos

Please add your type, model number and OS to your signature, it helps to help you.

Forum Search Option T430 2347-G7U W8 x64, Yoga 10 HD+, Tablet 1838-2BG, T61p 6460-67G W7 x64, T43p 2668-G2G XP, T23 2647-9LG XP, plus a few more.

FYI Unsolicited Personal Messages will be ignored.

de.gif  Deutsche Community   es.gif  Comunidad en Español  uk.gif  English Community ru.gif Русскоязычное Сообщество

PepperonI blog 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms