Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
Posts: 3
Registered: ‎02-08-2011
Location: Crewe, UK
Message 1 of 8 (1,677 Views)

W510 with Windows 7 Pro x64 - bluetooth not working

My bluetooth stopped working about 2 weeks after I got the W510. I have uninstalled and reinstalled the Bluetooth 2.1 with EDR software several times but it still will not detect any bluetooth devices. I know the hardware is working, because I have the W510 set up with a dual-boot Ubuntu installation, and the Lenovo Bluetooth Laser Mouse is detected immediately when I use that instead of Windows 7. Has anyone else had a similar problem? Any tips for getting it working?

Thanks

Bit Torrent
Posts: 1,213
Registered: ‎12-24-2010
Location: Perth, Australia
Message 2 of 8 (1,598 Views)

Re: W510 with Windows 7 Pro x64 - bluetooth not working

Hello mate,

 

Check in the device manager in the properties of USB hub if the bluettoth is powered properly.

What exactly happens ? can you turn it on or not at all ?

__________________________________________________________________________________

Knowledge is of two kinds. We know a subject ourselves, or we know where we can find information on it.


ThinkPad T510 4313-CTO Windows 8 x64 - Intel Core i7-620M - NVIDIA NVS 3100M - 8GB RAM - 240GB SSD- Intel Centrino Ultimate-N 6300 - Gobi 2000.
ThinkPad Helix 3697-CTO Windows 8.1 x64 - Intel Core i7-3667U - Intel HD Graphics 4000 - 8GB RAM- 256GB SSD - Intel Centrino Advanced-N 6205 - Ericsson C5621gw

Paper Tape
Posts: 3
Registered: ‎02-08-2011
Location: Crewe, UK
Message 3 of 8 (1,588 Views)

Re: W510 with Windows 7 Pro x64 - bluetooth not working

Er, sorry, how do I try to turn on the power from the device manager?

If I look at the generic USB hub properties (the one with BT attached) I see:

 

HID-compliant mouse - 100mA required

Thinkpad Bluetooth 2.1 - 0mA required

USB composite device - unknown

 

the last one is the webcam, I believe

 

Cheers

 

Bit Torrent
Posts: 1,213
Registered: ‎12-24-2010
Location: Perth, Australia
Message 4 of 8 (1,568 Views)

Re: W510 with Windows 7 Pro x64 - bluetooth not working

What's happen when you press Fn+F5 ?

__________________________________________________________________________________

Knowledge is of two kinds. We know a subject ourselves, or we know where we can find information on it.


ThinkPad T510 4313-CTO Windows 8 x64 - Intel Core i7-620M - NVIDIA NVS 3100M - 8GB RAM - 240GB SSD- Intel Centrino Ultimate-N 6300 - Gobi 2000.
ThinkPad Helix 3697-CTO Windows 8.1 x64 - Intel Core i7-3667U - Intel HD Graphics 4000 - 8GB RAM- 256GB SSD - Intel Centrino Advanced-N 6205 - Ericsson C5621gw

Paper Tape
Posts: 3
Registered: ‎02-08-2011
Location: Crewe, UK
Message 5 of 8 (1,559 Views)

Re: W510 with Windows 7 Pro x64 - bluetooth not working

[ Edited ]

If I press Fn+F5 I get the display as expected. Bluetooth shows as powered on; I can power it on and off from the OSD and the green light under the screen reacts as expected -  but nothing will persuade it to find any devices!

802.11n
Posts: 501
Registered: ‎03-10-2009
Location: Chicago, IL
Message 6 of 8 (1,031 Views)

Re: W510 with Windows 7 Pro x64 - bluetooth not working

[ Edited ]

Hi,

 

I have the same thing going on but with a new W520. Finds devices for a couple days then stops finding devices and cannot pair to the computer from another device (my phone) though it is discoverable there. When I go back to the Lenovo OKR image from the recovery partition, it starts working again.

When it eventually stops working there are no errors in device manager, the BT radio is on, all appears like it should be working but it doesn't. This is on a Windows 7 x64 Pro OKR image (upgraded to Ultimate). It is a perplexing and annoying issue.

Guru
Posts: 1,439
Registered: ‎04-20-2008
Location: US
Message 7 of 8 (1,024 Views)

Re: W510 with Windows 7 Pro x64 - bluetooth not working

What does "OKR" stand for?


P70 XEON 1505, BIOS 2.06, UHD 4k Display, 64GB non-ECC RAM, M3000M NVIDIA GPU, RAID 1 512GB Samsung 951 PCIe-NVMe SSD x 2, Samsung 850 Pro 1TB SSD. EM7455 WWAN

T460s, BIOS 1.14, WQHD display, 20GB RAM, I7-6600U, Samsung PM961 1TB PCIe-NVMe SSD, EM7455 WWAN
802.11n
Posts: 501
Registered: ‎03-10-2009
Location: Chicago, IL
Message 8 of 8 (1,021 Views)

Re: W510 with Windows 7 Pro x64 - bluetooth not working

[ Edited ]

OKR - On eKey Recovery. Sorry. I was refering to the system image from the recovery partition.

top kudoed authors