cancel
Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 7,213

Question

I swapped out the hard disk when I got it for a Crucial M4 256GB.  The machine has been fast and totally stable until now.  I'm using Win7 Pro and have not applied reg hacks or bois updates, and it just worked.

 

Now I am seeing the 2100: Detection Error on HDD0 message sporadically after being unattended for about 30 mins.  Rebooting solves the problem.  The machine is set to never sleep or hibernate other than manually.  It hasn't yet occured when working at the machine but I suspect Windows is crashing, then this message appears as the machine tries to reboot.  When I reboot manually its detected and Win7 runs.

 

Has anyone seen this or have any ideas?


SSD Life reports the drive is in excellent health.  All files are stored on network shares, only program files on the SSD.

 

Answer

There could have more workarounds than being addressed here.  We shared what we noticed from the community discussions.

 

A forum user whose SSD has 5200 power on hours had encountered this issue as described in Crucial forum: http://forum.crucial.com/t5/Solid-State-Drives-SSD/BSOD-Crucial-M4/td-p/79098

 

This forum user updated the SSD firmware and it fixed the issue.

Firmware can be found in Crucial Support site: http://www.crucial.com/support/firmware.aspx

 

Another community user commented that re-seating the drive seemed to have solved the problem too.

Was this information helpful?

Comments
eos

I had the same issue with the same mSATA SSD - after 1.5 years of stable use, out of the blue got 2010 detection error.

Unfortunately, the mSATA was my bood disk.  After trying recomendations from Curical (leave it in bios for 30 mins, then pull power plug), the machine became toast - no lights no beeps, no bios, completely dead.  As it happened 3 days after my unused 3 year NBD warrantey expired, LEvovo said tough luck, so the laptop was binned, and went back to Dell.  So if you get this error, you could be in deep trouble.

almozar

I've the 2100 Detection Error on HDD0 with my W520, I am using PNY XLR8 240GB SSD.

 

It worked fine for a month.

 

I also have PGP installed and whole disc encrypted.

 

I installed an update of Intel Management Engine Firmware and Intel Chipset, both are the latest from lenovo site because I was experiencing expreme slowness from my harddrive. Programs would freeze. Webpages would take forever to load..


The next time I rebooted, I got the error. If I leave the SSD out for a bit, and put the SSD back in, the disk will work for some time... but on next reboot, it is again detection error..

 

TRIM is enabled on my system. I am not sure how the SSD died so quickly.

 

I am back to using my HDD but I am not happy. I want a solution... is this a intel chipset issue? Intel IMEI issue? Is  the PNY SSD just a bad model?

 

I've googled plenty and dont really see a solution. Sometimes there is a firmware update.. PNY has no firmware updates for my drive.. I don't see anybody else using PNY on their W520, but plenty of people are experiencing Error 2100 with SSD on their W520.. somethings fishy..

 

help please! thanks in advance !

GuyInLouisiana

I have an E531 6885 running Win7 64 bit. After a windows update, the laptop started giving me this error. I attempted the quick fixes, such as going into diagnostic, the HDD isn't present there either. I've reseated the HDD, nothing is working. I believe this could be a chipset/IRST mismatch issue, I just need to know what to get and a suggestion on how to get it installed. 

 

Ok yes it's an old laptop but I need to get it going even if only long enough to back up my data. I am desperate please any solution is a godsend at this point.

 

 I'll give you more info: I put the HDD into a similar Lenovo, and took the HDD from that computer and put it in mine, and the error stayed with the HDD. There is ONE caveat to this: the other computer has Windows 10, so that *might* not mitigate there being an Chipset/IRST mismatch, maybe? My old computer booted into Windows 10 using that HDD just fine, and I got exactly the same error on the other computer (2100 detection error) with the HDD from my old laptop. Is there any possibility of recovering this HDD?

TechnoDaddy

Hi everyone.
I am using T420 and X220. On T420after powering it On appear message: 2100: Detection error on HDD0 (Main HDD) Press Esc to continue.
I took the disk out and connect it to my another Lenovo and I check using Comand Promt. As the result I found only 4 bad sectors. I was able to trace out all my personal information from damaged disk. When I made the copy from original disk to new SSD it showing to me absolutely the same message: 2100: Detection error on HDD0 (Main HDD) Press Esc to continue.
So how can I fix this issue? Where I can get Software for it?