English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

6 Posts

03-19-2012

Massachusetts

5 Signins

28 Page Views

  • Posts: 6
  • Registered: ‎03-19-2012
  • Location: Massachusetts
  • Views: 28
  • Message 1 of 9

W520 Trackpoint doesn't click while typing

2013-10-01, 17:05 PM

Using Win 8.1 x64 and the latest Synaptics drivers, if I'm typing or holding a key the left click does not work. I've tried every setting in the Synaptics control panel and can't figure out how to disable this behavior.

 

Does anyone know how to disable this? It's very annoying, especially as there is a delay after pressing a key before I can click the mouse of around a half second.

 

Easily recreated by opening notepad and holding down the A key, then trying to left click something.

Solved! See the solution
Reply
Options

6 Posts

03-19-2012

Massachusetts

5 Signins

28 Page Views

  • Posts: 6
  • Registered: ‎03-19-2012
  • Location: Massachusetts
  • Views: 28
  • Message 2 of 9

Re: W520 Trackpoint doesn't click while typing

2013-10-09, 3:32 AM

Bumping this because it is very frustrating and I've tried everything I can think of. Newest Synaptic drivers, old ones, no drivers, every option in the control panel.


Does anyone have any idea?

Reply
Options

3 Posts

10-27-2013

United States

4 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎10-27-2013
  • Location: United States
  • Views: 35
  • Message 3 of 9

Re: W520 Trackpoint doesn't click while typing

2013-10-27, 11:04 AM

Found a solution! For whatever reason, Windows 8.1 has preconfigured mouse settings which conflict with whatever mouse and touchpad drivers you have installed. These settings can be accessed via "PC Settings". Open up the charms bar, go to "Settings", then click "Change PC Settings". Within "PC Settings", click "PC and devices". Click "Mouse and touchpad", and under the header "Touchpad" using the dropdown menu, select "No delay (always on)! 



Hope this helps if you haven't figured it out already! :smileywink:

0 person found this solution to be helpful.

This helped me too

Reply
Options

6 Posts

03-19-2012

Massachusetts

5 Signins

28 Page Views

  • Posts: 6
  • Registered: ‎03-19-2012
  • Location: Massachusetts
  • Views: 28
  • Message 4 of 9

Re: W520 Trackpoint doesn't click while typing

2013-10-27, 21:11 PM

Funnily enough, I accidentally found that setting yesterday. I was sure that it was something to do with Synaptics after seeing nothing in the Mouse control panel so I was trying to very to drivers from 2007, and ended up doing a search for Mouse in the Metro UI which brought up that other mouse menu. Mighty frustrating that they have mouse settings in two different places!

Reply
Options

3 Posts

10-27-2013

United States

4 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎10-27-2013
  • Location: United States
  • Views: 35
  • Message 5 of 9

Re: W520 Trackpoint doesn't click while typing

2013-10-27, 23:45 PM
I know. What were they thinking?
Reply
Options

2 Posts

05-07-2013

United States

2 Signins

12 Page Views

  • Posts: 2
  • Registered: ‎05-07-2013
  • Location: United States
  • Views: 12
  • Message 6 of 9

Re: W520 Trackpoint doesn't click while typing

2014-03-02, 3:05 AM

Wow, thanks so much for this... been developing a game in DirectX and thought this mouse input problem was my fault.  FINALLY got this figured out.

Reply
Options

3 Posts

10-27-2013

United States

4 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎10-27-2013
  • Location: United States
  • Views: 35
  • Message 7 of 9

Re: W520 Trackpoint doesn't click while typing

2014-03-02, 13:57 PM

No problem! :)

Reply
Options

1 Posts

07-09-2017

US

1 Signins

7 Page Views

  • Posts: 1
  • Registered: ‎07-09-2017
  • Location: US
  • Views: 7
  • Message 8 of 9

Re: W520 Trackpoint doesn't click while typing

2017-07-09, 4:54 AM

For what it's worth, the problem and solution are essentially the same with Windows 10 on a ThinkPad P51: Start -> Settings -> Devices -> Mouse and Touchpad.

 

I prefer to disable the touchpad and use only the trackpoint.  However, it is necessary to turn the Touchpad On using the Settings screen, in order to change the delay time.  You can then turn the touchpad off again, and the delay time fix (change to "No delay (always on)") remains in effect for the mouse buttons.  Not very intuitive....

Reply
Options

1 Posts

05-30-2018

US

3 Signins

102 Page Views

  • Posts: 1
  • Registered: ‎05-30-2018
  • Location: US
  • Views: 102
  • Message 9 of 9

Re: W520 Trackpoint doesn't click while typing

2018-05-30, 20:01 PM
Also for what it's worth, the most recent update of Windows completely removed the "No Delay" setting...

Finally after a couple hours of reasearching, I found a fix that worked for me on my ThinkPad P51 running Windows 10:

Reddit post by Abdellah_Abra:
 

"Hit windows key+R, type "regedit" then go to : HKEY_CURRENT_USER > Software > Microsoft > Windows > CurrentVersion > PrecisionTouchPad Then search for "AAPThreshold" on the right part of the window and double click it or right click it and click modify. Change the value from whatever it is (probably 2 or 3) to 0 and click OK. Restart you computer and it should work."

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete