cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KnightCa
What's DOS?
Posts: 3
Location: United States
Views: 1,567
Message 1 of 6

W520 entering sleep mode but sleep disabled in power mgmt?

I have a W520 running Windows 7 Professional. Just recently, my laptop has been going into sleep mode after being idle for about 2-4 minutes (the time is not consistent). My power management is set to "high performance". Put the computer to sleep is set to "Never". The advanced power settings are:

Sleep after
On battery: Never
Plugged in: Never
Allow hybrid sleep
On battery: Off
Plugged in: Off
Hibernate after
On battery: Never
Plugged in: Never
Allow wake timers
On battery: Disable
Plugged in: Disable

Does anybody have an idea of why my laptop goes into sleep mode after 2-4 minutes? Is this a software or hardware problem?

Retired Support Specialist
Posts: 1,090
Location: Bangalore
Views: 1,534
Message 2 of 6

Re: W520 entering sleep mode but sleep disabled in power mgmt?

Hi KnightCa,

 

Welcome to Lenovo Community Forums!

 

I'm really sorry to hear that your Lenovo W520 goes into sleep mode even after it has been disabled in Power management.

 

Go to Control panel - - >Power Options - - >Change plan settings (Choose the Power plan that you have selected) - - >Change advanced power settings - - >Adjust the settings under sleep and display as shown below.

1.jpg 

2.jpg

Also, try doing a windows update and reinstallation of Power manager in your system.

 

If the above said didn’t help, try doing a registry editing.

 

1. Open the Start Menu.

2. In the white line (Start Search) area, type regedit and press Enter.

3. If prompted, click on Continue in the prompt.

4. In regedit, go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0\DefaultPowerSchemeValues.

 

5. Expand DefaultPowerSchemeValues and Click on the key that is for the Power Plan that you want to change the wait time (Refer the table below)

 

Spoiler
3.jpg

6. In the right pane, right click on ACSettingIndex (while on AC power) or DCSettingIndex (while on battery power) and click on Modify.

 

7. Choose Decimal, and type in how many seconds you want Windows to wait to go back to sleep automatically after an unattended wakeup.

 

Spoiler
4.jpg

8. Close regedit.

9. Restart the computer to apply.

 

 

Hope this helps and do post back with the results. Expecting to hear from you soon.

 

Best Regards,

Mithun.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Guru
Posts: 9,591
Location: CA
Views: 1,520
Message 3 of 6

Re: W520 entering sleep mode but sleep disabled in power mgmt?

I'd check in Event Viewer, System log. There should be entries under Kernel-Power for what caused the system to sleep when.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
KnightCa
What's DOS?
Posts: 3
Location: United States
Views: 1,508
Message 4 of 6

Re: W520 entering sleep mode but sleep disabled in power mgmt?

The first steps (changing them in the power menu) made absolutely no difference.

Reinstalling the power management driver also had no effect.

 

Changing them in registry to a longer time period, adjusted them to the longer period.

Unfortunately, it does not appear possible to direct it to never to go to sleep (since it must be a increment of seconds).

 

Please direct how this can be changed to never go to sleep.

I would ideally like this to not require a registry change, as this should work properly with the driver and software for power management.

KnightCa
What's DOS?
Posts: 3
Location: United States
Views: 1,507
Message 5 of 6

Re: W520 entering sleep mode but sleep disabled in power mgmt?

I will check that as soon as I get home. 

 

Since it only happens when the power management driver and softweare is installed, this leads me to believe it is related to that. Since adjusting the sleep time (in seconds) in the registry under that software, it likewise leads me to be believe its faulty coding in the software/driver.

survivant
Punch Card
Posts: 40
Location: canada
Views: 663
Message 6 of 6

Re: W520 entering sleep mode but sleep disabled in power mgmt?

I have the same problem with my Lenovo T510 and my new P70.   I was able to avoid the problem with my T510 by pausing a video.  That avoid the computer to do in sleep mode (yes the workaround is stupid.. but it works).

 

But that stupid workaround doesn't work with the P70.  If I let my computer without touching it, it will go in sleep mode.  Don't download anything while going to the bathroom.

 

PS.  I have Windows 10 on both my computers.

Top Kudoed Authors