cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
eos
802.11n
Posts: 469
Registered: ‎06-30-2011
Location: gibraltar
Views: 3,017
Message 1 of 5

W520 internal 1080p display stuck at 640x480, and freaks when connected to my displayport monitor.

For 6 weeks I have had no problems driving my 30" dell from the W520 displayport at its native 2560x1600 as the single "projector" display.

 

Today, I aroused the laptop from sleep as usual, and was greeted with a blank Monitor and the laptops internal display on, with a fixed unchangeable resolution of 640x480.

 

after about 5 reboots (includring removing power and battery), I found a way to get the W520 panel back to 1080p,but it wont display anything on the external monitor. 

 

The monitor works fine connected to the displayport of my dell laptop, so I dont think its anything to do with the monitor.

 

Interestingly, If I have the monitor plugged in, and do "Detect Displays" in he windows Display->Screen Resolutoin dialogue, I get this:

 

1. ThinkPad Display 1920x1080

2. Display Device on: Mobile PC Display

Available Display output on: Nvidia Quadro 2000M

Available Display output on: Intel(R) HD Graphics Family

 

what on earth is a "Mobile PC Display?"

 

If I disconnect the DisplayPort and detect displays, the "Mobile PC Display" goes away.

 

 

During the many attempts to fix this issue, twice I saw the message "Nvidia user experience driver component has stopped working", but I cant find specific steps to reproduce this.

 

I have done no sw updates, nor installed any SW or changed any configuration in the last 2 weeks.

 

I have tried all the combinations of connecting an external Projector:

Show desktop on 1

Show desktop on 2

Extend

Duplicate

Projector only

etc.

 

If I try and "duplicate" in the projector menu (windows-p), the internal display goes to 1024x768, and the external monitor gets no signal.  Looking at the windows resolution dialogue, it shows 1&2 both on the internal display, and nothing on the exteranl monitor which becomes 3).

 

 If I say projector only, the external mointor gets a signal, but both screens are blank.

 

I have been fighting for the last month to get the 3yr NBD warranty which was purchased with the machine online 2 months ago registered, but the Lenovo warranty support team say they have a problem with their process, and they have no way to give me the warranty I purchased and paid for as there is a date problem in their system.  They have even said I have to return the machine to UK where I bought it if I want to get the warranty purchased online as part of the machine order.  Obvoisly, Im not going to post back the machine and be unable to work for unknown weeks to get my on-site Next Business Day warrantly I purchased at significant expesse so I would not be wihtout the machine for more than 1 day in case of problems like this.

 

According to the Lenovo toolbox, the driver version is 8.17.12.6802. I searched the website, and it seems there is a newer version: 8.17.12.6871 so ill try updating it.

Installed the new version - no difference.

JazJon
Punch Card
Posts: 58
Registered: ‎08-07-2011
Location: San Francisco
Views: 2,994
Message 2 of 5

Re: W520 internal 1080p display stuck at 640x480, and freaks when connected to my displayport monito

Did you hit Fn (Function) + Spacebar ?   That seems to put the screen in some wierd zoomed in yet low res mode)

eos
802.11n
Posts: 469
Registered: ‎06-30-2011
Location: gibraltar
Views: 2,985
Message 3 of 5

Re: W520 internal 1080p display stuck at 640x480, and freaks when connected to my displayport monito

Good idea, but unfortunately thats not it. You are right that it changes the resolution though.
Guru
Posts: 1,749
Registered: ‎04-20-2008
Location: US
Views: 2,971
Message 4 of 5

Re: W520 internal 1080p display stuck at 640x480, and freaks when connected to my displayport monito

The fact that the internal display reverted to 640x480 (VGA) probably means that the drivers have become corrupted. I'm not sure what you have already tried, but may I suggest the following:

 

1. Uninstall the NVDIA drivers

2. Disable the NVIDIA GPU  (in Devioe Manager)

3. Shutdown and reboot into BIOS (F1)

4. Select Internal Graphics only

5. Exit and boot

6. Uninstall the Intel HD drivers

7. Disable the Intenal HD GPU

8. Reboot (Display should now be in VGA mode)

9 Enable the Intel HD GPU in Device Manager

10. System should reinstall the Intel drivers

11. Confirm that you can now control the Internal Display Resolution and set to 1080p

12. Shutdown and reboot into BIOS (F1)

13. Set GPU to Discrete

14. Exit and boot

15. Enable the NVDIA GPU in Device Manager

16. System should reinstall the NVIDIA drivers.

 

If you are now able to control the resolution of the displays, then shutdown and reboot into BIOS.

Set the graphics options back to Optimus.

 


P70 XEON 1505, BIOS 2.28, UHD 4k Display, 64GB non-ECC RAM, M3000M NVIDIA GPU, RAID 1 512GB Samsung 951 PCIe-NVMe SSD x 2, 2x Samsung 850 Pro 1TB SSD. EM7455 WWAN
P1. BIOS 1.17,Xeon Processor, 32GB, PM981 1TB x 2, RAID 1
T460s, BIOS 1.20, WQHD display, 20GB RAM, I7-6600U, Samsung PM961 1TB PCIe-NVMe SSD, EM7455 WWAN
T470s, 16GB RAM, BIOS 1.10, i7-7500, WQHD display, 512GB PM961 PCIe NVMe SSD
MikeOfKW
Paper Tape
Posts: 1
Registered: ‎09-12-2018
Location: CA
Views: 263
Message 5 of 5

Re: W520 internal 1080p display stuck at 640x480, and freaks when connected to my displayport monito

I had a similar issue. I had two monitors connected to my lenovo docking station. One was connected using DisplayPort and another using VGA. The monitor using VGA was working correctly, but the monitor using DisplayPort was maxing out at 640x480 resolution. This is how I resolved my issue (Windows 10):

  1. Right click on desktop > Display Settings
  2. Near the bottom, click on Advanced display settings
  3. Click on Display adapter properties for Display # (the one you're having trouble with)
  4. Select the Monitor tab and click the Properties button
  5. Select the Driver tab and click the Uninstall Device button
  6. Then disconnect and reconnect the monitor.
  7. You may need to go back into Display Settings to re-enable the 2nd monitor.

 

Check out current deals!


Shop current deals