cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
fofo911
Paper Tape
Posts: 2
Registered: ‎03-12-2013
Location: France
Views: 1,075
Message 1 of 3

W520 - nVIDIA Quadro 1000M remains disabled

Hi,

I need your help for this issue. Actually, I had an issue with the motherboard of my ThinkPad W520. The IT guys of my company gave me a temporary laptop, but it was a W510. They put the hard drive of the W520 in the W510. Well it worked. They just reinstalled some drivers. When the W520 was repaired, they put back the hard drive to it. But since then, the nVIDIA Quadro 1000M appears as disabled. I have installed and reinstalled several times the nVidia driver, but it is still disabled.

 

The OS is Windows 7 64-bit.

I checked the graphics setting in the BIOS, it is set to Optimus.

 

nvidia1.jpg

 

nvidia2.jpg

 

And When I launch the NVIDIA Control Panel, I have the following :

nvidia3.jpg

 

Any idea ?

Thanks in advance.

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 1,061
Message 2 of 3

Re: W520 - nVIDIA Quadro 1000M remains disabled

Go into BIOS and make sure graphics is set to Optimus, and detect switchable is off.

Go into Device Manager and uninstall the NVIDIA driver (check delete driver software). Windows will immediately try to hook up the next older driver it has. See if this works, if not, repeat the delete driver step. Do this until Windows starts calling it a Standard VGA adapter. At this point, reboot, and install the latest NVIDIA driver.


W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
fofo911
Paper Tape
Posts: 2
Registered: ‎03-12-2013
Location: France
Views: 1,036
Message 3 of 3

Re: W520 - nVIDIA Quadro 1000M remains disabled

Thanks for the hints.

I have followed the steps, but I am still having the same issue.

After I modified the BIOS, I even used the latest driver from NVIDIA and restarted.

But I notice also something strange, in the device manager, there is a device : "AGN Virtual Network Adapter" which always appear as disabled too. Even if I enable it and reboot the machine, it will become disabled again.

See screen shots below. I know that when they swtiched my laptop to the W510, there was an issue to connect to the internet, and the IT guys installed a new Ethernet driver. I have tried to reinstall the Ethernet driver, but, I am still facing the same behaviour.

 

Link to picture

 

The NVIDIA driver version :

 

Link to picture

 

Actually, my goal is to extend the display of my laptop to another monitor. I used to do it before without any problem.

But now, I can't. I think the root cause is that nVidia driver cannot install successfully.

 

Link to picture

 

When I select the second monitor, I have just a VGA device and I can't extend to this monitor. I can't also use projectors. I have installed the monitor's driver, but same problem.

 

Link to picture

 

Moderator note; picture(s) totalling >50K converted to link(s) Forum Rules

Check out current deals!


Shop current deals

Top Kudoed Authors