cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
amazingskillz
What's DOS?
Posts: 3
Registered: ‎07-19-2013
Location: Canada
Views: 2,323
Message 1 of 8

W520 only charges with docking station wall plug does not work

I have experienced this problem twice and am very confused about why it is occuring. 

 

I usually use my W520 laptop on a docking station and when I am at home or travelling I keep it powered by with a wall adapter.  So at work it stays charged and operating from the docking station (i.e. ports on the bottom of the laptop).  When I am at home it stays charged by pulling it in using the Lenovo (170W power adapter).

 

Last year I was in China working and all of a sudden my laptop would no longer charge and would shutdown when the battery died) with the wall adapter.  I ended up buying a docking station and managed to keep it charged and operating that way.  Obtaining any type of warranty service in China was a major pain but the problem was diagnosed to be an issue with my motherboard.  I returned to Canada and had my computer replaced (computer was about 3 months old).

 

Now I am back in Canada and have the same problem with my new replacement laptop.  I am puzzled why this keeps happening.  Has this occured with anyone else?  Is the plug on the W520 not very good quality?  Any thoughts or suggestions will be super appreciated. 

Community SeniorMod
Community SeniorMod
Posts: 9,874
Registered: ‎01-01-2010
Location: US
Views: 2,292
Message 2 of 8

Re: W520 only charges with docking station wall plug does not work

I have never heard of this problem. The DC-in cable is very similar to all the other models. Do you use the same AC adapter with the dock?

Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
amazingskillz
What's DOS?
Posts: 3
Registered: ‎07-19-2013
Location: Canada
Views: 2,268
Message 3 of 8

Re: W520 only charges with docking station wall plug does not work

Thanks for the reply. Actually everyone always thinks it is a problem with the power adapter cable but the cable I am using is the same one for my dock. I only had one cable for my dock and when I am travelling unpug it and use it when I am on the road.

Last time in China they took apart my computer and confirmed (I was watching them as they used the voltmeter) that power and proper voltgage was coming into my computer from the plug and all the way to the board (ie checking every interface along the way). Yet it was not charging the battery or providing power to run the computer. The only way to solv the problem was to use a dock. Only thing I could think of is that maybe something on the bottomdock connector is messed up and hence the computer believes it is connected to the dock and hence not wanting to provide power via the power adapter at the same time to avoid shorting out the board. Any thoughts?
Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 2,266
Message 4 of 8

Re: W520 only charges with docking station wall plug does not work

Go into Power Manager, Battery tab. Does it say "A 170W AC adapter is attached" or something?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
amazingskillz
What's DOS?
Posts: 3
Registered: ‎07-19-2013
Location: Canada
Views: 2,253
Message 5 of 8

Re: W520 only charges with docking station wall plug does not work

Thanks for the input. I did asyou said and when I am "docked" it says the 170W power supply is attached. But when I remove it from the dock and plug in the same power adapter (ie same one used to power the dock) it says The Battery is running in Maximum lifespan mode......
Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 2,245
Message 6 of 8

Re: W520 only charges with docking station wall plug does not work

Interesting. Something might be wrong with the centre pin on the adapter (or possibly, both laptops).

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
alvish
What's DOS?
Posts: 1
Registered: ‎04-09-2014
Location: United Arab Emirates
Views: 2,032
Message 7 of 8

Re: W520 only charges with docking station wall plug does not work

Hi,

 

Has anyone solved this issue? I am facing the same problem with my work laptop (T420s). It only charges when I put it in the docking station. When I went out for fieldwork and used the wall plug it says "battery not detected" hence wouldn't charge!

ogjerstad
Paper Tape
Posts: 7
Registered: ‎07-04-2016
Location: NO
Views: 1,411
Message 8 of 8

Re: W520 only charges with docking station wall plug does not work

I have the exact same problem on a W540 now. This thread is quite old, are there any known solutions for this?

Check out current deals!


Shop current deals

Top Kudoed Authors