cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
erneca
Fanfold Paper
Posts: 6
Registered: ‎03-27-2013
Location: germany
Views: 550
Message 1 of 7

W520 "random" CPU slowdown to 0,8 ghz on AC mode

I'm working with a w520 (i7 2760QM, 16GB Ram, Samsung SSD 830, Win7 64 bit, bios 1.42). 

Producing music, I am working a lot with ableton live (live 9, 64bit), I'm in need of quite a lot of cpu.

 

So, I have two problems with my w520. 

 

1. On battery it slows down to 0,8 ghz (which seems to be a known problem, but I can not figure out how to resolve this isse)

 

2. Lately, even on AC mode, it somehow randomly slows down from a max of 3,1 ghz to 0,8 ghz as well. I cannot work anymore when this happens, everything is way too slow. It happens every 4-5 minutes, when I'm using ableton live 9. I already checked, it doesnt slow down, when the cpu gets hot, it also slows down with lower cpu temperature.

 

 

this is absolutely not working for me. I'd need a tool where you could tell the cpu at certain times, to stick with the maximum performance all the time. I'd also like to increase the speed when on battery. I noticed, there are some threads discussing this issue, but there seems to be a different solution for a lot of people.

w520, i7 2760QM, 16GB Ram, Samsung SSD 830, Win7 64 bit, bios 1.42
unclewebb
802.11n
Posts: 236
Registered: ‎05-08-2010
Location: Cochrane
Views: 520
Message 2 of 7

Re: W520 "random" CPU slowdown to 0,8 ghz on AC mode

Check out ThrottleStop.  It is available from TechPowerUp.

 

It should allow you to manage your CPU speed a lot better.  For the dropping down to 800 MHz when on AC power, try disabling BD PROCHOT.  That little Intel feature has created a lot of nightmares for users.

 

Also make sure you are using the Windows High Performance profile with the Minimum processor state set to 100%.

erneca
Fanfold Paper
Posts: 6
Registered: ‎03-27-2013
Location: germany
Views: 505
Message 3 of 7

Re: W520 "random" CPU slowdown to 0,8 ghz on AC mode

Thanks for your answer. As suggested, I downloaded ThrottleStop, disabled BD PROCHOT and put the Windows High Performance mode on. Then I started one of my more CPU consuming Ableton Live projects and put it into a loop.  After around five minutes, my 4 cores slowed down to 800 mhz again. 1 minute later, everything goes back to normal, I run the project, and it keeps on happening again. I'm also monitoring the temperature of the cpu, but there doesnt seem to be a connection like slowdown after a certain threshold is reached. 

w520, i7 2760QM, 16GB Ram, Samsung SSD 830, Win7 64 bit, bios 1.42
unclewebb
802.11n
Posts: 236
Registered: ‎05-08-2010
Location: Cochrane
Views: 492
Message 4 of 7

Re: W520 "random" CPU slowdown to 0,8 ghz on AC mode

Can you post a screen shot of ThrottleStop so I can see exactly how you have it setup.  Try to snap a screenshot while your CPU is loaded and running at only 800 MHz.

 

If your CPU is not overheating, it is very rare when ThrottleStop can not be adjusted to get it running at its full Intel rated speed.

 

You can also check off the ThrottleStop Log File option.  When you are done testing, exit ThrottleStop so all of the data is written to the file.  Go into the ThrottleStop folder and then go into the Logs sub directory.  Open up the log file with today's date on it and copy and paste the log data somewhere convenient like www.pastebin.com  and then post a link here.

 

Seeing some more data can help with understanding the problem you are having.

erneca
Fanfold Paper
Posts: 6
Registered: ‎03-27-2013
Location: germany
Views: 454
Message 5 of 7

Re: W520 "random" CPU slowdown to 0,8 ghz on AC mode

 

Thanks again for your reply. So, I tried the first thing: Put on the ableton project, maximum power and wait for it to slow down to 0,8 ghz. This is how throttleStop looks like in that situation.

 

Link to image

 

If this doesnt help, I can try the logfile option afterwards too.

 

 

Moderator comment: Image(s) converted to link(s). For helpful information, please see: About Posting Pictures In The Forums.

w520, i7 2760QM, 16GB Ram, Samsung SSD 830, Win7 64 bit, bios 1.42
unclewebb
802.11n
Posts: 236
Registered: ‎05-08-2010
Location: Cochrane
Views: 442
Message 6 of 7

Re: W520 "random" CPU slowdown to 0,8 ghz on AC mode

Your screen shot shows that ThrottleStop is in Monitoring Mode only so it is not trying to do anything to help with your throttling problem.

 

To use ThrottleStop, adjust the Set Multiplier value to 35T for your CPU, put a check mark in the Set Multiplier box and then click on the Turn On button at the lower right.  See if this makes any difference.

 

To post just an image of ThrottleStop, highlight ThrottleStop, hold down the ALT key on your keyboard and then while ALT is down, push the Print Screen button usually at the top right area of your keyboard.  This puts an image of just the program that is highlighted into your clipboard so you can open up Paint, etc. and Paste that image and then save it.  

 

Posting small images or links to images keeps the mods happy.  Smiley Happy

erneca
Fanfold Paper
Posts: 6
Registered: ‎03-27-2013
Location: germany
Views: 397
Message 7 of 7

Re: W520 "random" CPU slowdown to 0,8 ghz on AC mode

hey unclewebb. thanks a lot, your comments helped a lot in getting closer to solving the problem. although my cpu still doesnt seem to fully respond to throttlestop, it is getting close most of the time to the values set by the multiplier. also in battery mode, I can achieve more than only 0,8ghz. and my initial problem with the slowdown on AC every couple of minutes also doesnt occur anymore. thats a big relief! thanks for your time and effort!

w520, i7 2760QM, 16GB Ram, Samsung SSD 830, Win7 64 bit, bios 1.42

Check out current deals!


Shop current deals

Top Kudoed Authors