English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

28 Posts

04-19-2014

Vienna

20 Signins

190 Page Views

  • Posts: 28
  • Registered: ‎04-19-2014
  • Location: Vienna
  • Views: 190
  • Message 1 of 6

W540 Card Reader not working

2014-04-19, 19:24 PM

Hi!

 

 I've a new Thinkpad W540 with Windows 7 64bit. I can't see the Card Reader in the device list. When I insert a SD Card, nothing happens. All I/Os are enabled in the Bios. What can I do? Pls help!

 

Thx

esquire1968

 

Solved! See the solution
Reply
Options

9644 Posts

12-27-2009

CA

3312 Signins

95273 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: CA
  • Views: 95273
  • Message 2 of 6

Re: W540 Card Reader not working

2014-04-20, 23:24 PM
Try installing one of these packages:
http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS038432
http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS039073

One of these should be for your system. The other should complain at install.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U

0 person found this solution to be helpful.

This helped me too

Reply
Options

28 Posts

04-19-2014

Vienna

20 Signins

190 Page Views

  • Posts: 28
  • Registered: ‎04-19-2014
  • Location: Vienna
  • Views: 190
  • Message 3 of 6

Re: W540 Card Reader not working

2014-04-27, 8:17 AM
Thx! It works! The O2micro was the right driver.

Best regards
Reply
Options

4 Posts

05-27-2014

Canada

13 Signins

112 Page Views

  • Posts: 4
  • Registered: ‎05-27-2014
  • Location: Canada
  • Views: 112
  • Message 4 of 6

Re: W540 Card Reader not working

2014-05-27, 2:17 AM
I got some solution , just enter bios > security > I/O Access > "Card Reader" make disable then starup pc , then shut down pc , start up and enter bios again , "Card Reader" enable again . and you try to "Card Reader" ,should works :smileyhappy:

bios ver. = 2.11
"Card Reader" ver. = 1.2.2.1057
Reply
Options

3 Posts

06-04-2016

MX

1 Signins

103 Page Views

  • Posts: 3
  • Registered: ‎06-04-2016
  • Location: MX
  • Views: 103
  • Message 5 of 6

Re: W540 Card Reader not working

2016-06-04, 17:13 PM

Thanks it worked for my w541 (the O2 driver was the one!)

Reply
Options

1 Posts

10-16-2016

US

2 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎10-16-2016
  • Location: US
  • Views: 10
  • Message 6 of 6

Re: W540 Card Reader not working

2016-10-16, 18:51 PM

Thanks!! I can confirm that works!! Just disable the card reader in BIOS, reboot, then re-enable card reader in BIOS, then reboot again. Looks like this is a BIOS issue.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms