Showing results for 
Search instead for 
Do you mean 
Reply
Ctrl-Alt-Del
Posts: 6
Registered: ‎01-20-2014
Location: Switzerland
Message 1 of 7 (12,151 Views)

W540, Disabling Optimus in BIOS/UEFI gone?

In previous version of Thinkpads with a "discrete" and "integrated" graphic card we were able to choose to use only one specific card or let the OS choose.

This options seems to be not available on Thinkpad W540 anymore. And I got troubles to force some applications to use the Nvidia Card so I get crappy performances.

I had the oportunity to test the HP Zbook 15 with the exact same configuration (HD4600 + K2100M 2Go) than the W540. And the Zbook still has this setting in it's firmware.

Anyone with the same problem? Any solution?

I tried many Nvidia Quadro drivers and settings, but no luck.

The program with the most performances issues is Trackmania Nation Forever that I use for benchmarking purpose. I get 110 FPS on W540 and 250 FPS on the Zbook with the Discrete Card forced.

Punch Card
Posts: 48
Registered: ‎11-10-2013
Location: Denver
Message 2 of 7 (12,052 Views)

Re: W540, Disabling Optimus in BIOS/UEFI gone?

Try this setting in the Nvidia control panel.  It's not on the BIOS level, but it seems to work.

 

temp.png

Ctrl-Alt-Del
Posts: 6
Registered: ‎01-20-2014
Location: Switzerland
Message 3 of 7 (12,029 Views)

Re: W540, Disabling Optimus in BIOS/UEFI gone?

Thanks for your help cshen24.

 

I've already tried this but it changes nothing to the frame rate Smiley Sad

Punch Card
Posts: 48
Registered: ‎11-10-2013
Location: Denver
Message 4 of 7 (12,021 Views)

Re: W540, Disabling Optimus in BIOS/UEFI gone?

I'm still new to Optimus myself, so I'm not sure how to properly diagnose these problems.

One last thing you can try, is to enable "Display GPU Activity Icon in Notification Area". Next, explicitly add a profile to the "Program Settings" tab for the app and tell it to use the discrete GPU. I tried an app that defaulted to the integrated GPU even though my base settings said to use the discrete GPU. After adding the profile, the discrete GPU seemed to be activated. You can alt-tab out of the program and verify that the taskbar icon reports the discrete GPU being used.
Punch Card
Posts: 66
Registered: ‎12-30-2011
Location: Miami
Message 5 of 7 (12,002 Views)

Re: W540, Disabling Optimus in BIOS/UEFI gone?

Ah crap, that means it might not be as useful for EGPU connections.  Sigh...

Ctrl-Alt-Del
Posts: 6
Registered: ‎01-20-2014
Location: Switzerland
Message 6 of 7 (11,965 Views)

Re: W540, Disabling Optimus in BIOS/UEFI gone?

Cshen24, you helped me to point something out.

 

I have tried to force the Nvidia GPU but the result was the same, 110FPS.
But this time I forced it to use the Intel HD4600 card and now the frame rate is 73FPS.

 

So, Optimus seems to work. The laptop, by default, was using the nvidia card Smiley Happy Now I just have a problem with the drivers from Nvidia as it should have 250+ FPS.

 

I don't know if I can tell that this topic is SOLVED. Because I still have issue with the performances. And if we want to use a Linux, maybe the missing BIOS parameter is a problem too. But on Windows, Optimis is working well.

Fanfold Paper
Posts: 10
Registered: ‎01-30-2014
Location: USA
Message 7 of 7 (11,945 Views)

Re: W540, Disabling Optimus in BIOS/UEFI gone?

Running linux w/ bumblebee.

I'm woundering if the descrete card is being used for rendering w/ the intel card.

 

The glmark2 score seems a bit high for the intel.

 

glmark2

#glmark2 2>&1 | tee intel.txt
=======================================================
    glmark2 2012.08
=======================================================
    OpenGL Information
    GL_VENDOR:     Intel Open Source Technology Center
    GL_RENDERER:   Mesa DRI Intel(R) Haswell Mobile
    GL_VERSION:    3.0 Mesa 9.2.1
=======================================================
[build] use-vbo=false: FPS: 2199 FrameTime: 0.455 ms
[build] use-vbo=true: FPS: 2455 FrameTime: 0.407 ms
[texture] texture-filter=nearest: FPS: 2585 FrameTime: 0.387 ms
[texture] texture-filter=linear:
=======================================================
                                  glmark2 Score: 2290


 

optirun glmark2 2>&1 | tee intel.txt
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
=======================================================
    glmark2 2012.08
=======================================================
    OpenGL Information
    GL_VENDOR:     NVIDIA Corporation
    GL_RENDERER:   Quadro K2100M/PCIe/SSE2
    GL_VERSION:    4.3.0 NVIDIA 319.60
=======================================================
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
[build] use-vbo=false: FPS: 60 FrameTime: 16.667 ms
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
[build] use-vbo=true: FPS: 60 FrameTime: 16.667 ms
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
[texture] texture-filter=nearest: FPS: 60 FrameTime: 16.667 ms
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
[texture] texture-filter=linear: FPS: 60 FrameTime: 16.667 ms
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
[texture] texture-filter=mipmap: FPS: 60 FrameTime: 16.667 ms
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
[shading] shading=gouraud: FPS: 60 FrameTime: 16.667 ms
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
[shading] shading=blinn-phong-inf: FPS: 61 FrameTime: 16.393 ms
=======================================================
                                  glmark2 Score: 60
=======================================================

 

Top Kudoed Authors