cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Bernardez
Not applicable
Posts: 3
Registered: ‎02-28-2013
Location: NL
Views: 839
Message 1 of 3

W540 GPU K1100m gone after Bios update 2.35

Hello Community,

 

The dedicated graphics chip on my W540 went missing after i had installed the latest Bios: GNET87WW (2.35).

After several days of searching for a solution, I have found nothing besides negative opinions on Nvidia Optimus, and i need your help.

I read that the Intel HD Graphics chip manages all of the display outputs and that the Nvidia chip 'streams' data to the Intel one to send out to a display. Proper installation of the Nvidia Optimus drivers would be to have uninstalled all graphics drivers and to install the latest official Lenovo video driver package (intel + NVidia). However, this did not work for me. The Intel HD graphics installed just fine, the NVidia could not detect the hardware and just stops.

 

When i look into device manager, or 'System information for windows' or 'lspci' on Linux. I never see the Nvidia chip.

There was an hidden entry in the device management for the NVidia chip, but it had an error 45 which meant it had been removed from the system. Uninstalling that device and searching for new hardware did not bring anything at all.

 

On other W540 systems there is an entry in 'lspci' with the following information:

01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev a1)

On my system this is missing.

 

Only the GK107 HDMI audio controller is present but serves no function without the GPU (and driver).

 

Of course, there are options available in the BIOS, I tried different power plans (balanced and high power) for the graphics, and the default and advanced mode for display output, also tried reverting to default settings, but no NVidia controller returned. I also tried to revert to the oldest possible 2.32 Bios. The system restarts to start updating (reverting) but immediately skips the step and launches windows. I also tried a diffrent older graphics driver. 

 

My question is: how is it possible that an bios update disabled (broke?) my graphics? And how can I revert this?

 

ThinkPad W540

M/N: 20BHS1Y200

Windows 10 x64 1704

32GB Ram

i7-4700MQ

plainandsimple
Not applicable
Posts: 6
Registered: ‎12-06-2016
Location: CA
Views: 805
Message 2 of 3

Re: W540 GPU K1100m gone after Bios update 2.35

Have you tried just reverting back to 2.34? I have a W540 and had no issues with the graphics card but had the fingerprint reader vanish on me after the first time going from 2.33 to 2.34. I reverted back one step (which seems permitted by lenovo) and got the fingerprint reader back. A few weeks later I tried the 2.34 update again (Vantage kept bugging me) and this time the fingerprint reader was OK.

Extrapolating from that, you may have to revert one step and install the update again to get your GPU back.

Bernardez
Not applicable
Posts: 3
Registered: ‎02-28-2013
Location: NL
Views: 747
Message 3 of 3

Re: W540 GPU K1100m gone after Bios update 2.35

The Nvidia GPU is working now again. The way it was resolved was a little strange to myself.

 

I describe the 'presumably' cause of my problem for others when they experience the same issue:

 

I had installed Ubuntu 18.04 on my laptop on a diffrent drive, where i had problems getting the nvidia gpu to work because the driver support from Nvidia is poor. What i did was experiment with diffrent drivers, for example, bumblebee.

I think i accedently blocked the PCIe address within the bootloader phase of startup. And because Windows 10 started from the Grub bootloader, the PCIe address was also invisible within Windows 10.

I just dod not notise the gpu whent missing until after i updated the BIOS and tried installing newer Nvidia drivers.

 

After reinstalling Ubuntu 18.04 (and thus a fresh bootloader) the Windows installation detected the K1100M again and the driver installation succeeded.

 

tl;dr:

Do not attempt anything with the Nvidia GPU within Linux.

 

Thanks!

Check out current deals!


Shop current deals

Top Kudoed Authors