cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
k00b
Paper Tape
Posts: 4
Registered: ‎07-15-2018
Location: AT
Views: 1,282
Message 1 of 6

W540 not using all CPU/RAM

I already posted this on gearslutz, but sadly to no avail. The programs i mainly use are DAWs (Digital AUdio Workstations), so basically audio editing.

I consider writing this already a fail, as i really tried hard searching the webz for an answer and wasn't lucky. Feel free to redirect me.

In a nutshell: Years ago (~3) i bought myself a workstation laptop which should work as a beast (by then, still not bad by todays standards imo, specs bellow). Somewhere after the upgrade to Win10Pro i noticed that ProTools as well as Cubase get dropouts and CPU overloads, even when just working with 2 stereotracks (ie deskoutput+roommic) and puting a single (altough probably intensive) Waves plugin at them.
According to both the DAWs performance meters, i'm running out of CPU power/memory.
windows shows me that CPU usage never seems to go over ~30%, more or less same with RAM (see attached pix).
Fun fact: The performance meter in ProTools shows 1 of 8 Cores (4 virtual) basically clipping under all of the load while the others don't seem to have much to do.

I tried everything i found.
Hyperthreading on/off, both pointless.
Cubase as well as PT as well as Win10Pro are all 64bit versions on a 64bit machine.
I tried swapping RAM blocks.
I installed Win10Pro, Cubase 9 and ProTools12(.3.1) from scratch.
All the drivers&updates are up to date via the Lenovo webpage (except the imo unnecessery Lenovo-own software like LenovoPowerManager etc. ... a mistake?).
Win PowerManagement set to 100% all the time on battery&plug.
No difference if using with RME FF UCX or internal ASIO ****tycard.
I did the hardware test with BIOS.
Run Antivirus, first Avira, then the windows-own after the re-install.
I might forgot one or two suggested solutions.

I have the feeling of overlooking something stupidly simple, and it makes me wanna kind of cry. This should still be a proper working horse, instead it behaves like a 12 year old 2nd hand minesweeper machine when running a DAW.

The Computer:
Lenovo ThinkPad w540
Windows 10 Pro 64-bit, 32GB RAM, Intel Core i7 4810MQ, SSD drive
Details:
Intel Core i7 4810MQ
Cores 4
Threads 8
Name Intel Core i7 4810MQ
Code Name Haswell
Package Socket 947 rPGA
Technology 22nm
Specification Intel Core i7-4810MQ CPU @ 2.80GHz

RAM
Memory slots
Total memory slots 4
Used memory slots 4
Free memory slots 0
Memory
Type DDR3
Size 32768 MBytes
Channels # Dual
DRAM Frequency 799.0 MHz
CAS# Latency (CL) 11 clocks
RAS# to CAS# Delay (tRCD) 11 clocks
RAS# Precharge (tRP) 11 clocks
Cycle Time (tRAS) 28 clocks
Command Rate (CR) 2T
Physical Memory
Memory Usage 17 %
Total Physical 32 GB
Available Physical 26 GB
Total Virtual 36 GB
Available Virtual 31 GB
Motherboard
Manufacturer LENOVO
Model 20BHS2N900 (CPU Socket - U3E1)
Version 0B98417 PRO
Chipset Vendor Intel
Chipset Model Haswell
Chipset Revision 06
Southbridge Vendor Intel
Southbridge Model QM87
Southbridge Revision C1
BIOS
Brand LENOVO
Version GNET87WW (2.35 )
Date 4/9/2018
Hard drives
Samsung SSD 840 Series (SSD)
Manufacturer SAMSUNG
Heads 16
Cylinders 60,801
Tracks 15,504,255
Sectors 976,768,065
SATA type SATA-III 6.0Gb/s
Device type Fixed
ATA Standard ACS2
Serial Number S14NNEAD101678P
Firmware Version Number DXT07B0Q
LBA Size 48-bit LBA
Power On Count 7916 times
Power On Time 481.0 days
Speed Not used (SSD Drive)
Features S.M.A.R.T., NCQ, TRIM, SSD
Max. Transfer Mode SATA III 6.0Gb/s
Used Transfer Mode SATA III 6.0Gb/s
Interface SATA
Capacity 465 GB
Real size 500,107,862,016 bytes
RAID Type None

just realized that my cores' temperatures oscillate between 70-90°C, Speccy already marks this red. how bad is that really? in my logic it shouldn't put 3 out of 4 cores out of order everytime i start a DAW.

This is just some of the specs "Speccy" gave me, i will gladly post more into-detail stuff if you point me in the right direction. I might crosspost this to some lenovo/thinkpad forum, just thought someone here might know why this is happening, since it's mostly with audio.

Any help will be very appreciated and, given the option, rewarded with adequate amounts of beer should you drop by in vienna some day.

cubase lag1.pngcubase lag 2.pnglatencyMon.png
Community SeniorMod
Community SeniorMod
Posts: 3,419
Registered: ‎12-01-2007
Location: US
Views: 1,239
Message 2 of 6

Re: W540 not using all CPU/RAM

Hello,

 

I noticed that the ThinkPad W540 has a Samsung 840 SSD installed in it.  This generation of SSDs had a lot of "pausing" type problems that were eventually fixed in firmware.  You may wish to check to see if the latest firmware is installed.

 

As far as the Lenovo's drivers go, I would suggest installing them.  Otherwise, you end up running Microsoft Windows' own generic drivers, which usually do not perform nearly as well as those made for the device.

 

Regards,

 

Aryeh Goretsky

 



I am a volunteer and neither a Lenovo nor a Microsoft employee.

L380 YogaP72 (20MB-*)P50 (20EN-*)S230u (3347-4HU)T23 (2648-LU7)T42 (2378-R4U)T43p (2678-H7U)T61p (6459-CTO)W510 (4318-CTO)W530 (2441-4R3)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)X220 (4286-CTO)X250 (20CM-*)Yoga 370

  Communities:   English    Deutsche    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Język Polski    Moto English

k00b
Paper Tape
Posts: 4
Registered: ‎07-15-2018
Location: AT
Views: 1,216
Message 3 of 6

Re: W540 not using all CPU/RAM

thank you very much for the response!

indeed my SSD wasn't fitted with the actual firmware, didn't knew this issue existed. unfortunately, the update did not help. according to the perfomance meter in cubase the diskusage seems to be no problem at all, it must have something to do with the CPU and/or RAM, altough i kind of suspect the CPU lately, since that was what ProTools showed me (just one of 8 [4 real 4 virtual, hyperthreading) cores "clips").

cubase lag3.png

i did indeed install all of the lenovo drivers trough the lenovo homepage, even with this lenovo-service-bridge thing. what i did NOT install is things i always considered bloatware, like the power manager, the WiFi/Network tool (whatever its name is) and things alike. things that windows already has tools for, where i don't need them a second time.

 

so, at the moment, the service-bridge suggests:

1, [CRITICAL] ThinkPad Video Features (NVIDIA GT 720M/730M, Quadro K1100M/K2100M Optimus) - 10

2, [SUGGESTED] ThinkPad Hotkey Features Integration Package Setup - 10

3, [OPTIONAL] Intel Management Engine 11.6 Software - 8/8.1/10

4, [OPTIONAL] Integrated Camera Driver for Sunplus - 7 /8.1/10

 

From what i understand and researched, none of these should have an impact on the actual CPU, if, then propbably the intel management thing, which is "optional". am i wrong?

thank you very much for your time. i might just try these anyway since i don't really see any other way at the moment.

k00b
Paper Tape
Posts: 4
Registered: ‎07-15-2018
Location: AT
Views: 1,072
Message 4 of 6

Re: W540 not using all CPU/RAM

it's emberassing to stumble upon ones own posts while still trying to look for the solution to the same problem. i always hated when people were doing this bump, but i'm really _really_ desperate here.

 

isn't there anybody who could at least pomit me somewhere other then "go buy something else"? because i am afraid that's gonna happen soon. and i honestly wanted to like lenovos ThinkPads.

pjg
802.11n
Posts: 205
Registered: ‎05-30-2009
Location: CA
Views: 1,065
Message 5 of 6

Re: W540 not using all CPU/RAM

Hey.  I had a W541 which always worked well.  Here's what I would suggest:

 

1) Make sure you have ALL the latest drivers from LENOVO. Not the default drivers from the Windows 10 install.  When i install a fresh Windows 10 (not upgrade), I make sure I am not connected to any network. Install Windows 10 (and don't connect WiFi during install). Then post install, install ALL W540 drivers from Lenovo's web site. Reboot and THEN let Windows 10 install anything else it wants. This way, i know I am getting the drivers as recommended by Lenovo

 

2) Try installing the Intel Extreme Tuning Utility.  I use it to get better data from the processor. On my new P52, there is a weird bug that sometimes when I boot, the Max Core Frequency doesn't go above 1 GHz. So I then know why my laptop is slow. 

 

Intel Extreme Tuning Utility

 

3) As suggested, install Samsung's Magician software to ensure that you have the latest firmware on the device.

 

4) Do not install any type of caching software or Lenovo Active Protection.  That is useless with an SSD

 

5) Use Mark Russinovich's Autoruns software to enumerate all software that loads up with Windows. YOu can see what runs at Startup, Services, Devices, etc.  You can easily disable any item without deleting it permanently.

 

SysInternals AUTORUNS

 

Give those things a try

k00b
Paper Tape
Posts: 4
Registered: ‎07-15-2018
Location: AT
Views: 1,027
Message 6 of 6

[SOLVED] W540 not using all CPU/RAM

first of all, thanks for the reply. the Samsung SSD was already updated. the Intel Tuning Utility is actually a neat piece of software, altough i'm rather afraid of touching anything there.

anyway, while i was talking to a friend of mine, i mentioned that said Intel Utility is showing me spikes of rising temperature up to ~95°C, when the CPU starts its throtteling.

...well...

 

turns out, when i cleaned my the cooling fan assembly (probably more than a year ago), i kind of didn't apply new thermal compound. naive-me just did not realize how important this souce is.

 

i just did an hour ago. so far, everything that used to stutter before now runs smoothly and i seldomly hear the fan. so far.

 

may this help anyone who also stucks with a CPU which should perform much better but doesn't.. check your temperature & cooling assembly.

 

and thank you very much for the advice, nevertheless Smiley Happy

Check out current deals!


Shop current deals

Top Kudoed Authors