cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sdu
Not applicable
Posts: 15
Registered: ‎06-09-2015
Location: Belgium
Views: 1,670
Message 21 of 30

Re: W550s: horrible performance

Hi,

Try disable power management in the bios and uninstall power management and active protection.

I do that and the system is better

Still some lags but only when CPU is high used, after some time it come back to normal.

But if you have the option to return this notebook, don't hesitate

 

soymilk69
Not applicable
Posts: 8
Registered: ‎09-06-2015
Location: USA
Views: 1,667
Message 22 of 30

Re: W550s: horrible performance

thank you for your advice.

it seems best option is return the machine and wait again.
soymilk69
Not applicable
Posts: 8
Registered: ‎09-06-2015
Location: USA
Views: 1,658
Message 23 of 30

Re: W550s: horrible performance

I believe the cause of my issues are from a lack of RAM. I underestimated the average activity level of my usage and will have to upgrade.

I want to add two 16 gigs, is this overkill? I read the cpu maxes out at 26 or something.

Lastly, I believe the audio problem is not solvable but it is quite minor.
khoanguyen
Not applicable
Posts: 1
Registered: ‎03-18-2016
Location: Canada
Views: 1,308
Message 24 of 30

Re: W550s: horrible performance

I bought Thinkpad W550s I7 550U RAM 12G, 500G, last month and got the same problem like you, which makes me disappointed on Lenovo Thankpad version as just updated from X220. I had tried to get lastest update from Lenovo, and even Intel, but it did not work. Followed some extended installations, and especially disabled "intelligent cooling" technology, now it is quite getting better performance. Let check more few days to make sure that it will be caused by such "INTELLIGENT" defined by softtech effect. 

Running on Windows 10 newest update. 

Intelligent coolling can be disabled from Lenovo Setting -> Power tab -> Intelligent Cooling -> OFF. 

 

  

rfog
Not applicable
Posts: 3
Registered: ‎04-18-2016
Location: NL
Views: 983
Message 25 of 30

Re: W550s: horrible performance

Last week I got a BIOS update when run the Lenovo System Update app and the problem dissapeard. I had it since updated to Windows 10.

 

This problem is called "throttling" and is a common problem with last Intel Processors that happens in a lot of systems. Even the acclaimed Surface Pro 4 had it and took half a year to be resolved by Microsoft (after a lot of people started a collective demand).

he-mobile
Not applicable
Posts: 4
Registered: ‎04-15-2017
Location: DE
Views: 953
Message 26 of 30

Re: W550s: horrible performance

This is strange but I noticed a better performance with the balanced plan with everything to the max when plugged in then with the high performance plan and everything to the max.

 

With high performance when the cpu has nothing to do, the clock shows 2.90 GHz and dropps to 2.70 GHz when it actually does something!

 

With the balanced plan it dropps down to 0.70 GHz but raises up to 2.90 GHz under much load. Unbelivable ;-\

GiacomoCiani
Not applicable
Posts: 1
Registered: ‎06-20-2017
Location: US
Views: 854
Message 27 of 30

Re: W550s: horrible performance

Not sure if this helps, but I'd like to share my experiences (both with solution... so keep reading). You are warned: it's a bit long... :-)

 

My config:

- i7-5600U

- 16 Gb RAM

- SSD (system) + HDD (storage)

- Windows 10 Pro

 

First, a while ago I had an issue which would make the processor for some reason stuck at a throttling level well below 100% (something around 1 GHz) when I resumed from sleep. It wouldn't happen 100% of the times, but very very often (I'd say 80%). It was easy to recognize this situation because the CPU load would saturate at the maximum possible value for the throttled frequency (which was around 30%) every time the PC was doing something moderately intensive (and mind you, for some reason my Windows installation always runs a few seconds of very intensive CPU load when it resumes from sleeping... when the issue occurred, those become tens of seconds at maximum, albeit throttled, CPU load, making the pc almost unusable for quite a while).

My solution was to install an utility called throttlestop which has a 1000 options of which I only understand 1%. However, fiddling with the different preconfigured modes was usually enough to "unlock" the throttling and bring the pc back to normal operation. Interestingly, two or three months after the issue started, it spontaneously disappeared. I suspect it was due to some system update, although the fact that I was using throttlestop, thus mitingating the issue, prevented me to spot the exact moment in which the issue disappeared.

 

The second experience is more recent. All of a sudden I noticed my pc being very slow. Unfortunately I wasn't able to indentify what started it. In part this was due to the fact that the symptoms, although equally devastating in terms of performance, were a bit more subtle that in the previous case. Looking at the CPU usage woudln't necessarily indicate something strange, as the CPU load was high on average, but fluctuating quite rapidly, as it always happens when you have a lot of things going on (rather than a single thread sucking up all your computing power). Throttlestop, via a sub-program called LimitReason, gave me a hint that something was triggering throttling very frequently (as opposed as constantly n the previous case), but lack of documentation for limitreasons made it difficult to identify what.

Long story short, I ended up installing the Intel Extreme Tuning Utility (XTU), which clearly indicated that my system was throttling for excessive power very often. Observing the behavior for a while, I noticed that the system woudl never allow the package TDP to go above 7 W, while my processor is designed for 15 W. Interestingly, XTU indicated that the currently set TDP limit was 15 W, and fiddling with the windows power profile did not make any difference.

Eventually, I realized that by changing the value to whatever in XTU and then putting it back to 15 W would solve the issue. Unfortunately, the setting would not survive a reboot, and sometimes not even a sleep cycle. But modifying the settings in XTU was quick enough to be considered a usable workaround. By fiddling here and there I finally managed to make the setting stick. I suspect intelligent cooling in the Lenovo Settings app (which was reported as disabled, but maybe stuck in some strange state, as I would never hear the fan go off at max speed) was part of the issue. Again, changing and resetting the setting eventually made the power limit stick.

 

Currently my system runs fine and is very responsive. Under high CPU load, after a few seconds the fan goes to full speed and the processor is throttled back a bit (just a bit), but this is normal. Before trying XTU, I had tried to disable all CPU throttling in the attempt of solving the issue, and I haven't restored most of the settings. Run time on battery seems to have suffered a bit (maybe -20%?). Further fiddling could (should!) make possible to define a state in whcih the CPU is more agressively throttled while on battery, and basically not throttled while plugged in, but I haven't had time to expeirment. Since 90% of my usage is while plugged in, I don't care too much.

ColonelONeill
Not applicable
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 826
Message 28 of 30

Re: W550s: horrible performance

On my W550s, this is caused by the new-fangled "Cool Mode" when it tries to automatically detect if the laptop is being used on a lap. Unfortunately, this is sensitive enough to be tripped by typing while on a table, so it had to be disabled in Power Manager (Windows 7).

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
he-mobile
Not applicable
Posts: 4
Registered: ‎04-15-2017
Location: DE
Views: 789
Message 29 of 30

Re: W550s: horrible performance

I've found another way for improving the performance. You need to reduce the amount of virtual memory, this is the paging file. I have 16gb RAM and my paging file was 8gb, I reduced it to 2905 as my Windows 10 pro recommended and there is no scroll-lag in opera, websites open nearly instantly and the applications start immediately. Checking for updates in windows now only takes a few seconds (before it was a few minutes) It feels as if I had a new notebook Smiley SurprisedSmiley Wink

 

Go to

 

> Control Panel

> System and Security

> System

> Advanced system Settings (on the left)

> Advanced tab

> Performance group > Settings > Advanced (again)

> Change

 

Set the paging file to "Custom size" to whatever is Recommended by your system. Press "Set", restart the system and enjoy :-)

 

s1rM0xl

 

I've found it on reddit. see this link: https://www.reddit.com/r/Windows10/comments/3fm7m8/windows_10_is_very_laggy_and_slow_after_the_updat...

Highlighted
matthias_
Not applicable
Posts: 6
Registered: ‎12-12-2017
Location: DE
Views: 137
Message 30 of 30

Re: W550s: horrible performance

Thank you so much @sdu! You gave the hint to the solution that works for me Smiley Very Happy Smiley Very Happy Smiley Very Happy

I have been messing around with extremely slow CPU performance after every hibernation startup - I almost couldn't move my mouse sometimes and it took me about 2 minutes to open the Power Manager.

I identified this using "Throttle stop" which shows the limits and the task manger showed almost constantly 100% while power manager capped the CPU speed at 40-60 %.

 

What worked for me (Lenovo W550s Win7 Home Premium 64bit SP1) is very simple:

- open the "Active Protection System"

- click the "intelligent cooling" tab

- disable "enable intelligent cooling"

 

Disable it, it is not intelligent, it's stupid - it's a trap Smiley Wink

 

Before I realized this was the problem I found a workaround. If the proposed solution doesn't work, this might be a pretty annoying, though life-saving workaround:

- every time your CPU throttles, open the power manager

- click on "Advanced" button

- in the active mode (maximum performance or video playback in my case), extend the system settings and select "Turbo" for maximum CPU speed (even if maximum Turbo was selected previously).

- click apply

- then, select "Maximum Turbo" for maximum CPU speed again

- click apply

- CPU speed will go up on 100 % immediately and CPU load will drop to < 30 % or so

Check out current deals!


Shop current deals

Top Kudoed Authors