cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jchorn
Fanfold Paper
Posts: 5
Registered: ‎01-20-2010
Location: Portland, Oregon
Views: 741
Message 1 of 3

W700 Raid disk0 Error Occurred

I'm running a Raid1 (mirrored) setup preinstalled from the factory on two 320gb drives. W700-2757

 

The System event log showed an event 9 iaStor on disk0 of my raid, a timeout error.

 

The drive was automatically disabled but I had to reboot to get the system running smoothly again on a single drive.

 

Raid technology has delivered for me! There's a problem in the driver software or bios somewhere that still needs to be fixed. I called Lenovo, they sent me a new disk, I plugged it in and during the disk rebuild process, got the same error again. It was too easy. I called Lenovo again, got escalated. My Bios and drivers were out of date, no idea why, the Lenovo Update service isn't working prefectly yet for Windows 7 I guess. I updated:

BIOS (BIOS Update Utility for 64-bit Windows) 2.09-1.07

Intel Matrix Storage Console with Device Driver version 8.9.2.1002  

Intel Turbo Memory Driver version 1.10.1.1002-8.9.2.1002
Updates in that order (it's important).
 
So with updates installed, I went in to the Intel Matrix Console, (advanced mode) right clicked on the error'd drive to enable it again and rebooted so the drive would get automatically rebuilt once windows came up. All was a happy world until  67% into the rebuild process when the drive error'd again. I was too optimistic about the stability of the rebuild software as I also was doing Internet stuff and had a screen saver operational during the rebuild process. So, a little frustrated, I went and played my favorite MMORPG game for a couple of hours and just before bed time, I tried again. This time I disabled my screen saver, went into the matrix console and reenabled the drive, then rebooted. After about 3 hours of sleep, I awoke to find that the rebuild was going smoothly and I was at about 65%. I watched it rebuild until it was 100% and now all is well again in the world. The day after, I decided to look around in the matrix console and right clicked on the OEMRaid1 and noticed that my volume writeback cache was disabled. I enabled it and that's where I am today, all is well again.
 
It is important to note that during this whole episode I could use my computer in every way for everything I wanted.
 
I don't believe that the software updates completely fixed the problem because I saw the problem after the new updates were installed.
Question: When the timeout error occurred system performance was horrible *after* the disk was disabled.
                   Is there a way to decrease/ignore the error timeouts from the bad drive after it is disabled?
schmidtj
802.11n
Posts: 163
Registered: ‎01-29-2009
Location: US
Views: 719
Message 2 of 3

Re: W700 Raid disk0 Error Occurred

Enabling the Write Back Cache can cause you more problems if you suffer an OS failure. Leave it disabled. That's why it is disabled by default. You want the Write Through cache enabled but not the write back cache.

jchorn
Fanfold Paper
Posts: 5
Registered: ‎01-20-2010
Location: Portland, Oregon
Views: 697
Message 3 of 3

Re: W700 Raid disk0 Error Occurred

Thanks, Writeback cache disabled! I was a little disappointed that the sector size was only 512 bytes. On a 64 bit machine one would think that a 1 or 2k sector size would be a more appropriate choice for a default on a disk subsystem that has a data cache. Or is this just because the NTFS hasn't been improved?

Check out current deals!


Shop current deals

Top Kudoed Authors