cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kiig
Paper Tape
Posts: 4
Registered: ‎08-20-2009
Location: Denmark
Views: 1,609
Message 1 of 2

W700DS Raid 0: Error occured(0) on one of my discs.

Hi all. I discovered that my ICH9M raid controller claimed my raid 0 was in good condition, - but one of my discs was noted in red (just after bios post), - and it said "Error occured(0)".

After my adrenalive levels got down a bit, - I tried to continue to boot, - and it worked !.... so I backed everything up, - ordered a huge external disc, - just to be on the safe side for the future, and started wondering what had happened, - and wondered if I could find all my install discs as I thought my computer was in for a reinstall.

 

the following is a quick walkthrough of what I did, - not to ask questions really, - but I found very little information about this error on he internet, - so I thought I at least would contribute.

 

Feel free to laugh or use it as apropriate....

 

I called Lenovo tech Support...

"Hullo, - how can I help you"... oh, yeah, - I have a problem with my harddrives.."yeah?"... yeah, - it reports 'error occured' but my drive seemed to work just fine, - I can boot fine .. "ok...."... on my raid... "..oh.. did you say Raid ?",, yes I did... "Did you infact, Sir, - say Raid ?", - Erm, - yeah, - I'm running a striped Raid 0 on two 320 Gb. drives..."ok, - we have no experience with Raid, - so we can't help you"... ermm are you telling me I can get no support whatsoever on my new Lenovo W700DS just because it's running in a raid?.. "well, I have no experience with raid, - so no, - I can't help you."... but.... "Should you discover that one of the physical discs fail, - feel free to call us again, - and this time ! provide us with your modelnumber and serial, - have a nice day"....

Well, - sort of like that, - not very promising.

 

As the computer works, - I thought it could be the SMART counters, - but after some investigation I realised that when running a Raid, - the SMART counters per drive can't easily be 'read', - or something, - any way, - I downloaded Harddrive toolbox from Lenovo, - changed the Bios setting from Raid to AHCI and booted the USB stick the toolbox software prepared. Both drives came through error-free. (I haven't tried the 'test' in Raid mode, - but I assume it wont work as it doesn't see the 'drives' but the logical disk, - spanned by the raid.)

 

anyway, - wondering if I should trim my partition, - backup it up to the external drive, - and rebuild everything using a mirror (raid 1) instead, - i noticed a post regarding "frosen computers and shutdowns, -and subsequent errors".. thinking back It did actually freeze on me the day before, - and I had to hold the power-button down to kill it... maybe I just hadn't noticed the error before.... and the post continued talking about "marking the discs in a raid as "normal" "... so, - instead of formatting everything while grinding my teeth, - it thought I might as well try it.... found the correct Intel Storage Manager software from Intel, - and as soon as I installed it, - it reported "one of your drives are failing" in the taskbar... Huh.. ?

 

Well, - it said nothing more than that, - no logs or anything, - but I ended up thinking that If I killed the power, - it might have registered an error while reading or writing to the disc, - and have raised the 'error' just in case.

 

I right clicked the physical drive, -and selected "Mark as normal", - and the error went away.

 

Reboot, - still no error, - checked the entire disc with a standard windows error check, - still nothing wrong.

 

so I think, - the freeze caused the controller to 'record' the error, - and my subsequent tests have shown that there are no errors on the discs.

 

So should you ever see this error, - don't panic, - it's not allways as bad as you think, - and the second most important thing to remember, - don't panic !.... :-) trying to change the raid0 to a raid1 would probably not have been a good idea at this stage though I did fint posts about that.... changing the raid level, - while unplugging the drives... uhm, - sort of glad I didn't just do it, - but waited, -and researched some more .

 

and if your system works, - install the intel storage manager and see what it reports, - the above shows it's helpfull.

 

and above all, - backup your important stuff... eventually something WILL go wrong and you will LOOSE data. A backup will not stop this from happening, - but it will help you recover :-)

 

I have 20+ years experience with anything from laptops to mainframes and clustered environments, - eventually, - you _will_loose_data.

 

and why am I running a raid 0 then, -and not raid 1 ? well, - I need performance on this particular computer, - thats why, - but my backup plan is somewhat over the top to compensate for that.

 

My important stuff get's backed up daily to an external mirrored harddrive (raid 1), - when I archive something, it goes to external harddrives (not raid, - but 2 physical drives), - so I have one 'archive' disc here in the office, - and the other in a remote location.

 

and everything on the archive drives, - and on my external mirrored drive, - are replicated to my Raid 5 NAS storage as well. Should be safe enough :-)

 

 

 

 

Kim Igel.

 

 

 

 

jchorn
Fanfold Paper
Posts: 5
Registered: ‎01-20-2010
Location: Portland, Oregon
Views: 1,445
Message 2 of 2

Re: W700DS Raid 0: Error occured(0) on one of my discs.

Most of Raid technology is new to most tech support line people. They know the basics but probably don't know the difference between striped and mirrored disk setups, it's just not a technology in common use yet.

 

Unlike you, I'm running a Raid1 (mirrored) setup preinstalled from the factory on two 320gb drives. I wanted Raid1 for data integraty and uptime, not for speed. Two months after purchasing it, I got this same failure on my W700. The technology has delivered for me, you just got lucky. As it turns out, there's a problem in the driver software or bios somewhere that still needs to be fixed. I called Lenovo, they sent me a new disk, I plugged it in and during the disk rebuild process, got the same error again. It was too easy. I called Lenovo again, got escalated. My Bios and drivers were out of date, no idea why, the Lenovo Update service isn't working prefectly yet for Windows 7 I guess. I updated:

BIOS (BIOS Update Utility for 64-bit Windows)

Intel Matrix Storage Console with Device Driver

Intel Turbo Memory Driver
Updates in that order, it's important.
So with updates installed, I went in to the Intel Matrix Console, (advanced mode) right clicked on the error'd drive to enable it again and rebooted so the drive would get automatically rebuilt once windows came up. All was a happy world until  67% into the rebuild process when the drive error'd again. I was too optimistic about the stability of the rebuild software as I also was doing Internet stuff and had a screen saver operational during the rebuild process. So, a little frustrated, I went and played my favorite MMORPG game for a couple of hours and just before bed time, I tried again. This time I disabled my screen saver, went into the matrix console and reenabled the drive, then rebooted. After about 3 hours of sleep, I awoke to find that the rebuild was going smoothly and I was at about 65%. I watched it rebuild until it was 100% and now all is well again in the world. The day after, I decided to look around in the matrix console and right clicked on the OEMRaid1 and noticed that my volume writeback cache was disabled. I enabled it and that's where I am today, all is well again.
It is important to note that during this whole episode I could use my computer in every way for everything I wanted.

Check out current deals!


Shop current deals

Top Kudoed Authors