cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
FCrites
Paper Tape
Posts: 3
Registered: ‎01-26-2011
Location: USA
Views: 3,222
Message 1 of 7

error 2100 with SSD

Can anyone provide a solution to the error 2100 on boot with SSD's? Mine is a Crucial C300 128gb and I cannot even load the OS yet.

 Running latest BIOS  on laptop and the SSD is the latest firmware (currently ver 6).  I was able to see the drive and partition using a USB3 HDD external case. After placing drive in primary HDD0  was only able to "see" the drive if I set the BIOS sata to "compatibility mode"

Drive passed all the BIOS tests while in "compatibility mode" but OS install still does not complete. If BIOS is set to AHCI mode (which is the correct setting for SSD’s) the W510 boots to an error 2100 and does not recognize the drive.

 

Thanks for any help provided!

ThorsHammer
Bit Torrent
Posts: 2,423
Registered: ‎04-08-2011
Location: US
Views: 3,209
Message 2 of 7

Re: error 2100 with SSD

Where is the C300 in the boot list when looking at startup in the BIOS?

 

FYI, my T410s works fine with it's C300 so I have no doubt you can get this resolved.

FCrites
Paper Tape
Posts: 3
Registered: ‎01-26-2011
Location: USA
Views: 3,205
Message 3 of 7

Re: error 2100 with SSD

Thanks for responding!

 

First boot device is DVD, second is HDD when I have the standard seagate 320 HDD in HDD0  it all works fine. When SSD is in, 2100 error hits. THe best I ever got was compat mode and 10%  of install then failed.

 

 

FCrites
Paper Tape
Posts: 3
Registered: ‎01-26-2011
Location: USA
Views: 3,158
Message 4 of 7

Re: error 2100 with SSD

I opened a ticket with Lenovo. (spoke to first level tech) Was told that since I did not buy SSD from Lenovo and that my original HHD worked I get no support. (surprise). When I said that the SSD loaded fine on a Dell Latitude, reponse was same. Lenovo position is if not from lenovo (no support).

Update: I placed the w510 in diagnostics boot mode. This give a little more time for the hardware to examine itself.

I was able to load the OS finally.

 

 Now I only get a 2100 error 50% of time from cold boot, when cold boot error occurs a 3 finger salute usually brings it right in to os now. When I perform a warm reboot from OS about 25% of time I get the 2100 error. It really is a shame that Lenovo will not even try to resolve this.

 

FYI for those that suggested the firmware fix from Lenovo, that only supports a limited list of SSD's (probably only the ones they sell directly) and not the Crucial C300

 

What I am now asking of the forum community is: anyone running a c300 on a W510 4810 w/o the boot error?

 

Thanks

wditters
802.11n
Posts: 189
Registered: ‎07-30-2009
Location: NL
Views: 3,145
Message 5 of 7

Re: error 2100 with SSD

Crucial C300 SSD's are known for this. Prior to the boot there's a startup check in the SSD's PCB, a sort of self-check. That one is prone to failure in the Crucial SSD disks. I experienced it twice but thankfully was able to recover from it. This happened with the lastest firmware version 00006.

 

Aside from that, the Cucial seems a bit flaky on sata3 as well. I would suggest return the C300, or if impossible, ditch it on eBay or so, and get an Intel 510 or an OWC. I did so and never looked back. (The OCZ Vertex 3 currently are suffering from bad production batches, hence the shortage, I have a good one, but for now I'd stay clear of them)

Lenovo Premium Business Partner
X1 Tablet 3rd gen | i7-8650U | 16Gb | 1Tb | WWAN | W10 Pro x64 | Thunderbolt 3 Dock
nu-lenovo
What's DOS?
Posts: 1
Registered: ‎03-25-2012
Location: Canada
Views: 2,676
Message 6 of 7

Re: error 2100 with SSD

shame on Lenov, as they sent a used hadd to replace my damaged hdd in new T420s.  did they ever state in the service agreement that they can do so?  Please do not support lenovo.  This is my first and last notebook from them

 

BTW, i just got oCA vertex 3 240 ssd, to my suprise, first it is a little too big for the slot.  Anyway I managed it in.  However, when the system started up, it does not recognize the ssd, showed the same error 2100, hadd initilization error.  I chekced with other computer with the ssd, it works perfect fine.  Worst was that I called lenovo technical support to ask which brand and type of ssd I should purchase to replace the hdd in order to improve the hdd failure chances.  they said that you shall know it well if you want to replace it.  Then, I bought oca vertex 3, it does not work with T420s at all.  what a shame.  we shall let more people know that lenovo support is suck.  

 

Guru
Posts: 1,756
Registered: ‎04-20-2008
Location: US
Views: 2,672
Message 7 of 7

Re: error 2100 with SSD

Yes, your service agreement says that parts can be replaced with new or serviceable parts. Replacing parts with "serviceable" parts has been common for years. Usually, the parts are actually unused, but if it had been returned, it must get an orange "refurbished" sticker.

 

The T420s primary HDD slot is for 7mm drives. SSDs are either 7mm or 9.5mm. Some come with removable shims to allow them to fit in the 7mm slots.  The Ultrabay can handle 9.5mm SSD or HDD. People have reported that Intel and Samsung SSD units work without difficulty (with the exception of the Intel 510 which needs a soon to be released BIOS fix).


P70 XEON 1505, BIOS 2.28, UHD 4k Display, 64GB non-ECC RAM, M3000M NVIDIA GPU, RAID 1 512GB Samsung 951 PCIe-NVMe SSD x 2, 2x Samsung 850 Pro 1TB SSD. EM7455 WWAN
P1. BIOS 1.18,Xeon Processor, 32GB, PM981 1TB x 2, RAID 1
T460s, BIOS 1.20, WQHD display, 20GB RAM, I7-6600U, Samsung PM961 1TB PCIe-NVMe SSD, EM7455 WWAN
T470s, 16GB RAM, BIOS 1.10, i7-7500, WQHD display, 512GB PM961 PCIe NVMe SSD

Check out current deals!


Shop current deals

Top Kudoed Authors