Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

9 Posts

12-05-2011

Germany

5 Signins

39 Page Views

  • Posts: 9
  • Registered: ‎12-05-2011
  • Location: Germany
  • Views: 39
  • Message 1 of 36

w520 bad sound quality and audio glitches with current conexant driver

2011-12-05, 16:08 PM

Hi guys,

 

I have to cope with several audio problems. Before any changes I had a lot of audio glitches while playing MP3s, viewing videos etc. The sound playback hangs from time to time and gives me error sounds (glitches, where some samples are played repeatedly).

 

Then I read that removing the conexant driver and using the windows 7 drivers works better. And they did. I deinstalled the conexant drivers and immedeately win7 installed some standard drivers. Then nearly all errors and glitches were gone. But I could not use my docking station anymore. :(

 

Ok, now I installed the latest conexant drivers for windows 7, the problem are less than with the old conexant drivers, but still way worse that the microsoft windows 7 drivers.

 

These problems seem to be related to network usage. I think they appear much more often, if I am plugged into my LAN or surfing the internet. This happens when using LAN or WLAN.

 

Further the signal to noise ratio is very poor. If I crank up my speakers there are several "sounds" when using the W520, internet access, hd access etc. can all be "heard"...

 

Has anyone experienced the same? I spent a lot of time working on this problem. Why couldn't lenovo put a decent soundcard into the W520? This really gets on my nerves. Any help is highly appreciated.

 

Cheers,

Marcus

Reply
Answer
Options

73 Posts

10-18-2011

United States of America

185 Signins

2003 Page Views

  • Posts: 73
  • Registered: ‎10-18-2011
  • Location: United States of America
  • Views: 2003

Re: w520 bad sound quality and audio glitches with current conexant driver

2013-07-23, 4:35 AM

This unofficial driver package KICKS SOME MAJOR @$$ on Win 8 x64.

 

Yep, sounds pretty full and loud (even at 40%), esp. when playing soundtracks. I had pretty good VOIP with Skype too. Good instructions too (one thing that should be added is that Windows 8 users have to reboot in advanced mode, selecting 'Disable driver signature enforcement'.

 

Now, if we can just make that 170W power supply a wee bit smaller and lighter for traveling.

 

 

 

T450 | W520 | Moto G4
Reply

Replies(35)
Options

1597 Posts

05-29-2010

Singapore

2878 Signins

59007 Page Views

  • Posts: 1597
  • Registered: ‎05-29-2010
  • Location: Singapore
  • Views: 59007
  • Message 2 of 36

Re: w520 bad sound quality and audio glitches with current conexant driver

2011-12-05, 17:32 PM

Hi marmuw520

1. You could either try Dolby driver or something. For me, I have less or even no glitches compared to Conexant. I can't promise anything, but you can try. Mileage vary.


Dolby drivers: 
Under "Simplifications of installing and optimizing Dolby Home Theater v4" Topic: 

http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/W520-Sound-Enhancement-Thread/td-p/442761/page/8

Sound tweaks setting (ThinkMix v2): (Attachment in Message 120)
http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/W520-Sound-Enhancement-Thread/td-p/442761/page/12 

 

2. Intel NIC Card configuration 
This workaround should resolve the issues.
Large Send Offload (IPv6): Disabled 

TCP Checksum Offload (IPv6): Disabled

UDP Checksum Offload (IPv6): Disabled
 
Currently, other manufacturer with Intel NIC card have this issues too, therefore it's not Lenovo's fault. We (Manufacturer and End-User) are still waiting for a solution I guess.

Cheers :smileyvery-happy:

Peter
(Current: W520 4284-A99) (Refunded: W510 4876-A11)

=============================================

Does someone’s post help you? Give them kudos as a reward, as they will do better to improve :smileyvery-happy:

Mark it as solved if the solution works for you, so it could be reference for others in the future :smileyvery-happy:

 

Dolby Home Theater v4 (ThinkMix V2)!

http://forums.lenovo.com/t5/W-Series-ThinkPad-Lapt​ops/W520-Sound-Enhancement-Thread/m-p/451401#M155...  

Reply
Options

9 Posts

12-05-2011

Germany

5 Signins

39 Page Views

  • Posts: 9
  • Registered: ‎12-05-2011
  • Location: Germany
  • Views: 39
  • Message 3 of 36

Re: w520 bad sound quality and audio glitches with current conexant driver

2011-12-14, 11:32 AM

1.

I didn't try the dolby drivers yet, since I think I'll have problem with my docking station again. As described above...

I am looking at the Sound tweaks setting stuff right now

 

2.

Intel NIC Card configuration 
This workaround should resolve the issues.
Large Send Offload (IPv6): Disabled 

TCP Checksum Offload (IPv6): Disabled

UDP Checksum Offload (IPv6): Disabled

 

this doen't help at all... :(

 

Any more hints on how to get a decent glitch free sound on the W520?

 

Cheers,

Marcus

Reply
Options

1597 Posts

05-29-2010

Singapore

2878 Signins

59007 Page Views

  • Posts: 1597
  • Registered: ‎05-29-2010
  • Location: Singapore
  • Views: 59007
  • Message 4 of 36

Re: w520 bad sound quality and audio glitches with current conexant driver

2011-12-14, 12:43 PM

Hi marmuw520

 

How about disable CPU management as last resort? To see if it resolves the problem.

If not, contact Lenovo Support. I think cpu or system board (part of the components) is faulty. For me, I disabled Nvidia and choose Integrated Graphic in BIOS, things run smoothly again, as my Nvidia dGPU is failing soon I guess. (Depending on case by case, I am not sure whether it works for you)

Cheers :smileyvery-happy:

Peter
ThinkPad: W520 (4284-A99)

=============================================

Does someone’s post help you? Give them kudos as a reward, as they will do better to improve :smileyvery-happy:

Mark it as solved if the solution works for you, so it could be reference for others in the future :smileyvery-happy:


Dolby Home Theater v4 (Essential/IdeaPad/ThinkPad)

http://forums.lenovo.com/t5/General-Discussion/Dolby-Home-Theater-v4-for-most-Lenovo-Laptops/td-p/62...

Reply
Options

49 Posts

04-07-2009

Denmark

51 Signins

821 Page Views

  • Posts: 49
  • Registered: ‎04-07-2009
  • Location: Denmark
  • Views: 821
  • Message 5 of 36

Re: w520 bad sound quality and audio glitches with current conexant driver

2011-12-15, 12:26 PM

This might help you. It changes the networktrhottle limits.

 

* Open regedit
* Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile
* There will be an entry for network performance throttling, default value is 10; set it to FFFFFFFF hex (willl look like 0xFFFFFFFF to the right of the entry)
* Reboot

 

You can change it back same way if it does not help.

Reply
Options

49 Posts

04-07-2009

Denmark

51 Signins

821 Page Views

  • Posts: 49
  • Registered: ‎04-07-2009
  • Location: Denmark
  • Views: 821
  • Message 6 of 36

Re: w520 bad sound quality and audio glitches with current conexant driver

2011-12-16, 10:17 AM

BTW

Toying around with the regedit is not a good idea in general. But if you stick to what I discribed above you should be safe. The networkthrottle limits is taxing the network when playing Multimedia like video/music and games, in some cases it disturbs the connection of streaming or playing files over either internet or network. and it will turnout as you mention, like lagging in playback often like pitching or distorting or slowing down connection.

 

try it out?

Reply
Options

4 Posts

02-16-2012

Orem, Utah

17 Signins

50 Page Views

  • Posts: 4
  • Registered: ‎02-16-2012
  • Location: Orem, Utah
  • Views: 50
  • Message 7 of 36

Re: w520 bad sound quality and audio glitches with current conexant driver

2012-02-16, 18:16 PM
I've experienced the same problems. Given the less-than-stellar quality of the onboard sound anyway, I bought a SoundBlaster SB1240 external USB sound card (nice, despite Creative's declining charm). This worked *great* until a couple of weeks ago when my solid-state hard-drive crapped out (seriously) and I had to get a new one and re-install everything from scratch. There's definitely something different, now. Even with updated drivers, the behavior is different. It could be some power management settings or other driver-related settings that I have to "re-discover". I'm not sure. It could even be some obscure Win7 setting that I managed to find before. Don't know. All of the hardware is the same as it was except for the hard drive. Network activity isn't any different than before (using Synergy to drive a workstation). I hate to see others suffering the same predicament but hopefully somebody will discover the magic bullet .
Reply
Options

584 Posts

11-04-2010

Canada

811 Signins

5452 Page Views

  • Posts: 584
  • Registered: ‎11-04-2010
  • Location: Canada
  • Views: 5452
  • Message 8 of 36

Re: w520 bad sound quality and audio glitches with current conexant driver

2012-02-17, 8:59 AM

The sound...OMG.  It's probably the worst amoung other laptops in the similar price range.

 

I decided to go with an external USB DAC and a pair of DT-1350.

Reply
Options

618 Posts

07-03-2009

Andorra

534 Signins

5552 Page Views

  • Posts: 618
  • Registered: ‎07-03-2009
  • Location: Andorra
  • Views: 5552
  • Message 9 of 36

Re: w520 bad sound quality and audio glitches with current conexant driver

2012-02-17, 20:19 PM
Here is more you may find helpful: http://social.technet.microsoft.com/Forums/en-US/itprovistasp/thread/4f275ed8-fa95-49b2-ac0f-0902b82a5013/
Reply
Options

283 Posts

09-19-2011

USA

2285 Signins

8620 Page Views

  • Posts: 283
  • Registered: ‎09-19-2011
  • Location: USA
  • Views: 8620
  • Message 10 of 36

Here's my work-around

2012-02-17, 21:45 PM

Motorola EQ5 Bluetooth speakers

 

As I've mentioned elsewhere on this board, they were a great value at $26 that I paid. Now that they are $50 and up, not so much.

 

Still, they are compact and sound suprisingly good. They have a lot more volume than the internal W520 speakers.

 

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms