Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit our eSupport here.

English Community

ThinkPad NotebooksThinkPad: S Series, ThinkPad Yoga and Twist Laptops
All Forum Topics
Options

4 Posts

11-16-2014

Ireland

8 Signins

74 Page Views

  • Posts: 4
  • Registered: ‎11-16-2014
  • Location: Ireland
  • Views: 74
  • Message 1 of 13

Disabling Secure Boot on Thinkpad Yoga S1

2014-11-16, 14:46 PM

I am trying to disable UEFI Secure Boot on my Thinkpad Yoga S1 but it keeps getting re-enabled after a reboot. If I set secure boot to disabled I can boot into the non secure OSes installed on the machine imediately afterwards but if the machine is restarted the Secure Boot seting in the BIOS is re-enabled.  It's important for me to have secure boot disabled as I use OSes without secure boot.

 

I try to disable Secure Boot in the BIOS on the following screen :

 

Link to image 1

 

But if I re-enter the BIOS either after booting into an OS or simply re-entering the BIOS, Secure Boot is back on:

 

Link to image 2

 

I have also tried to disable "OS Optimzed Defaults" but it also returns to enabled after a restart.

 

Link to image 3

 

Some of the other BIOS settings save correctly so I can't figure out why the secure boot settings don't. The BIOS version I have is the latest (1.18).

 

Any ideas what I'm doing wrong? It's inconvenient to manually disable secure boot each time I want to use the laptop. The two operating systems (Ubuntu and Android x86) do work reasonably well once booted.

 

Thanks!

 

Juan

 

Moderator note: large image(s) converted to link(s):  About Posting Pictures In The Forums

Solved! See the solution
Reply
Options

1 Posts

11-18-2014

here

4 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎11-18-2014
  • Location: here
  • Views: 15
  • Message 2 of 13

Re: Disabling Secure Boot on Thinkpad Yoga S1

2014-11-18, 15:31 PM

I'm having the same issue. I've experienced this with 4 brand new yogas.

 

I will enter bios, disable secure boot, enable legacy pxe and upon reboot the changes are lost. I'm saving changes and exiting.  


Resetting user mode options, saving changes and not exiting, those have inconsistently allowed me to keep my changes long enough so i can legacy boot. 

Reply
Options

13 Posts

11-25-2014

Canada

22 Signins

186 Page Views

  • Posts: 13
  • Registered: ‎11-25-2014
  • Location: Canada
  • Views: 186
  • Message 3 of 13

Re: Disabling Secure Boot on Thinkpad Yoga S1

2014-11-25, 1:39 AM

Same here with a brang new TP Yoga.

I have updated BIOS to latest (1.20), the problem is still there.

This is very frustrating. I have done clean installs from USB on two other Thinkpad Yoga and I could disable secure boot without any problem. The only difference is that I was installing new hard-drives at the same time. In this case it is as if the pre-installed windows 8.1 was interfering with BIOS. I have tried to enter the BIOS from Windows 8.1 as explained here: http://itsfoss.com/disable-uefi-secure-boot-in-windows-8/

But same result, changes are never saved. I have confirmed that I can save other changes to the BIOS (e.g. keyboard beep), but secure boot and UEFI/Legacy boot always come back to their original status.

I would be grateful for any pointers!

 

Reply
Options

13 Posts

11-25-2014

Canada

22 Signins

186 Page Views

  • Posts: 13
  • Registered: ‎11-25-2014
  • Location: Canada
  • Views: 186
  • Message 4 of 13

Re: Disabling Secure Boot on Thinkpad Yoga S1

2014-11-25, 2:08 AM

IT FINALLY WORKED FOR ME!

I played with "OS Optimized Defaults" after reading your message more carefully.

Here is what I had to do:

1) in "Restart" tab, select "Disabled" for "OS Optimized Defaults" (accept warnings)
2) In "Restart" tab, select "Load Setup Defaults" (accept warnings)
3) Exit and save changes

 

In my case secure boot is now disabled and stays disabled after a reboot. A sign that it worked is that the boot screen (first image you see) changed from Lenovo (I think) to the black/white Thinkpad with a red dot.

 

I was able to boot from USB without any problems after that.

 

 

0 person found this solution to be helpful.

This helped me too

Reply
Options

4 Posts

11-16-2014

Ireland

8 Signins

74 Page Views

  • Posts: 4
  • Registered: ‎11-16-2014
  • Location: Ireland
  • Views: 74
  • Message 5 of 13

Re: Disabling Secure Boot on Thinkpad Yoga S1

2014-11-25, 23:10 PM

Thanks MikBik, that worked for me too!

Reply
Options

12 Posts

09-16-2012

United States of America

28 Signins

118 Page Views

  • Posts: 12
  • Registered: ‎09-16-2012
  • Location: United States of America
  • Views: 118
  • Message 6 of 13

Re: Disabling Secure Boot on Thinkpad Yoga S1

2014-11-29, 20:03 PM

Pardon the ignorace, but what exactly is secure boot?

Reply
Options

4 Posts

11-16-2014

Ireland

8 Signins

74 Page Views

  • Posts: 4
  • Registered: ‎11-16-2014
  • Location: Ireland
  • Views: 74
  • Message 7 of 13

Re: Disabling Secure Boot on Thinkpad Yoga S1

2014-11-29, 20:53 PM

It's a feature of the UEFI 'bios' on the laptop that prevents booting up of operating systems without a valid digital signature. Normally this isn't an issue if you are just using Windows but if you want to play around with the boot loaders and try out other operating systems then secure boot can get in the way.

Reply
Options

2 Posts

02-04-2015

United States

1 Signins

12 Page Views

  • Posts: 2
  • Registered: ‎02-04-2015
  • Location: United States
  • Views: 12
  • Message 8 of 13

Re: Disabling Secure Boot on Thinkpad Yoga S1

2015-02-04, 11:26 AM

i love you!!!

 

you saved me from hours of frustration...

 

you're a genius :)

 

best best regards and thank you!

 

 

Reply
Options

3 Posts

03-06-2015

Denmark

3 Signins

20 Page Views

  • Posts: 3
  • Registered: ‎03-06-2015
  • Location: Denmark
  • Views: 20
  • Message 9 of 13

Re: Disabling Secure Boot on Thinkpad Yoga S1

2015-03-06, 12:09 PM
Thanks alot, this saved my day ! :)
Reply
Options

22 Posts

07-10-2013

Missouri

27 Signins

116 Page Views

  • Posts: 22
  • Registered: ‎07-10-2013
  • Location: Missouri
  • Views: 116
  • Message 10 of 13

Re: Disabling Secure Boot on Thinkpad Yoga S1

2015-03-18, 18:39 PM

@MikBik

Thanks for that info.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms