Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: S Series, ThinkPad Yoga and Twist Laptops
All Forum Topics
Options

213 Posts

12-06-2007

United States of America

431 Signins

7269 Page Views

  • Posts: 213
  • Registered: ‎12-06-2007
  • Location: United States of America
  • Views: 7269
  • Message 21 of 52

Re: 2100: Detection error on HDD0 (Main HDD)

2016-01-08, 15:10 PM

 

- (Deleted my posting and moved response to different forum thread)

 

Reply
Options

1 Posts

01-29-2016

United States

3 Signins

23 Page Views

  • Posts: 1
  • Registered: ‎01-29-2016
  • Location: United States
  • Views: 23
  • Message 22 of 52

Re: 2100: Detection error on HDD0 (Main HDD)

2016-01-29, 16:48 PM

I am trying to install a custom Win7 64bit image on an X250 with 256gb ssd. I have received 2100: Detection error on HDD0 (Main HDD) twice now. 

 

This is on a brand new drive from Lenovo, the original would not boot into Windows so I had it replaced. Now, what do I have to do in order to complete the reimage to this drive?

Reply
Options

1 Posts

02-11-2016

United States

1 Signins

12 Page Views

  • Posts: 1
  • Registered: ‎02-11-2016
  • Location: United States
  • Views: 12
  • Message 23 of 52

Re: 2100: Detection error on HDD0 (Main HDD)

2016-02-11, 18:23 PM
When I have had this issue it was due to the SSD being stuck in Hibernation mode. I was able to go into BIOS and change SATA to Compatibility, Save and then reboot. This would "wake" the drive back up. The PC would then BSOD due to the SATA setting. Go back into BIOS and change SATA back to AHCI and all is good.
Reply
Options

4 Posts

07-20-2015

United States of America

5 Signins

65 Page Views

  • Posts: 4
  • Registered: ‎07-20-2015
  • Location: United States of America
  • Views: 65
  • Message 24 of 52

Re: 2100: Detection error on HDD0 (Main HDD)

2016-02-17, 18:11 PM

I am also having this error on several brand new Lenovo X250's as well.  we recently purchased a batch of 5 brand new X250's and 3 out of 5 of them are giving us this error after the users received the machines and used them for a couple of days.  On previous batches we had almost 10 lenovo X250's out of 30 that had bad motherboards and were replaced (not repaired) by Lenovo because the wait time on motherboards was so long due to the amount of defects. I am hoping the X260's do not have these quality issues. 

Reply
Options

4 Posts

09-14-2014

Italy

8 Signins

52 Page Views

  • Posts: 4
  • Registered: ‎09-14-2014
  • Location: Italy
  • Views: 52
  • Message 25 of 52

Re: 2100: Detection error on HDD0 (Main HDD)

2016-03-16, 13:33 PM
Hi,
maybe you can take a look here http://forum.thinkpads.com/viewtopic.php?f=68&t=120577
Reply
Options

1609 Posts

09-16-2014

United States of America

3048 Signins

61403 Page Views

  • Posts: 1609
  • Registered: ‎09-16-2014
  • Location: United States of America
  • Views: 61403
  • Message 26 of 52

Re: 2100: Detection error on HDD0 (Main HDD)

2016-03-31, 13:43 PM

In response to customer reports of intermittently receiving POST 2100 HDD Detection Error messages on X250 ThinkPads, Lenovo has made a solution available.

 

If you are experiencing this issue, please contact Lenovo Service for support and reference Service TIP #SF16-T0033/ HT118152. The system will need to be serviced.

 

Thank you,

Reply
Options

1 Posts

06-13-2016

Finland

4 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎06-13-2016
  • Location: Finland
  • Views: 15
  • Message 27 of 52

Re: 2100: Detection error on HDD0 (Main HDD)

2016-06-13, 16:04 PM
Hi!

Is there a way to update the driver while having this 2100: Detection error on HDD0? Because some documents on my broken SSD are very important.
Somehow with a flash drive containing windows/Linux?

Greetings
Robert
Reply
Options

4481 Posts

12-02-2007

United States of America

9199 Signins

202483 Page Views

  • Posts: 4481
  • Registered: ‎12-02-2007
  • Location: United States of America
  • Views: 202483
  • Message 28 of 52

Re: 2100: Detection error on HDD0 (Main HDD)

2016-06-14, 7:39 AM

Hello,

 

My understanding is that the computer needs to be sent into Lenovo for servicing, so it may not be something that is solved via a software update.

 

Regards,

 

Aryeh Goretsky

 


wrote:
Hi!

Is there a way to update the driver while having this 2100: Detection error on HDD0? Because some documents on my broken SSD are very important.
Somehow with a flash drive containing windows/Linux?

Greetings
Robert

 



I am a volunteer and neither a Lenovo nor a Microsoft employee.

L380 YogaP50 (20EN-*)P51sP72 (20MB-*)P43sS230u (3347-4HU)T23 (2648-LU7)T42 (2378-R4U)T43p (2678-H7U)T61p (6459-CTO)W510 (4318-CTO)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)X220 (4286-CTO)X250 (20CM-*)X1e gen3X1 Yoga gen 5X12 gen1X13 gen1Yoga 370

Communities: English Deutsche Español Português Русскоязычное Česká Slovenská Українська Język Polski Moto English


Need an answer, fast? Try using Browser Search to find it in the Lenovo and Moto Community
Reply
Options

1 Posts

07-21-2016

Mexico

3 Signins

20 Page Views

  • Posts: 1
  • Registered: ‎07-21-2016
  • Location: Mexico
  • Views: 20
  • Message 29 of 52

Re: 2100: Detection error on HDD0 (Main HDD)

2016-07-21, 19:12 PM

Umm... yeah, no...

Same issue on a T430. Have tried with several drives. The Samsung 840 EVO, a WD Scorpio, the Seagate Momentus Thin the machine shipped with... Alll are hard drives I've tested and work fine, but this machine (T430) shows this error every time. I've played around with BIOS settings, I've tried going back to the factory settings... Nothing.

I would totally try bios updates, and/or driver updates, but I have no OS. I'm trying to install Windows 7 Pro (as per licence)... 

Nothing does the trick.

Reply
Options

7 Posts

07-31-2013

Czech Republic

19 Signins

131 Page Views

  • Posts: 7
  • Registered: ‎07-31-2013
  • Location: Czech Republic
  • Views: 131
  • Message 30 of 52

Re: 2100: Detection error on HDD0 (Main HDD)

2016-08-08, 13:38 PM
Thanks! My coworker's browser hanged, so she restarted the PC and ended up with "detection error on hdd0 (main hdd)". I ultimately tried your suggestion and after going back to AHCI her x230 worked again.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms