English Community

ThinkPad NotebooksThinkPad: S Series, ThinkPad Yoga and Twist Laptops
All Forum Topics
Options

1 Posts

04-03-2017

AU

2 Signins

22 Page Views

  • Posts: 1
  • Registered: ‎04-03-2017
  • Location: AU
  • Views: 22
  • Message 1 of 3

Auto Rotation not working Yoga 460 fixed

2017-04-03, 7:11 AM

A few days ago the auto rotation in tablet mode stopped working on my Yoga 460. The auto rotation lock button had vanished from the action centre and once I got the button back still nothing happened when the rotation lock was disabled.

 

After some searching I found the solution to the issue which was actually 2 separate issues.

 

  1. In the registry find HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AutoRotation
    And set sensorPresent to 1
  2. Also in the registry find HKEY_LOCAL_MACHINE\SOFTWARE\POLICIES\Microsoft\Windows\locationAndSensors
    and set DisableSensors to 0

The auto rotate worked when I got my laptop and I have no idea why these settings got changed but it all seems to be working now.

 

Hopefully this helps somebody and I don't think these issues are limited to the yoga, others seem to be having similar issues with spectre and surface devices.

 

Reply
Options

14 Posts

03-20-2016

Germany

42 Signins

563 Page Views

  • Posts: 14
  • Registered: ‎03-20-2016
  • Location: Germany
  • Views: 563
  • Message 2 of 3

Re: Auto Rotation not working Yoga 460 fixed

2017-05-15, 21:21 PM

Hi NicG,

 

thanks for your fix of the auto rotation problem. It works fine for my Yoga 460:

after correction of the registry setting, disabling of windows 10 quick start and a restart auto rotation is back again. :-)

 

Klaus.

 

 

Reply
Options

1 Posts

04-24-2018

DE

3 Signins

16 Page Views

  • Posts: 1
  • Registered: ‎04-24-2018
  • Location: DE
  • Views: 16
  • Message 3 of 3

Re: Auto Rotation not working Yoga 460 fixed

2018-04-24, 17:24 PM

This worked on my Lenovo Yoga 370 too! Thanks a lot!

 

tried it first without reboot, it seemed to look like wirking - but after reboot it worked absolutely correct!

 

Thanks twice for your share!!!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete