cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Syntax
Paper Tape
Posts: 3
Registered: ‎01-26-2013
Location: Canada
Views: 16,554
Message 1 of 17

Disable Auto Rotate on Thinkpad twist 230GU

Hello, I just purchased a newer (est) thinkpad twist and need to fully disable the auto rotate feature on this laptop. I switch to tablet mode, hit the rotate lock, and the screen will randomly rotate.

 

I'm running a older piece of work software that gets really buggy when the screen rotates. There must be a way to make the screen rotate strictly a manual operation?

 

I've tried unchecking the box in the control panel, but the screen still actively rotates, again even when the rotate lock is on.

 

Thanks in advance.

Syntax
Paper Tape
Posts: 3
Registered: ‎01-26-2013
Location: Canada
Views: 16,493
Message 2 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

just to clarify it is the 33472GU model
Retired Support Specialist
Posts: 636
Registered: ‎12-11-2012
Location: Raleigh, NC
Views: 16,459
Message 3 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

Hey there Syntax,

 

I definitely can understand how that auto-rotate can be tricky sometimes. Have you made sure your have all of your latest drivers, particularly the power manager driver? I notice with the Twist I have here, that if I have the machine in tablet mode, turn off auto-rotate it will not rotate anymore. But if put the machine back into the regular laptop form auto-rotate turns back on automatically, and I have to press the physical side button again once in tablet mode. I hope this helps.



Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.
Syntax
Paper Tape
Posts: 3
Registered: ‎01-26-2013
Location: Canada
Views: 16,451
Message 4 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

Yes, my experience is the same. The software I am using does not like to be rotated, so when it auto rotates back it crashes the program. Sometimes it also just rotates while its in tablet mode, despite the screen saying the mode is off. I've downloaded and installed those drivers,  but I may have already had them as I ran a full Lenovo solutions update of all the drivers just the other day.

 

There really should be a way to simply just turn off the rotate feature all together so it stays off!

mikokolee
What's DOS?
Posts: 2
Registered: ‎04-03-2013
Views: 16,240
Message 5 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

Same problem here. The twist will auto rotate randomly. For example, I am in laptop mode and I leave my desk. The laptop is in sleep mode when back but when I wake it it is in portrait orientation and I can't get it back to horizontal orientation until first pivot the screen than pivot back.

 

There must be a way to disable auto rotate. Need help.

ezimmerman8406
What's DOS?
Posts: 2
Registered: ‎07-14-2013
Location: Wauwatosa
Views: 15,847
Message 6 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

Has anyone figured this out? I have the same issue and it is really annoying...

twistuser
Paper Tape
Posts: 2
Registered: ‎07-15-2013
Location: USA
Views: 15,817
Message 7 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

Yes, this is very annoying. I have learned that the "upright" hotkey is Ctrl-Alt-UpArrow, but it still stinks that I have to press it every time my computer alerts me that AutoRotate is now On again.
technot
Fanfold Paper
Posts: 11
Registered: ‎05-19-2009
Location: Los Angeles
Views: 15,717
Message 8 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

I don't know if this will work for anyone else, but after I turned off auto-rotation by pressing Windows Key + o (the letter, not the number), I "manually" rotate the screen orientation by right-clicking on the desktop --> Graphic Options --> Rotation --> then choose from "Normal" (i.e., laptop); 90 Degrees; 180 Degrees; or 270 Degrees, and it seems to stick.  (The Ctrl+Arrow key combination never worked for me.)

 

Turning off Auto-Rotation while in Laptop mode:

From the desktop, I just used Windows Key + o until the "Autorotate off" message appeared onscreen.

Alternatively, you can press Windows Key +x --> Control Panel --> Hardware and Sound --> Display --> Change Display Settings --> remove the checkmark from the "Allow the Screen to auto-rotate" box --> Click OK

 

To Right-Click the desktop "by touch" (e.g., you're already in Tent Mode and the orientation is wrong, and it's awkward to try to use the keyboard):

Press and hold your finger on the desktop and a square will appear. Remove your finger from the desktop and the right-click menu will appear, then touch Graphic Options --> Rotation --> then choose 180 Degrees.

 

Updated:  Just realized that switching to Tent Mode doesn't turn auto-rotate back on, but if I collapse my screen down into Tablet Mode from Tent Mode, when the screen is about an inch from touching the keyboard, auto-rotate comes back on automatically.  Still, if I press the auto-rotate button above the power button to turn auto-rotate off, when I "manually" adjust the rotation of the screen, it stays in place.  But when I raise the lid again to go back into Laptop Mode, auto-rotation comes back on by itself.

I'd love to find out how to disable whatever turns on the auto-rotation function when the screen is in a certain position.

2020vision
Paper Tape
Posts: 11
Registered: ‎11-17-2012
Location: Oregon
Views: 15,446
Message 9 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

That information about the Windows key + o was very helpful.  The information on how to right click using the touch screen was also very helpful. However, when I do right click on the screen, I have no Graphics Option and nothing even similar.  I do have the Lenovo Thinkpad Twist that was mentioned in the original post. Can you think of another way to manually rotate the screen?

vanilla2
Paper Tape
Posts: 8
Registered: ‎10-12-2010
Location: USA
Views: 15,399
Message 10 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

I found rolling back PM driver from 1.67 to 1.66 lets autorotate remain off. Details at posting below.

Check out current deals!


Shop current deals

Top Kudoed Authors