cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vanilla2
Paper Tape
Posts: 8
Registered: ‎10-12-2010
Location: USA
Views: 3,843
Message 11 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

I notice the following with PM 1.66 vs PM 1.67

 

PM 1.66

Autorotate does not enable itself upon waking from sleep.

Whether autorotate is on or not pressing rotate button does nothing at all.

 

PM 1.67

Autorotate enables itself upon waking from sleep.

With autorotate off, pressing rotate button does rotate the screen, but sometimes only in 180-degree increments.

With autorotate on, will do incorrect rotation to Portrait when clicking at lower left of screen. 

 

For both 1.66 and 1.67 Tablet-settings > Choose the order in which your screen rotates seems to be ignored, and changes in order also are not remembered.

vanilla2
Paper Tape
Posts: 8
Registered: ‎10-12-2010
Location: USA
Views: 3,837
Message 12 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU. Can disable if you use older PM 1.66 (not 1.67)

With the 1.66 driver, when I turn off "AutoRotate" it stays disabled after waking from sleep, rebooting, etc. Hopefully, that may be the answer to orignal posters question.

 

After updating to the 1.67 driver, on same box saw lots of un-desired behavior: Autorotate enables itself upon wake from sleep, and then rotates the screen incorrectly when I hit my "Classic Start Menu 3.68".

 

So I then un-installed 1.67 by Control-Panel > Programs and Features.

 

Then rolled-back to 1.66 like so:

 

Device Manger > System Devices > Lenovo PM Device > Driver (tab) > "Roll Back Driver" (button).

 

This puts back the older 1.66.0.17 driver dated 10/9/2012 (2012-oct-9).  And now I can disable autorotate and it stays disabled. If anyone knows any other pros/cons to sticking with 1.66 (instead of 1.67), please let us know!

 

If you can't roll back, then you'll need to download the installers. For my  ThinkPad Twist S230u (3347) the files/downloads are below, but get right ones for your particular model.

 

PM166 driver installer is   1,261,344 bytes, filename: geku09ww.exe

The link to at lenovo site seems dead: http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS031949

But found it at 3rd party site here: http://www.notebook-driver.com/detail/lenovo-driver-id-8155/

 

PM167 driver installer is:1,278,493 bytes, filename: giku06ww.exe from

http://support.lenovo.com/en_US/downloads/detail.page?LegacyDocID=MIGR-4GXPEG#tpad

 

Hope this helps...

ratedK
Paper Tape
Posts: 1
Registered: ‎08-29-2013
Location: Indianapolis, IN
Views: 3,582
Message 13 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

Windows Key + o

Solved my issue. Thanks so much, this was causing me to expel numerous curse words.
No trees were harmed sending this message. However, many millions of electrons were terribly inconvenienced
RJ345
Fanfold Paper
Posts: 2
Registered: ‎07-20-2013
Location: United States
Views: 3,537
Message 14 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU. Can disable if you use older PM 1.66 (not 1.67)

Thank you for the info. Backed up to 1.66 driver, now working. Was ready to trash this Twist for a Mac Air. Been putting up with this random auto-rotate for weeks & was ready to go to the dark side.

jasguild
Paper Tape
Posts: 16
Registered: ‎07-15-2013
Location: tampa
Views: 3,212
Message 15 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU. Can disable if you use older PM 1.66 (not 1.67)

Did anyone figure out how to turn off auto rotate PERMANENTLY?  Even with 1.66, it still goes back to enable after restart or boot.

 

This is very annoying!

technot
Fanfold Paper
Posts: 11
Registered: ‎05-19-2009
Location: Los Angeles
Views: 3,203
Message 16 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU. Can disable if you use older PM 1.66 (not 1.67)

I updated my Twist with the latest BIOS (1.61), Lenovo Power Management Driver (1.67.03.13), and Lenovo Setting Dependency Package (1.2.5.9), and my computer handles auto-rotation differently -- and in a way I think I understand and can control.

 

For me at least, auto-rotation seems to be OFF by default, when I'm in laptop mode.  When I pivot and collapse my screen down to tablet mode, when the screen is about an inch from the keyboard, auto-rotation turns on by itself.  But this is actually a good thing.  I tilt my Twist so that the screen is the way I like it (for example, maybe I want it to be Portrait while I'm in tablet mode), and then I press the previously-unreliable auto-rotation button (above the power button), and this turns auto-rotation OFF.  And it seems to stay OFF, so I don't lose my Portrait mode.

 

When I'm ready to go back to laptop mode, the most reliable way for me to make sure that my screen will revert to the correct orientation is while still in tablet mode to press the auto-rotation button to turn auto-rotate back on, tilt my Twist so that the screen is back in landscape (with the "Lenovo" emblem and physical windows button at the bottom of the screen), and then as I lift the screen out of tablet mode auto-rotate turns OFF automatically, and my Twist is in the correct laptop orientation.

 

If my screen is in the wrong orientation when I get back to laptop mode, I correct it by right-clicking on the desktop, choosing Graphic Options, Rotation, Rotate to Normal.

 

So, there seems to have been a change whereby auto-rotate is OFF by default in laptop mode, and it turns back on when you collapse to tablet mode, allowing you to control whether the screen is landscape or portrait in tablet mode.

 

I'm starting to feel that the Twist is finally becoming at least a shadow of the versatile tool it was advertised as being (as long as I ignore the lame battery, and the fact that memory usage always seems to be above 60%, and websites occasionally freeze, and WiDi doesn't seem to be active, and my laptop sometimes goes directly from the Start screen to the desktop without me touching it after it starts up, and...)

DMahoney139
What's DOS?
Posts: 1
Registered: ‎06-08-2017
Location: US
Views: 565
Message 17 of 17

Re: Disable Auto Rotate on Thinkpad twist 230GU

 It seems to me that everytime I open/close my Lexus laptop, another instance of the autorotate dll activates.  If I don this more than a couple of times, the CPU spikes to 100%.

 

My only work around is to rename the file C:\ProgramData\LenovoTransition\Server\x64\EnableAutoRotation.dll to something like EnableAutoRotation.dll.bad.

 

Please note that this is a hidden file, so you will have to tweak your windows explorer settings to find the file.  

 

The down side is that if you use the laptop in tablet mode, you will have to restore the original name and restart your computer. 

 

FYI - I am using a Ideapad Flex 4-1580 with windows 10.

Check out current deals!


Shop current deals

Top Kudoed Authors