Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 2
Registered: ‎07-13-2017
Location: US
Views: 531
Message 1 of 3

Internal SSD drives passing hardware tests, but extremely slow & failing Windows re-install

Two different internal SSD drives pass hardware tests, but attempts to re-install Windows on them fail during the initial disk partitioning and formatting options, with a low-level error and a very long delay.


The particular machine type model is 20CDCT01WW, the initial OS was Windows 8 Pro, later updated to Windows 10, and it's now out of warranty. It crashed one day during normal use, not near the time of any major hardware or software changes, and hung during re-booting. Attempts to recover the Windows installation failed, so we tried re-installing Windows from external media, and this process took far too long (running overnight, before finally failing with low-level error messages). I assumed the drive was faulty (the original Lenovo-installed Samsung PM851 128GB SSD), and by using Windows 10 recovery options from external media we could run the DiskPart utility & not have it find any partitions. I installed another, a new 500GB Samsung 850 EVO, only to have it behave in an identical way (the initial partitioning step of a new Windows install would run for hours, then fail with messages such as “We couldn't install Windows in the location you chose. Please check your media drive. Here's more info about what happened: 0x80070057.” Meanwhile we re-checked the original drive on another machine via a SATA to USB converter & saw an apparantly intact filesystem, so it didn't seem to be seriously faulty after all.


The built-in hardware diagnostics don't detect any problems with either drive installed. Obviously there's no way to run the standard Lenovo Windows-based diagnostics, but the Linux-based bootable diagnostic disk image from Lenovo didn't report anything. A test installation of Linux seemed to work, but was reporting that the SATA interface was not running at the full 6Gbps (unfortunately I don't have a before & after comparison with Linux to determine if this was always the case). Re-partitioning the new disk on another UEFI-aware system before trying the installation didn't make a difference. The firmware has been re-flashed to UEFI BIOS Version GQET52WW (1.32), 2017-05-04. We've tried various configuration settings, including reverting to the defaults. We've varied the USB ports to which the external media for the re-install were attached, and tried different media. When changing drives, I checked that there were no obvious problems with the SATA connector & that the drive was properly seated.

Could there be a subtle problem with disk controllers, cabling, or firmware settings that would cause it to pass the hardware tests but still fail a Windows installation?

Posts: 1,998
Registered: ‎02-27-2012
Location: EC
Views: 477
Message 2 of 3

Re: Internal SSD drives passing hardware tests, but extremely slow & failing Windows re-install

Hi, welcome to the forum


If it is not a hardware issue, my only guess will be to try to "reset factory settings" on the BIOS, just in case.  Check if you find that setting on the BIOS, I'm not sure where it should be since it change according the models.  You seem to be on the latest BIOS level, which lists some SATA and HDD improvements.


My other "software guess" will be to try creating a fresh Windows 10 install USB flash drive from Windows Media Creation Tool. Do a complete wipe of the HDD partitions when you install Windows (Remember to backup or recover any personal files if you still have some on the HDD). Check that you don't have any other USB HDD attached while you do the installation (I just read that on a forum).


But it is very strange that you get also SATA errors from Linux. So maybe it is a more deep hardware problem.




Martín Itúrbide NewsMaster
Self-proclaimed Trackpoint Fan Club President
"Don't Panic" 
Wil Wheaton
Remember: Your Friend Wil Declares....
Please click "Kudos" for Ego Boost !!


Paper Tape
Posts: 2
Registered: ‎07-13-2017
Location: US
Views: 463
Message 3 of 3

Re: Internal SSD drives passing hardware tests, but extremely slow & failing Windows re-install

Thanks for the advice: I think I've already tried that, but to be quite sure (there was an option, F9, for loading the defaults) did it again. The replacement drive started factory-fresh, but has been subjected to various attempts to install systems, so to be quite sure it was completely blank without even a fragmentary partition table I booted Linux off an external drive, verified that it was seeing the internal drive as /dev/sda, then did a

sudo dd bs=16M if=dev/zero of=/dev/sda

The Windows reinstall is aready off a bootable USB flash drive, so starting that again & specifying the blank drive as the destination for the complete installation again showed the same symptoms (it's not got around to displaying an error yet, but has been showing the hourglass cursor for an hour so far). The Windows image was something fairly generic (not a recovery image customized to that particular ThinkPad Yoga), so on a different support request to Lenovo I asked in passing if there could be driver problems with this, but the response was that there were known problems with the Enterprise version of Windows 10 in some cases, but Pro should be OK. The first version of Linux I'd been using was the Debian, but latterly I've tried Ubuntu 16.04.2 which is supposed to allow an install with almost the default settings (including secure boot), so tried that: it could partition & write to the drive, but couldn't then boot, and was still logging errors until it dropped to lower speeds when accessing the drive. At this point I'm thinking that there's degraded but not completely faulty hardware involved.

And we're back...

Move delayed but still coming

Learn More

Check out current deals!

Shop current deals

Top Kudoed Authors