cancel
Showing results for 
Search instead for 
Did you mean: 
Views: 12,247

Question

My ThinkPad Twist Touchscreen sometimes is unresponsive after the system wakes up from suspend or sleep mode.  Sometimes it works but then stops for a while and then starts working again.  It usually starts  working after 3, 5, 10 or 15 minutes. I cannot pinpoint exactly what makes it start or stop, it is very random. I hope Lenovo will fix it soon, it is a great machine otherwise.

Answer

 

Lenovo has a firmware update for the touchscreen that is in process of being released through our support site.  Since there could be multiple causes as discussed elsewhere in the forum the firmware update may or may not be be the solution for all possible causes.

 

Download the file attached to this article and rename it from .abc to .exe. It has been named .abc to get around some limitations with attaching executables and various anti-virus packages which would block it.  To install, be sure AC is attached and double click the file after you have renamed it.

 

After this update, many customers note that the screen feels more responsive and accurate.

 

NOTE:

 

After renaming to an .exe file, you need to right-click on the file and "unblock" it so that it could install. Be sure to reboot after installing.

 

unblocking.png

Was this information helpful?

Comments
Sakura15

I have a similar problem as well. My touch screen stopped working and i really don't know why. I haven't downloaded anything. the only new thing was the update that my computer had. I tried a lot of things to try to fix it but nothing works. The one i have is the Yoga 2 11" one. Only had it for less than a month. 

wtc23

Good luck - I have a Lenovo Twist and the touchscreen has never worked properly, despite what seems like a hundred updates from Lenovo. I finally gave up yesterday and ordered a new non-Lenovo laptop. Hopefully this one will actually work properly!

MrsCLM

lenovo Flex 3 -- WIndows 10 -=-

 

The default power settings seem to not be correct. The solution that is working:

  • Control Panel > Power Options Edit Power Settings
  • I changed the power plan to High Performance so I had the option to make changes
  • Sleep> Sleep After: I change both to NEVER so I wouldn't worry about this issue but you may still opt to keep it on
  • Sleep> Hibernate After: Also changed it ot NEVER
  • Sleep> Allow Wake Timers -- this was the biggie -- It was not enabled You usually want it Enabled 
  • Display> Check how much time you want the display to be on if you're not doing anything - my default was 5 minutes
  • Lastly I update the video driver because a Win10 update was causing a conflict.