cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
aa007
What's DOS?
Posts: 1
Registered: ‎11-16-2014
Location: Prague
Views: 399
Message 1 of 2

TP Yoga POST Error 2100 HDD0 after BIOS upgrade

Hi,

 

I updated BIOS on my ThinkPad Yoga to the latest version (i went from GQET35WW to GQET38WW according to the log). After I installed WIN 10 TP and Ubuntu 14.10 (dualboot with GRUB2).

Afrer a while I started recieving POST ERROR 2100 after cold boot. I thought my HDD is gone, so I went to dignostics menu and immidiately my HDD turned on (I heard it spin up), so I ran the tests (everything was successful) and everything was working correctly.

 

Next day I had the same issue - so i just launched diagnostic menu, my HDD spins up, then I just exit the diagnostics menu and everything is working correctly...

 

I have read some thread about this problem, but everybody is talking about their SSD drives. I suspect that the new BIOS is the problem, before that everything was OK.

 

Thanks for any advice.

 

golugolu
Blue Screen Again
Posts: 1
Registered: ‎12-01-2014
Location: Somewhere
Views: 329
Message 2 of 2

Re: TP Yoga POST Error 2100 HDD0 after BIOS upgrade

Hi aa07,

 

I had a situation similar to yours: a Thinkpad E531, with Windows 10 TP and Ubuntu 14.04 LTS. I happened to see the error after a VERY extensive update of Windows 10. I just managed to solve the problem, though do not know if this will solve the problem permanently: in Application Menu under Setup, I entered in Config tab and chose Serial ATA (SATA), and changed the value (of SATA Controller Mode Option) to Compatibiliti (originally it was on AHCI). After that the laptop was working again like a charm. I tried to change back the value to AHCI and still it boots smoothly (actually I did not dedicate time to figure out what those two values mean).

 

Anywa I beleive it's the fault of Windows 10 TP, since I had the problem immediately after Microsoft update, and actually the Wndows does not load anymore (I see a big )': in the middle of blue screen displaying an error), and though Windows tried to return to the previous version, it still does not load. It's the last time I'm going to try a TP product of ANY type.

 

Hope this helps.

Best

Check out current deals!


Shop current deals

Top Kudoed Authors