English Community

ThinkPad NotebooksThinkPad: S Series, ThinkPad Yoga and Twist Laptops
All Forum Topics
Options

1 Posts

12-25-2019

HU

1 Signins

13 Page Views

  • Posts: 1
  • Registered: ‎12-25-2019
  • Location: HU
  • Views: 13
  • Message 1 of 2

Thinkpad S540 - boot issue after SSD upgrade

2019-12-25, 20:53 PM

I have issues with booting my Thinkpad S540 after upgrading the old SSD + HDD combo with a new SSD 

 

- old storage: Plextor M2 64GB N3-L2064-01 SSD (used to have Windows on it) + a 1TB HDD

- new storage: 1TB Crucial MX500

- removed the 64GB small SSD and HDD and swapped for the Crucial one

- reinstalled Windows 10 64bit on the Crucial SSD

- upgraded the factory Samsung 4GB ram with Crucial CT2KIT51264BF160BJ 8 GB

 

After doing the swap the system booted flawlessly from the new SSD but after 3-4 restarts it refuses to boot from the SSD and stucks in the Boot menu. I receive the "pxe e61 media test failure" error then immediately goes to BOOT menu and despite offering to boot from the SSD it doesn't do anything.

The only workaround I found is: when powering up the machine I have to enter BIOS (I don't have to change anything just enter the BIOS menu), exit and the laptop boots without issue.

Though this works this is very tiring to do it every time I want to switch on the machine.

What is even more strange is that this boot issue doesn't happen when I only "restart" only when shutting down.

 

Steps I did, checked:

- updated all drivers including BIOS using Lenovo Service Bridge

- checked if the SSD is inserted correctly

- the SSD firmware is the latest one

- in the boot priority order the SSD is the first one

- checked the device manager: it recognises the SSD and the new RAMs (checked in the BIOS as well, all good)

- tried both via Legacy and UEFI boot order

- reseted BIOS to factory default

- tried to switch of network boot but the bios doesnt have this option

 

Any ideas? Any advice is much appreciated!

 

Reply
Options

8076 Posts

01-13-2008

US

77127 Signins

2181699 Page Views

  • Posts: 8076
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2181699
  • Message 2 of 2

Re: Thinkpad S540 - boot issue after SSD upgrade

2019-12-25, 23:12 PM

Hello and welcome,

 

I've run into something similar - and with the same SSD IIRC.

 

Your comment about going in and out of BIOS withouth changing anything pretty much confirms it.  That SSD takes longer to initialize on startup than the BIOS probe code waits for a drive to show up.  Going into BIOS allows some extra time powered on and leaving without changing anything doesn't do another startup reset so by then the SSD is fully "live".

 

AFAIK there is no fix other than finding another SSD that's quicker to get going.  The usual go-to is a firmware update but you're already at the latest.

 

Not what you wanted to hear...

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English


Using Browser Search to find your answers in Lenovo and Moto Community


Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete