Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics

15 Posts



31 Signins

399 Page Views

  • Posts: 15
  • Registered: ‎09-03-2019
  • Location: Pakistan
  • Views: 399
  • Message 1 of 1

2101 Detection Error on HDD2 (mini SATA)--older Thinkpads--attempt at finding a definitive solution

2019-09-09, 11:15 AM

After struggling with this fault on my T430 for many years, and reading (almost) all there is on the interwebz, I'm disappointed to see many laptops are affected by it and Lenovo hasn't (so far) given out an official word on the subject (apart from installing Express Cache on Windows 7). I understand the problem is specific to Lenovo and due to BIOS, not hardware. Apparently a few have had this problem despite not having an msata drive which is strange... 

This is an attempt at summarizing the experience and stop-gap solutions until (hopefully) Lenovo can say/ do something about it


My specs.

T430 Core i7 3840QM (mod). Discrete graphics with latest BIOS v. 2.82. 16 GB RAM, FHD (mod). I regularly use a 1TB KingSpec msata SSD (Chinese which despite all the negative press, has OK reviews and works fabulously on my machine), but have also used Transcend and Samsung SSDs with 128 GB capacity and have had the same problem. I also have a 2TB Seagate in my regular HDD slot and a 1TB Toshiba in place of CD-Drive.



- In AHCI mode only (for me at least), the computer intermittently gives error "2101 Detection Error on HDD2 (mini SATA)" (the HDD number or miniSATA vs m2.Sata might vary on different machines) at boot.

- mostly happens after changing BIOS settings, BIOS updates or installing/ removing hardware, but not limited to that only. Sometimes it also happens after draining the battery or removing and reinserting the battery (without power cable), and sometimes most unexpectedly when about to give a presentation or in a business meeting (most frequently... unlike Marvin, I think my laptop doesn't come with Genuine People Personality--stage fright).



- Switching from AHCI to compatibility mode. This however kills the whole purpose of having an SSD as it slows it down considerably. Note however, that I have not had the 2101 error in Compatibility mode, ever. Note also the mSATA slot on T430 is already half the regular SATA II speed, which is fine as it still a hell of a lot faster than a regular HDD, but not if it's in Compatibility mode as well.

Also to note that after the latest BIOS and EC firmware updates, my machine was virtually bricked until I switched to Compatibility mode. After switching back to AHCI, at least the machine wasn't bricked but problem recurred almost as frequently as before.


- Tinkering BIOS settings. What works 90% of the time is to switch Safeboot on or off. (If it's on, turn it off; if it's off, turn it on).

   - Switching graphics mode from Discrete to Integrated or from NVIDIA Optimus to either or back, also triggers the 2101 error and subsequent changes resolve it. If Safeboot doesn't work, this does.

    - Switching on or off TPM/ Anti Theft features also sometimes triggers/ resolves the problem (again, like safeboot, for no good reason).

   - Re-seating the SSD or battery, sometimes helps, but not always and again for no good reason. Cleaning contacts doesn't do anything.



   - In Windows 10 (at least), Express Cache doesn't do a thing. I understand Lenovo recommends it for Win8 and for small SSDs (8GB etc.) but I've tried it several times, sometimes running for a month on Win 10 on my 1TB (and also 128 GB SSDs) to no effect. I have a 2GB partition for cache. The eccmd commands work as they're supposed to. I've tried formatting cache and all, but to no effect. However, with express cache the problem isn't triggered by safeboot but (in my limited experience) by changing graphics mode (discrete, integrated or optimus).

   Also Express Cache eats up a lot of resources. Idle RAM usage goes up from a normal of about 10-12% to 22-24% (on idle, after booting up). It randomly takes a considerable amount of CPU power which among other things, makes the laptop unnecessarily warm when you don't want it to be (.e.g working with the machine on your lap).

-Reseating SSD and cleaning (unnecessarily) it's polished shiny gold contacts.

- Cleaning msata connector's contacts by spraying contact cleaner and using a soft squirrel-tail brush very lightly

- Removing battery, pressing power button for 10 seconds (and all variations of it: pressing it ten times for one second each, standing on your head and pressing it with your nose while counting backwards from 100--don't try your tongue or other pokey bits: at least mine isn't strong enough to press that button), etc....


I've had this problem since 2014, and have looked everywhere for solutions since then. I remember seeing a document/ forum at one point in history by lenovo (if I remember well) saying it was a BIOS problem, which it very much sounds like. But lately I've seen many people complain (on this forum and in many other places) but no permanent fix.


Requesting Lenovo to look into this problem. Most of us with older thinkpads love our machines and don't want to replace them with new ones for numerous reasons (affordability, lack of new features, unnecessarily sleek thinkpads which offer less storage and upgrade options, or simply, like me, love our old thinkpad well enough to not care about the new "millennial look"). 

Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop





No, I don’t want to share ideas Yes, I agree to these terms