English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

4 Posts

09-24-2020

CZ

5 Signins

30 Page Views

  • Posts: 4
  • Registered: ‎09-24-2020
  • Location: CZ
  • Views: 30
  • Message 1 of 6

AMD T14 Gen 1 USB-C issues

2020-09-24, 13:03 PM

Hello,

today I have updated Lenovo firmware to 1.09. Everything was OK except one issue. USB-C ports stopped working for my external HDD. If I connect the same HDD to any other USB port, it works correctly. I am using Win 10 with all updates.

 

Update: USB-C port works for any device (I can use it to backup my phone, connect USB headset). But it does not work for USB external HDD.

 

Please help

Best regards

Michal

Reply
Options

15 Posts

09-25-2020

DE

15 Signins

70 Page Views

  • Posts: 15
  • Registered: ‎09-25-2020
  • Location: DE
  • Views: 70
  • Message 2 of 6

Re:AMD T14 Gen 1 USB-C issues

2020-09-25, 14:14 PM

There seems to be a bigger problem with the BIOS Update 1.09.

 

After the update, my internal speakers on the AMD T14 Gen 1 stopped working, although they were shown as "device working properly" in device manager.  

 

Hopefully Lenovo will provide a fix real real soon!

 

Greetings

Reply
Options

4 Posts

09-24-2020

CZ

5 Signins

30 Page Views

  • Posts: 4
  • Registered: ‎09-24-2020
  • Location: CZ
  • Views: 30
  • Message 3 of 6

Re:AMD T14 Gen 1 USB-C issues

2020-09-28, 15:02 PM

Hello,

 

it looks there are even more issues. After the update I found out that USB external HDD are way more slower. Before that I was obly to copy 100MB/s and now its maximum 40MB/s.

 

Can you test if you have the same issue?

 

Strange thing is that when you connect USB flash drive to USB-C port, it works. Only issue is with external HDD.

Reply
Options

4 Posts

09-24-2020

CZ

5 Signins

30 Page Views

  • Posts: 4
  • Registered: ‎09-24-2020
  • Location: CZ
  • Views: 30
  • Message 4 of 6

Re:AMD T14 Gen 1 USB-C issues

2020-09-28, 15:20 PM

And one more thing, when you connect the external HDD to USB-C, neither BIOS recognize the external HDD. So deffinitely its a BIOS issue

Reply
Options

4 Posts

09-24-2020

CZ

5 Signins

30 Page Views

  • Posts: 4
  • Registered: ‎09-24-2020
  • Location: CZ
  • Views: 30
  • Message 5 of 6

Re:AMD T14 Gen 1 USB-C issues

2020-09-29, 15:38 PM

Small update. Reverting back to BIOS version 1.05 fixed all issues. USB-C recognize HDD again and it copies very fast everything.

So deffinitely the BIOS 1.09 has some bugs.

Reply
Options

8 Posts

10-08-2020

US

8 Signins

95 Page Views

  • Posts: 8
  • Registered: ‎10-08-2020
  • Location: US
  • Views: 95
  • Message 6 of 6

Re:AMD T14 Gen 1 USB-C issues

2020-10-08, 23:56 PM

I have an AMD T14 as well and noticed a problem  with a problem with a USB external drive IO timing out on large file transfers.  The drive is a Western Digital SN520 , the enclosure uses a Jmicron 583 controller.

 

I switched to a USB C to USB A cable and connected it to the 3.2 gen 1 (5gbit) port on the left side and it works fine. Both ports use the same AMD controller but the USB C is a 3.2 gen 2 (10gbit). You might want to try the A port if you have a cable.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete