Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

22 Posts

06-11-2009

ca

36 Signins

432 Page Views

  • Posts: 22
  • Registered: ‎06-11-2009
  • Location: ca
  • Views: 432
  • Message 1 of 17

Blank screen after awaking from sleep. [T400]

2009-06-21, 12:24 PM

This is the 3rd time this has happened so I was wondering if you can help me.

 

Sometimes when I return the T400 from sleep mode, it remains in the black screen forever. I have to do hard shutdown by holding onto the power key, and then restart.

 

I have no clue what is causing this problem and was wondering what your advice is.

Reply
Options

321 Posts

12-16-2008

Texarkana Texas

501 Signins

5306 Page Views

  • Posts: 321
  • Registered: ‎12-16-2008
  • Location: Texarkana Texas
  • Views: 5306
  • Message 2 of 17

Re: Blank screen after awaking from sleep. [T400]

2009-06-22, 0:16 AM
My t500 does this sometimes....  I wish they would fix it...
Thinkpad T500 - Intel Core2 P8400 (2.26GHz), 4 gigs of ram, 160GB/7200rpm hard drive, ATI 3650 GPU, WSXGA+ panel
Reply
Options

29 Posts

06-01-2009

australia

31 Signins

522 Page Views

  • Posts: 29
  • Registered: ‎06-01-2009
  • Location: australia
  • Views: 522
  • Message 3 of 17

Re: Blank screen after awaking from sleep. [T400]

2009-06-22, 0:50 AM
I've yet to experience this but I have a related issue regarding buggy screen software I'd like to report.  Sometimes when my t500 wakes from sleep, it is completely impossible to change the brightness setting.  Not in power manager, not by the keyboard.  It requires a restart.  Considering my own (less significant but still irritating) issue along with black screen on waking up there is definitely something that needs to be addressed.
Reply
Options

22 Posts

06-11-2009

ca

36 Signins

432 Page Views

  • Posts: 22
  • Registered: ‎06-11-2009
  • Location: ca
  • Views: 432
  • Message 4 of 17

Re: Blank screen after awaking from sleep. [T400]

2009-06-24, 11:40 AM

Hi

 

This just happened again. Is there drivers missing or not updated.

 

How come I cannot download files from the support website. I click agree but it just closes and no file pops up

 

 

Reply
Options

22 Posts

06-11-2009

ca

36 Signins

432 Page Views

  • Posts: 22
  • Registered: ‎06-11-2009
  • Location: ca
  • Views: 432
  • Message 5 of 17

Re: Blank screen after awaking from sleep. [T400]

2009-06-24, 16:32 PM

I checked with my current sleep settings by going to cmd and typing "powercfg -a". It says that I only have S3 sleep state. How do I enable S1 and S2 sleep state. Could this problem be related to S3 sleep state since RAM is not refreshed as often albeit saving a lot more power. I am perfectly happy with S1 or S2 sleep state if it fixes the problem.

 

Reply
Options

1041 Posts

03-10-2009

Michigan

1453 Signins

21182 Page Views

  • Posts: 1041
  • Registered: ‎03-10-2009
  • Location: Michigan
  • Views: 21182
  • Message 6 of 17

Re: Blank screen after awaking from sleep. [T400]

2009-06-24, 16:58 PM

Hi blackthinkpad,

 

Could you please post the type and model number of your T500? There are different varieties, with different video cards, drivers, etc. The type and model number are 7 digits XXXX-YYY on the label on the bottom, and in the main BIOS setup screen that appears when you press F1 at boot. Please do not post your serial number, which also appears there.

 

Also, which OS are you using?

 

Thanks,

Frank

---------

Results of Your Ideal Business-Class Laptop survey, concluded 2009-07-29.

Did someone help you?
Say thanks! with a kudo.
Even better: Pay it forward, help someone else. :smileyhappy:
Reply
Options

22 Posts

06-11-2009

ca

36 Signins

432 Page Views

  • Posts: 22
  • Registered: ‎06-11-2009
  • Location: ca
  • Views: 432
  • Message 7 of 17

Re: Blank screen after awaking from sleep. [T400]

2009-06-24, 18:34 PM

Hi Frank,

 

My machine is a 2764-CTO running Vista Business. I have done some researching online and have found this problem to be reported primarily among notebook computer users from many manufacturers (perhaps because notebook users sleep their computers more often). Interestingly I am looking at my old laptop (running XP Business) and it has only S3 sleep state also. I am also looking at a desktop PC (Vista Home) and it has S1 and S3 sleep state enabled. Don't know if it is an issue with vista and supporting hardware? The only setting difference between the T400 and the notebook and PC is that hibernation is switched off on the T400.

 

In an unrelated question, I was wondering how to keep screen settings constant after resuming from sleep. For example, even if I have my power setting at maximum performance (with screen brightness on maximum), I sometimes dim the screen depending on preference at any given point in time. However, everytime I come back from sleep mode it resumes itself onto maximum screen brightness a few seconds after the system wakes up and overriding my previous settings. I also notice that after I shutdown&restart my computer and I press the center scroll button a couple of times, that the information message describing the purpose of the middle key will display itself again. This is even after I had checked the box stating not to display the message again in a previous occasion. I had this same problem in my previous thinkpad also.

 

CHeers.

Message Edited by blackthinkpad on 06-24-2009 11:35 AM
Message Edited by blackthinkpad on 06-24-2009 11:41 AM
Reply
Options

22 Posts

06-11-2009

ca

36 Signins

432 Page Views

  • Posts: 22
  • Registered: ‎06-11-2009
  • Location: ca
  • Views: 432
  • Message 8 of 17

Re: Blank screen after awaking from sleep. [T400]

2009-06-25, 1:41 AM

I have done some experiments. I can now very dependably get my system to not wakeup at all. All I have to do is make it goto sleep in succession 6-7 times in a row and by then it will blank screen. This is after a fresh restart of vista before opening any programs.

 

I have hooked it onto an external monitor also and it shows nothing on the external monitor by the time it crashes. This particular outcome may not be surprising provided that windows has to load before the second monitor will work. But this does seem to indicate that windows is not loading properly.

 

When the system crashes, it appears I can only do the following: (1) turn LED light on or off, and (2) eject optical drive. The sleep icon (the moon) is sometimes on, sometimes not during this crash. If I insert an SD card into the media card reader, it shows a green light suggesting a response. The other thing I noticed is that after any crash, it takes extra long before I get the BIOS password prompt.

 

I just got this error message on the latest bootup after a crash (don't know if its related):

"

ERROR

0254: System NV7 Volume checksum bad - Default configuration used

 

Press <F1> to Setup

"

 

Reply
Options

1041 Posts

03-10-2009

Michigan

1453 Signins

21182 Page Views

  • Posts: 1041
  • Registered: ‎03-10-2009
  • Location: Michigan
  • Views: 21182
  • Message 9 of 17

Re: Blank screen after awaking from sleep. [T400]

2009-06-25, 1:55 AM

It is apparently common to have problems with standby mode when running Vista. Here is a thread that lists some things you can try

 

---------

Results of Your Ideal Business-Class Laptop survey, concluded 2009-07-29.

Did someone help you?
Say thanks! with a kudo.
Even better: Pay it forward, help someone else. :smileyhappy:
Reply
Options

22 Posts

06-11-2009

ca

36 Signins

432 Page Views

  • Posts: 22
  • Registered: ‎06-11-2009
  • Location: ca
  • Views: 432
  • Message 10 of 17

Re: Blank screen after awaking from sleep. [T400]

2009-07-12, 7:30 AM

I have tried everything and nothing is working.

 

Statistically speaking I can wake the T400 from sleep 1/10.

 

Interesting observation:

 

I have 3GB RAM. Tested with superfetch off also to minimize memory caching. RAM test in vista says there are no errors.

 

I noticed that the system will not wake from sleep once the physical memory has come close to 0 free memory (or maybe in the 10s of MB) when most of that memory is cached. If there are plenty of 'free' physical memory left (say in the GB to 100s of MB range) it seems to wake ok. That is why it seems to be dependent on what I open. For example when I open CAD software & word documents, numerical computation software etc - that takes a chunk of the RAM, and I sleep the T400, it wont be able to wake henceforth. Or similarly when I have used the computer for a while (which gradually probably caches a lot of things as time goes on), it doesnt wake also.

 

I am wondering if there is a problem related to RAM memory management (& perhaps paging also), either at a software level of the OS or drivers, or a hardware issue? If so what is a fix to this? Is anyone going to look into this cause its a problem apparently not limited to T400.

I also looked into Event Viewer. It sometimes displays an error with sleep transition. Can it be related to power management issue also? I'm making the upcomming scenario up, but is it possible things are getting shutdown too quick before windows has sufficient time to update the RAM with the sleep settings and also shuffling the previously cached memory into the page file (HDD)? Seems to correlate with my current observation of not waking when 'free' physical memory (RAM) is low. I current do not want to believe its an issue with the motherboard.
Message Edited by blackthinkpad on 07-12-2009 01:43 AM
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms