English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

4 Posts

03-02-2019

US

11 Signins

69 Page Views

  • Posts: 4
  • Registered: ‎03-02-2019
  • Location: US
  • Views: 69
  • Message 1 of 3

Cannot prevent TrackPoint mouse buttons from being disabled when typing

2019-03-02, 6:14 AM

I own a Thinkpad T470s laptop, and I'm having problems with the physical mouse buttons on top of the Trackpad being disabled for a second whenever a key is pressed. This appears to be a feature intended to prevent unintended mouse clicks on the Trackpad during typing, but for some reason, it also affects the buttons which are never accidentally pressed. The feature prevents me from playing many games without an external mouse and is also annoying when I'm coding or editing a document as I have to wait a second every time I want to click immediately after typing.

 

I've tried going into the mouse settings -> additional mouse options -> ThinkPad -> TouchPad -> Advanced settings and dragging the Palm Check Threshold all the way to the minimum, but this appears to have no effect. I've also tried editing various parts of the registry with no luck and updating my drivers.

Solved! See the solution
Reply
Options

4 Posts

03-02-2019

US

11 Signins

69 Page Views

  • Posts: 4
  • Registered: ‎03-02-2019
  • Location: US
  • Views: 69
  • Message 2 of 3

Re: Cannot prevent TrackPoint mouse buttons from being disabled when typing

2019-03-03, 5:22 AM

The problem appears to have been somehow magically fixed. I restored the registry using a backup when the stuff I tried failed, so I don't think it was because of that. It's probably due to the driver updates or something, although I restarted my computer multiple times earlier and the problem was still there after I've done that.

0 person found this solution to be helpful.

This helped me too

Reply
Options

6 Posts

07-06-2019

DK

2 Signins

57 Page Views

  • Posts: 6
  • Registered: ‎07-06-2019
  • Location: DK
  • Views: 57
  • Message 3 of 3

Re: Cannot prevent TrackPoint mouse buttons from being disabled when typing

2019-07-06, 19:10 PM

To others having similar issues, this was the fix that worked from me (from here ):

 

Registry key

Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\PrecisionTouchPad

 

Set AAPThreshold to 0

 

Reboot.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete