English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

16 Posts

11-10-2016

DE

41 Signins

148 Page Views

  • Posts: 16
  • Registered: ‎11-10-2016
  • Location: DE
  • Views: 148
  • Message 1 of 14

Intel ME WMI Provider missing

2020-08-03, 10:43 AM

Hello,

 

on newer systems like the T490 the Intel ME WMI Provider is missing in "Intel Management Engine 14.0 Software" (Link). On older Systems T470p, T460p, T440p it is installed and the Softwarepackage also is much larger (over 100mb vs. 18mb).

 

Because of missing the WMI Provider, there is no WMI-Class "Intel_ME", so there are no possibilities to check ME status/firmware etc. in Microsoft SCCM (MEM).

 

If i install the full setup e.g. from station-drivers/dell/msi the wmi provider is present.

 

Question 1: Why Lenovo, why? Why is the Intel Management Engine 14.0 Software stripped down?

Question 2: Are there any solutions for this problem? Except dealing with unsupported Software from other OEMs than Lenovo.

 

Thank you,

 

Best Regards

Reply
Options

6513 Posts

10-29-2009

NC

17651 Signins

162019 Page Views

  • Posts: 6513
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 162019
  • Message 2 of 14

Re:Intel ME WMI Provider missing

2020-08-04, 14:42 PM

We recently moved to an INF-only driver package to meet some Microsoft requirements, the full setup is not available in this package because there is no way to install it from INF.  However, we do understand why you need it.  We are discussing how to provide the SetupME.exe that you need.  Sorry for this trouble.

Reply
Options

6513 Posts

10-29-2009

NC

17651 Signins

162019 Page Views

  • Posts: 6513
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 162019
  • Message 3 of 14

Re:Intel ME WMI Provider missing

2020-08-04, 17:01 PM

Here is the installer that I think you are looking for.  Can you please check it and let me know?

 

2021.14.0.1623_SetupME_DCHInstaller.zip

Reply
Options

16 Posts

11-10-2016

DE

41 Signins

148 Page Views

  • Posts: 16
  • Registered: ‎11-10-2016
  • Location: DE
  • Views: 148
  • Message 4 of 14

Re:Intel ME WMI Provider missing

2020-08-05, 6:14 AM

Hi,

 

the installer is working fine and the required WMI Classes are present. Thank you.

 

Can we expect this package (and future versions) to be generally available via tvsu/update retriever?

 

Best Regards.

Reply
Options

6513 Posts

10-29-2009

NC

17651 Signins

162019 Page Views

  • Posts: 6513
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 162019
  • Message 5 of 14

Re:Intel ME WMI Provider missing

2020-08-06, 18:24 PM

I have made the request to get this into System Update somehow, but I don't think it is something we can do in the short-term.

Reply
Options

16 Posts

11-10-2016

DE

41 Signins

148 Page Views

  • Posts: 16
  • Registered: ‎11-10-2016
  • Location: DE
  • Views: 148
  • Message 6 of 14

Re:Intel ME WMI Provider missing

2020-08-07, 10:03 AM

Okay,

 

can we use the package you provided us in the meantime or is it not official from lenovo and we might get no support in case of an issue?

 

Thank you,

 

Best Regards

Reply
Options

6513 Posts

10-29-2009

NC

17651 Signins

162019 Page Views

  • Posts: 6513
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 162019
  • Message 7 of 14

Re:Intel ME WMI Provider missing

2020-08-07, 11:53 AM

You can use that package, if you find some issue you can let me know here.  Thanks.

Reply
Options

33 Posts

10-08-2010

US

38 Signins

644 Page Views

  • Posts: 33
  • Registered: ‎10-08-2010
  • Location: US
  • Views: 644
  • Message 8 of 14

Re:Intel ME WMI Provider missing

2020-10-15, 20:17 PM

Someotherguy,

 

We've run into the same issue with the Thinkpad X1 Carbon 7th-gen (types 20QD and 20QE).  While attempting to programmatically deploy recent Intel ME Firmware & ME Software updates for CVE-2020-8758, we were surprised to discover that our 7th-gen Carbons were missing the "me_system" Class, and the parent "root\intel_me" Namespace, from WMI.

 

We used this WMI class with previous models (X1 Carbon 6th-gen, X1 Yoga, etc.) to both track ME version compliance and to programmatically deploy ME Firmware and ME Software updates-- so this has created a problem for us with this latest purchase of 7th-gen Carbons. 

 

Do you have a download somewhere for the Intel ME Software (for the ThinkPad X1 Carbon 7th-gen) that actually creates the Intel_ME namespace in WMI like the older installers used to? It appears the latest ME Software install is just a a batch file with a slew of pnputil driver injections...

 

 

:Vpro_Install

rem =======================MESW drivers and Components(vPro)======================

echo.

echo.

echo System is vPro...

echo Installing MEI(HECI) and SOL drivers...

echo.

 

pnputil /add-driver "%~dp0MEI_SOL_Drivers\MEI\win10\heci.inf" /install

pnputil /add-driver "%~dp0MEI_SOL_Drivers\SOL\mesrl.inf" /install

 

echo.

echo.

echo Installing ME Software Components(iCLS, JHI, LMS, WiMAN and Extension INFs)...

echo.

 

pnputil /add-driver "%~dp0MESW_Components\ICLS\iclsClient.inf" /install

pnputil /add-driver "%~dp0MESW_Components\JHI\win10\DAL.inf" /install

pnputil /add-driver "%~dp0MESW_Components\LMS\LMS.inf" /install

 

pnputil /add-driver "%~dp0MESW_Components\wiman_wlan_extension\wiman_wlan_extension.inf" /install

pnputil /add-driver "%~dp0MESW_Components\WiMan\WiMan.inf" /install

Reply
Options

6513 Posts

10-29-2009

NC

17651 Signins

162019 Page Views

  • Posts: 6513
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 162019
  • Message 9 of 14

Re:Intel ME WMI Provider missing

2020-10-16, 12:19 PM

@MegaMan31 you should be able to use the same ME software package that I provided in message #3 of this thread.  Use the driver from the support website, and then install the software to get the WMI provider that you are looking for.

Reply
Options

33 Posts

10-08-2010

US

38 Signins

644 Page Views

  • Posts: 33
  • Registered: ‎10-08-2010
  • Location: US
  • Views: 644
  • Message 10 of 14

Re:Intel ME WMI Provider missing

2020-10-19, 18:48 PM

Someotherguy,

 

The SetupME.exe installer linked above does successfully generate the IntelME namespace in WMI on our 7th-gen Carbons (Model 20Q*), but it also replaced the Intel MEI Driver 2013.14.0.1529 (the latest version available for models 20Q*, contains mitigations for CVE-2020-8758) with version 2021.14.0.1615 which is not listed as an available version for the 7th-gen Carbon models.

 

Should we instead use the "SetupMe.exe -nodrv" parameter to prevent the driver installation? Is using the above SetupME.exe from another model a supported solution if we run into problems with the Intel ME on the 7th-gen Carbons? Lastly, what is the timeline for getting the classic SetupME.exe + Drivers package for this model back? The above method seems very kludgy.

 

Thanks

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete