English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

0 Posts

01-22-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎01-22-2020
  • Location: US
  • Views: 0
  • Message 1 of 11

Lenovo T450s - network card shows 100mbps only

2020-01-22, 12:02 PM

Hello,

yesterday I found there is some problem with my network card. It shows 100mbps only. It's connected to gigabit mikrotik routerboard. I tried to connect it to another gigabit port, same result. Tried to change cable, same result. 

 

With another notebook, same cable, same gigabit port it shows 1gbps without any problems.

 

Using latest Windows 10 Pro 64bit (official).

Checked drivers, have latest I think (used automatic driver update and manual driver update)

 

Intel(R) Ethernet Connection (3) I218-LM

 

I downloaded latest driver from lenovo but it shows me I already have that driver

https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t450s/downloads/driver-list/component?name=Networking%3A%20LAN%20%28Ethernet%29

 

Any idea what is bad and how to fix that?

 

Some screens

 

 

Reply
Options

385 Posts

06-26-2016

DE

941 Signins

11804 Page Views

  • Posts: 385
  • Registered: ‎06-26-2016
  • Location: DE
  • Views: 11804
  • Message 2 of 11

Re: Lenovo T450s - network card shows 100mbps only

2020-01-22, 15:46 PM

 

check if nic  has  "auto negotiation" enabled

 

 

 

If "auto negotiation" was enabled than check if the rj45 lan port  has any damaged/bent  pins. Maybe you'll need to clean  the port if it had not been used for a long time?

 

Reply
Options

0 Posts

01-22-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎01-22-2020
  • Location: US
  • Views: 0
  • Message 3 of 11

Re: Lenovo T450s - network card shows 100mbps only

2020-01-22, 16:37 PM

Hello,

auto negotiation is enabled.

Tried to clean RJ45 port, same result.

 

Will format HDD and install WIN10 if it's necessary

Reply
Options

8362 Posts

01-13-2008

US

77313 Signins

2195224 Page Views

  • Posts: 8362
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2195224
  • Message 4 of 11

Re: Lenovo T450s - network card shows 100mbps only

2020-01-22, 16:40 PM

 wrote:

Hello,

auto negotiation is enabled.

Tried to clean RJ45 port, same result.

 

Will format HDD and install WIN10 if it's necessary


Before a full reinstall it might be worth booting a live Linux flash drive and seeing @ what speed it runs the port.  Could help distinguish between hardware and software problem.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

385 Posts

06-26-2016

DE

941 Signins

11804 Page Views

  • Posts: 385
  • Registered: ‎06-26-2016
  • Location: DE
  • Views: 11804
  • Message 5 of 11

Re: Lenovo T450s - network card shows 100mbps only

2020-01-22, 16:44 PM

 

before reinstalling everything I would try another LAN cable first. Maybe try a linux live CD and see if you get same 100Mbit only connection. 

 

Lan port:  for 1GB to work propperly all 8 pins need to have good contacts to the rj-45 plug.

 

 

 

Reply
Options

0 Posts

01-22-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎01-22-2020
  • Location: US
  • Views: 0
  • Message 6 of 11

Re: Lenovo T450s - network card shows 100mbps only

2020-01-22, 16:53 PM

Ok tried it with Ubuntu 18.04 Live, same result. 100mbps.

 

So what's now?

Reply
Options

385 Posts

06-26-2016

DE

941 Signins

11804 Page Views

  • Posts: 385
  • Registered: ‎06-26-2016
  • Location: DE
  • Views: 11804
  • Message 7 of 11

Re: Lenovo T450s - network card shows 100mbps only

2020-01-22, 17:00 PM

1. try another cable

2. try another port

3. try setting port to 1GB only

4. try setting NIC to 1GB only    

5. try another switch

6. try a direct  nic to nic connect.

 

Reply
Options

0 Posts

01-22-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎01-22-2020
  • Location: US
  • Views: 0
  • Message 8 of 11

Re: Lenovo T450s - network card shows 100mbps only

2020-01-22, 17:01 PM

1. tried 2 another cables

2. tried another ports in mikrotik (it has gigabit ports), tried another mikrotik at work

3. tried to change auto negotiation to 1gbps full duplex, connection didn't work

4. what is it?

5. tried another mikrotik at work. Tried cisco switch too

6. what is it?

Reply
Options

385 Posts

06-26-2016

DE

941 Signins

11804 Page Views

  • Posts: 385
  • Registered: ‎06-26-2016
  • Location: DE
  • Views: 11804
  • Message 9 of 11

Re: Lenovo T450s - network card shows 100mbps only

2020-01-22, 17:11 PM

3.  configure switch port  to 1GB only

4.  configure the lan interface (=NIC)  from 'auto neg'  to 1GB only 

6.  you connect two devices w/o any switch directly with a lan cable

 

But I suspect some physical issues.  Either not all pins make contact to the plug, or the pins don't have contact to pcb.

Open device and check connections  from port  to motherboard.

 

Reply
Options

0 Posts

01-22-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎01-22-2020
  • Location: US
  • Views: 0
  • Message 10 of 11

Re: Lenovo T450s - network card shows 100mbps only

2020-01-22, 17:59 PM

3. tried it now, same result

4. tried, if I set 1gbps only, connection doesn't work

6. tried it, 100mbps still

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete