Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

26 Posts

05-30-2009

USA

34 Signins

468 Page Views

  • Posts: 26
  • Registered: ‎05-30-2009
  • Location: USA
  • Views: 468
  • Message 1 of 8

Lenovo T510 Freezes Randomly

2011-11-02, 19:17 PM

I have a newer T510 laptop that my company gave me. We have approximately twenty T510's in the company and I would say 6-8 people have complained that at random their computer freezes. Mine is one of them. I've found only a handful of threads but it doesn't appear that anyone has a solution.

 

My computer freezes at random while plugged in or running on battery. The computer itself doesn't seem like its frozen just the screen, but there is no way to shut down properly or save any work. The mouse doesn't work and the only way to shut down is pulling the battery or pressing down the power button. I would say a random freeze happens once a month and my computer is on 10hrs a day.

 

Can anyone help? Is there any known solutions? Does Lenovo know there is a problem? I have a feeling more and more people in our office are having this problem but their just not saying anything.

 

Thanks in advance.

Lenovo T500 - Windows XP Professional
Reply
Options

20 Posts

08-07-2011

Lithuania

116 Signins

304 Page Views

  • Posts: 20
  • Registered: ‎08-07-2011
  • Location: Lithuania
  • Views: 304
  • Message 2 of 8

Re: Lenovo T510 Freezes Randomly

2011-11-03, 20:58 PM

Hi.

I had this problem earlier before. I completely reinstalled Windows and thought the problem was solved (I had no crashes for a couple of weeks). But they came back again. I experience them about every 2-3 days. It happens randomly and not under heavy load. Usually when watching a movie, watching a video on youtube or browsing internet.

Should I consider taking my laptop to the warranty service? Could someone from Lenovo tech support reply about this issue and Lenovo aware of this problem?

 

EDIT: I had the crush just a second ago. Found 1 critical, 3 error and 3 warnings. I was watching a movie.

 

I will paste the errors here one by one in a row.

 

 

 

I've experienced the shutdown at 22:52:19

 

On 22:53:13 I've found the critical error (after the system boots?):

 

The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

Source: Kernel-Power

Event ID: 41

Task Category (63)

Keywords: (2)

 

- System 

  - Provider 

   [ Name]  Microsoft-Windows-Kernel-Power 
   [ Guid]  {331C3B3A-2005-44C2-AC5E-77220C37D6B4} 
 
   EventID 41 
 
   Version 2 
 
   Level 1 
 
   Task 63 
 
   Opcode 0 
 
   Keywords 0x8000000000000002 
 
  - TimeCreated 

   [ SystemTime]  2011-11-03T20:53:13.724410900Z 
 
   EventRecordID 25636 
 
   Correlation 
 
  - Execution 

   [ ProcessID]  4 
   [ ThreadID]  8 
 
   Channel System 
 
   Computer Giedrius-PC 
 
  - Security 

   [ UserID]  S-1-5-18 
 

- EventData 

  BugcheckCode 0 
  BugcheckParameter1 0x0 
  BugcheckParameter2 0x0 
  BugcheckParameter3 0x0 
  BugcheckParameter4 0x0 
  SleepInProgress false 
  PowerButtonTimestamp 0 

 

Followed by a warning at 22:53:20: (3 times in the last 24 hrs)

 

The driver \Driver\WUDFRd failed to load for the device USB\VID_147E&PID_2016\6&24bfad55&0&3.

Source: Kernel-PnP

Event ID: 219

Task Category: (212)

 

- System 

  - Provider 

   [ Name]  Microsoft-Windows-Kernel-PnP 
   [ Guid]  {9C205A39-1250-487D-ABD7-E831C6290539} 
 
   EventID 219 
 
   Version 0 
 
   Level 3 
 
   Task 212 
 
   Opcode 0 
 
   Keywords 0x8000000000000000 
 
  - TimeCreated 

   [ SystemTime]  2011-11-03T20:53:20.307622500Z 
 
   EventRecordID 25649 
 
   Correlation 
 
  - Execution 

   [ ProcessID]  4 
   [ ThreadID]  60 
 
   Channel System 
 
   Computer Giedrius-PC 
 
  - Security 

   [ UserID]  S-1-5-18 
 

- EventData 

  DriverNameLength 36 
  DriverName USB\VID_147E&PID_2016\6&24bfad55&0&3 
  Status 3221226341 
  FailureNameLength 14 
  FailureName \Driver\WUDFRd 
  Version 0 

 

 

Another warning at 22:53:23: (3 times in the last 24 hrs)

 

Intel(R) 82579LM Gigabit Network Connection
Network link is disconnected.

Source: e1cexpress

Event ID: 27

Task Category: None

Keywords: Classic

 

- System 

  - Provider 

   [ Name]  e1cexpress 
 
  - EventID 27 

   [ Qualifiers]  40964 
 
   Level 3 
 
   Task 0 
 
   Keywords 0x80000000000000 
 
  - TimeCreated 

   [ SystemTime]  2011-11-03T20:53:23.209227600Z 
 
   EventRecordID 25657 
 
   Channel System 
 
   Computer Giedrius-PC 
 
   Security 
 

- EventData 

    
   Intel(R) 82579LM Gigabit Network Connection 
   0000040002003000000000001B0004A00000000000000000000000000000000000000000000000001B0004A0 


--------------------------------------------------------------------------------

Binary data:


In Words

0000: 00040000 00300002 00000000 A004001B 
0008: 00000000 00000000 00000000 00000000 
0010: 00000000 00000000 A004001B  


In Bytes

0000: 00 00 04 00 02 00 30 00   ......0.
0008: 00 00 00 00 1B 00 04 A0   ....... 
0010: 00 00 00 00 00 00 00 00   ........
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........
0028: 1B 00 04 A0               ... 

 

 

And at the same time (22:53:23) I've found an error: (happened 3 times in a 7 day period)

 

The previous system shutdown at 22:52:19 on ‎2011.‎11.‎03 was unexpected.

Source: EventLog

Event ID: 6008

Task Category: None

Keywords: Classic

 

- System 

  - Provider 

   [ Name]  EventLog 
 
  - EventID 6008 

   [ Qualifiers]  32768 
 
   Level 2 
 
   Task 0 
 
   Keywords 0x80000000000000 
 
  - TimeCreated 

   [ SystemTime]  2011-11-03T20:53:23.000000000Z 
 
   EventRecordID 25645 
 
   Channel System 
 
   Computer Giedrius-PC 
 
   Security 
 

- EventData 

   22:52:19 
   ‎2011.‎11.‎03 
    
    
   45146 
    
    
   DB070B0004000300160034001300D003DB070B0004000300140034001300D0033C0000003C000000000000000000000000000000000000000100000000000000 


--------------------------------------------------------------------------------

Binary data:


In Words

0000: 000B07DB 00030004 00340016 03D00013 
0008: 000B07DB 00030004 00340014 03D00013 
0010: 0000003C 0000003C 00000000 00000000 
0018: 00000000 00000000 00000001 00000000 


In Bytes

0000: DB 07 0B 00 04 00 03 00   Û.......
0008: 16 00 34 00 13 00 D0 03   ..4...Ð.
0010: DB 07 0B 00 04 00 03 00   Û.......
0018: 14 00 34 00 13 00 D0 03   ..4...Ð.
0020: 3C 00 00 00 3C 00 00 00   <...<...
0028: 00 00 00 00 00 00 00 00   ........
0030: 00 00 00 00 00 00 00 00   ........
0038: 01 00 00 00 00 00 00 00   ........

 

 

At 22:53:29 I get another error: (happened 3 times during the last 24 hrs)

 

The DgiVecp service failed to start due to the following error:
The system cannot find the device specified.

Source: Service Control Manager

Event ID: 7000

Task Category: None

Keywords: Classic

 

- System 

  - Provider 

   [ Name]  Service Control Manager 
   [ Guid]  {555908d1-a6d7-4695-8e1e-26931d2012f4} 
   [ EventSourceName]  Service Control Manager 
 
  - EventID 7000 

   [ Qualifiers]  49152 
 
   Version 0 
 
   Level 2 
 
   Task 0 
 
   Opcode 0 
 
   Keywords 0x8080000000000000 
 
  - TimeCreated 

   [ SystemTime]  2011-11-03T20:53:29.765640500Z 
 
   EventRecordID 25701 
 
   Correlation 
 
  - Execution 

   [ ProcessID]  792 
   [ ThreadID]  796 
 
   Channel System 
 
   Computer Giedrius-PC 
 
   Security 
 

- EventData 

  param1 DgiVecp 
  param2 %%20 

 

 

At 22:53:32 I find another warning: (3 times in the last 24 hrs)

 

Custom dynamic link libraries are being loaded for every application. The system administrator should review the list of libraries to ensure they are related to trusted applications.

Source: wininit

Event ID: 11

Task Category: None

 

- System 

  - Provider 

   [ Name]  Microsoft-Windows-Wininit 
   [ Guid]  {206F6DEA-D3C5-4D10-BC72-989F03C8B84B} 
 
   EventID 11 
 
   Version 0 
 
   Level 3 
 
   Task 0 
 
   Opcode 0 
 
   Keywords 0x4000000000000000 
 
  - TimeCreated 

   [ SystemTime]  2011-11-03T20:53:32.714045600Z 
 
   EventRecordID 25718 
 
   Correlation 
 
  - Execution 

   [ ProcessID]  736 
   [ ThreadID]  768 
 
   Channel System 
 
   Computer Giedrius-PC 
 
  - Security 

   [ UserID]  S-1-5-18 
 

- EventData 

  StringCount 1 
  String C:\Windows\system32\nvinitx.dll 

 

 

And the last error is logged at 22:53:38: (3 times during the 24 hr period)

 

Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.

Source: WMI

Event ID: 10

Task Category: None

Keywords: Classic

 

- System 

  - Provider 

   [ Name]  Microsoft-Windows-WMI 
   [ Guid]  {1edeee53-0afe-4609-b846-d8c0b2075b1f} 
   [ EventSourceName]  WinMgmt 
 
  - EventID 10 

   [ Qualifiers]  49152 
 
   Version 0 
 
   Level 2 
 
   Task 0 
 
   Opcode 0 
 
   Keywords 0x80000000000000 
 
  - TimeCreated 

   [ SystemTime]  2011-11-03T20:53:38.000000000Z 
 
   EventRecordID 7166 
 
   Correlation 
 
  - Execution 

   [ ProcessID]  0 
   [ ThreadID]  0 
 
   Channel Application 
 
   Computer Giedrius-PC 
 
   Security 
 

- EventData 

   //./root/CIMV2 
   SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99 
   0x80041003 

 

 

 

That's everything that I've found in the event viewer right after the freeze. Hope this helps. I haven't seen the last two errors before.

 

I think the errors and warning that occured 3 times happens whenever the OS is booted. The ones that happened only once might cause the problem, though I'm not sure.

ThinkPad T520 i5-2410M(2.3GHz), 4GB RAM, 500GB 7200rpm HD, 15.6in 1600x900 LCD, NVIDIA NVS 4200M 1GB
Reply
Options

1 Posts

11-12-2011

Dumaguete Philippines

2 Signins

13 Page Views

  • Posts: 1
  • Registered: ‎11-12-2011
  • Location: Dumaguete Philippines
  • Views: 13
  • Message 3 of 8

Re: Lenovo T510 Freezes Randomly

2011-11-12, 12:20 PM

Hi also experiences this it really bothers me for i have to do emergency shut down so i can use the computer again. Im using lenove z470 

 

Could anyone it here help us how to solve this issue!!!

Reply
Options

315 Posts

02-21-2008

Singapore

577 Signins

3826 Page Views

  • Posts: 315
  • Registered: ‎02-21-2008
  • Location: Singapore
  • Views: 3826
  • Message 4 of 8

Re: Lenovo T510 Freezes Randomly

2011-11-12, 14:58 PM

These are the common problem

 

a) Most of the freezes I have experienced are due to graphic card problem. This is IMHO a intel-lenovo, or Nvdia-lenovo driver problem.

b) A second common source of problem is overheating of the graphic card, especially during intense movie, gaming.

c) A rare but possible problem is the window networking (especially window xp) trying to find the domain, IP address, network cache or whatever. The issue was so random that I don't think there was a solution. You will experience this if you ever try to connect to a network and find a disk drive, it just 'freeze' till the correct IP and window network name is 'resolved'. Some googled solutions shows that you can set the search time to faster, eg 1 second instead of the default.....with some compromise of course.

 

My suggestion is

 

a) You can try process tamer, a freeware at  http://www.donationcoder.com/Software/Mouser/proctamer/  What this does is to reduce the process that is hogging the system and at least give you back some control from the 'freezing'. This works great for me when using XP. You can also see which process is the culprit 

 

b) From Bios set the CPU Stepping to be 'balance' instead of maximum performance for AC or battery operation mode.

 

c) You can download an official window 7 that can be tested for 30 days before activation is required. Set a 30GB partition and install this into that partition. When bootup you can choose XP or window 7. This is for you to use window 7 to see if the freezing still occurs.

Reply
Options

20 Posts

08-07-2011

Lithuania

116 Signins

304 Page Views

  • Posts: 20
  • Registered: ‎08-07-2011
  • Location: Lithuania
  • Views: 304
  • Message 5 of 8

Re: Lenovo T510 Freezes Randomly

2011-11-15, 12:11 PM
Thanks for the reply! I will try the process tamer app.

Also, I'll set the CPU to balance and see if that helps too.

By the way, I'm on Windows 7 64bit at the moment so I don't think, that installing another copy of them would be any help.
ThinkPad T520 i5-2410M(2.3GHz), 4GB RAM, 500GB 7200rpm HD, 15.6in 1600x900 LCD, NVIDIA NVS 4200M 1GB
Reply
Options

315 Posts

02-21-2008

Singapore

577 Signins

3826 Page Views

  • Posts: 315
  • Registered: ‎02-21-2008
  • Location: Singapore
  • Views: 3826
  • Message 6 of 8

Re: Lenovo T510 Freezes Randomly

2011-11-15, 14:00 PM

Actually it sometimes helps to install another window to test for operating system errors. Sometime errors in graphics/network/weird drivers cannot be eradicated, no matter how many times you uninstall, resinstall, update, or downgrade the drivers.You can clean the registy, try custom settings and nothing will work because of some weird bug.

 

I have some of these random crashes due to graphic cards with several of my models T400, T410s, X301 etc.

 

The only 'fast' way I have found is to install a fresh window on the same laptop, so that when you boot up, you can select the fresh window 7 partition and see if the same problems occurs. If the sympton stopped, it is simply porting over the personal data, delete the original window 7 partition, or use the recovery partition to start fresh.

 

Obviously before doing a fresh start, it's faster to create a new partiiton, install a trial window 7 to see if it works. With window 7, it only takes around 20 mins on a SSD.

Reply
Options

20 Posts

08-07-2011

Lithuania

116 Signins

304 Page Views

  • Posts: 20
  • Registered: ‎08-07-2011
  • Location: Lithuania
  • Views: 304
  • Message 7 of 8

Re: Lenovo T510 Freezes Randomly

2011-11-22, 15:25 PM
It's been over a week since I've started using the soft you've suggested me and switched the CPU stepping to balance and I haven't experienced a single freeze. I used to get like 3 a week or so before this.

Thanks!!
ThinkPad T520 i5-2410M(2.3GHz), 4GB RAM, 500GB 7200rpm HD, 15.6in 1600x900 LCD, NVIDIA NVS 4200M 1GB
Reply
Options

1 Posts

08-25-2013

Stockholm, Sweden

2 Signins

30 Page Views

  • Posts: 1
  • Registered: ‎08-25-2013
  • Location: Stockholm, Sweden
  • Views: 30
  • Message 8 of 8

Re: Lenovo T510 Freezes Randomly

2013-08-25, 19:03 PM

wrote:

These are the common problem

 

a) Most of the freezes I have experienced are due to graphic card problem. This is IMHO a intel-lenovo, or Nvdia-lenovo driver problem.

b) A second common source of problem is overheating of the graphic card, especially during intense movie, gaming.

c) A rare but possible problem is the window networking (especially window xp) trying to find the domain, IP address, network cache or whatever. The issue was so random that I don't think there was a solution. You will experience this if you ever try to connect to a network and find a disk drive, it just 'freeze' till the correct IP and window network name is 'resolved'. Some googled solutions shows that you can set the search time to faster, eg 1 second instead of the default.....with some compromise of course.

 

My suggestion is

 

a) You can try process tamer, a freeware at  http://www.donationcoder.com/Software/Mouser/proctamer/  What this does is to reduce the process that is hogging the system and at least give you back some control from the 'freezing'. This works great for me when using XP. You can also see which process is the culprit 

 

b) From Bios set the CPU Stepping to be 'balance' instead of maximum performance for AC or battery operation mode.

 

c) You can download an official window 7 that can be tested for 30 days before activation is required. Set a 30GB partition and install this into that partition. When bootup you can choose XP or window 7. This is for you to use window 7 to see if the freezing still occurs.


I have similar problems, so I chose not to start a new thread, but rather reply here.

 

I downloaded the "Process Tamer", without any help.

 

I tried to change the CPU settings in the BIOS, but could not find the options for "CPU Stepping". I attach a photo of the BIOS screen of my T510.

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms