English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

987 Posts

06-03-2011

United States of America

591 Signins

14790 Page Views

  • Posts: 987
  • Registered: ‎06-03-2011
  • Location: United States of America
  • Views: 14790
  • Message 1 of 10

My T420 Review + Warranty Experience + Accessories & Upgrades

2011-07-02, 21:13 PM

I received my T420 earlier this week and wanted to let everyone know my experiences with the machine itself as well as some accessories I purchased for it. You will see comparisons to the T400. The T400 is my SO's machine. Machine details for both are in my sig. The T420 shipped with a 500GB HDD & 4GB (4x1) RAM. This review is mainly about the T420 with the HDD installed, but with 8GB of RAM.

 

A little about me

As a student I mainly care about battery life, boot/ resume time, and system stability. Stability is very important to me because I take my class notes on my computer and we take exams on our computers as well. If I have computer issues during an exam, I could receive a worse grade or even fail. I fell in love with Thinkpads and the trackpoint the first time I ever used one years ago back in the era of 266MHz processors. While I have owned other laptop brands (Gateway, Acer, Compaq) it was soley because of price. I am happy to have a Thinkpad to call my own again.

 

For a while, I considered an x220, the x220t, and the W520. I decided I could not live with the screen resolution on the x220, the 3yr Think Pad protection + on-site was too much on the x220t ($459 vs $259 for other Think Pads), and I did not want to haul around the extra weight and size of the W520. This is my third 14" ThinkPad. I bought the machine during a sale where there was a free upgrade to 500GB HDD and 4GB of RAM. At the same time there was an extra 5% off on any T series. With those deals and the educational discount, I felt the T420 was an excellent deal.

 

Summary

 

Pros: Speed; Battery life; I do not have a screen door screen; warranty service is great; Keyboard is a joy to type on.

 

Cons: Louder than the T400 (T420 seems to have smaller heatsink). Mainboard, Keyboard, and Palm rest had to be replaced. Keyboard needs to be replaced again. Smelled bad when taking out of box. 14W sleeve is too big.

 

Review


When I unboxed the machine the fist thing I noticed was a horrible smell that I can only describe as "new computer smell" it was a mixture of ozone plus melted plastic. The 9 cell sure is a big battery. I only have a 6 cell on my T400. The 9 cell on the T420 sticks out about the same amount as the 6 cell on the T400 does. Machine feels like a good weight and very solid. Weighs 5.2lbs without the power brick (with HDD + 8GB RAM, Optical Drive, and 9 cell battery).

 

When I pressed the power button the first thing I noticed was that I could hear the fan. The fan on the T400 is almost inaudible. On the T420, you can hear the fan is there, but it is a quiet and soft fan noise. The T420 seems to have a smaller heat sink compared to the T400. The machine boots fast even with the HDD installed taking only about 80-90 seconds or so after applying all Windows updates. Display resolution of 1600x900 is very sharp and useful for putting documents side by side. My external monitors are 16:9 displays (2x Dell U2211h) so it is nice to have matching aspect ratios. I would prefer 16:10, but 16:9 at 1600x900 is enough pixels. Optimus works fine and allowed me to have both of the U2211h at 1920x1080 and the internal display on at the same time. I had one monitor connected through VGA and the other over display port. I do not see the screen door effect that some people have had issues with on these screens. I was very worried about the screen door, so I am glad not to have it.

 

I mainly use my computer to run Office, One Note, and write emails. I rarely do any gaming on my laptop. I do some image editing (GIMP, Inkscape) and both programs run fine with great speed. Machine sleeps and hibernates fine. I get great range and speed with the internal wireless card that is better than most people. Ran a graphics intensive benchmark and Optimus works great. Battery life seems amazing so far. I only used about 10% in an meeting that lasted over an hour. I was only typing during the meeting so I had the brightness turned down to 2. If I wanted to I could probably use just the battery and leave the adapter at home.

 

Accessories


I bought the machine with the 14W Sleeve (57Y4294). The sleeve is gigantic and does not fit right. I think it was designed to hold the machine with a 9 cell battery + the slice + the power adapter. I will check later, but I think I could probably fit the T400 and the T420 into the sleeve at the same time and it would still have extra room. I may return the sleeve and buy a different one as I was hoping for a better fit. I have no idea why they offer the 15W Sleeve during the ordering process as the 14W is huge.

 

Upgrades


I added an extra 4GB of Samsung RAM, an Intel 320 SSD in the 160 GB size, and an AKE USB 3.0 Expresscard 34. I planned to use the USB 3.0 express card with the 500GB drive in an external enclosure as a backup for both the T420 and T400. If I was just looking for the T420 I would simply have used the eSATA port as I feel eSATA is probably faster than USB 3.0.

 

The RAM works great with the factory installed Samsung RAM. The RAM was easy to install, since the cover is on the bottom of the machine. If you are upgrading both RAM slots, the other slot is under the keyboard. The HMM shows the keyboard as being held in with only one screw so it is probably easy to upgrade.

 

I bought the 320 because it is supposed to be as reliable as the X-25M. My Intel 320 SSD died on me within 12 hours of installing it into the machine. I experienced the 8MB bug, where the drive dies and reports as unformatted and 8MB in size, normally after an "unsafe" shutdown (as in holding down the power button/ sudden loss of power). There has been talk of this bug on the Intel Forums since June, see this post or just Google for more details about the issue many 320 owners are experiencing. My replacement 320 is here now, and I will see if I can get >12 hours of use out of it. The Intel Data Migration software did work well and it cloned the drive over and resized the partitions just fine. I was able to see speeds of up to 250MB/sec with the SSD internally. I regret purchasing the 320, and if the second dies on me I will ask for a refund and buy something else.

 

The AKE USB 3.0 Express Card has the NEC USB chipset. These are known to get around 180MB/sec when mounted on a motherboard and connected to a fast SSD. I saw speeds of up to 185MB/sec when connected to the Intel SSD. I am happy with the Express card. It sits flush in the Express Card slot. It does look ugly with the extra USB cable for power, but that is necessary to supply full power to a USB 3.0 device.

 

Warranty Service (2 Keyboards, 1 Palm Rest, 1 System Board)

 

When I purchased the 3yr warranty with Think Pad protection and on-site service, I never thought I would need to use it in the first week. I notice that the Trackpoint seemed a little jumpy when I first started using the machine. The first night I had the machine I was working on a project, something caused the machine to hang and it shutdown. On reboot, the machine refused to POST. My first thought was that I seated the RAM improperly, so I took that out. It did not help. I reseated the SSD, nothing. Tried the original HDD, nothing. Put the SSD back in. The keyboard had the microphone mute, speaker mute, and caps lock lights on when the machine was off. That seemed odd to me. Next day, I called up service center. It said it was in Atlanta, Georgia, but guy I spoke to had such a heavy accent I had to have him repeat everything 2-3 times. He had me run through some things and decided that the keyboard was fine, but that the system board needed to be replaced.

 

A friendly Tech came out and replaced the system board. System booted off of the tech's usb floppy to run a utility. Lights were still on the keyboard. Keyboard did not work. I grabbed a USB external keyboard + mouse combo from my desktop and plugged it in. USB mouse and keyboard worked fine. Tech attempted to boot into Windows. System did not recognize SSD on first two boots, third boot it worked. Odd beeping sound in Windows, put volume on mute. Laptop keyboard still did not work, and touchpad was very jumpy. Tech called to order keyboard + palm rest (touchpad) and I ran ThinkVantage Toolbox scan. Machine passed. Reactivated Windows. I then used the machine for a few hours, and then hibernated it. When I came back, it acted like the SSD was not there.

 

Tech arrived the next day with Keyboard + palm rest. I was very happy that the part was overnighted. New keyboard installed. Seemed like everything was working. System refused to boot off of the SSD. Put in HDD, system boots fine. I ran ThinkVantage Toolbox scan and the machine passed. A few hours after the tech left, I noticed that my J & K keys were acting odd. Turned out keyboard screw was hitting underneath them and making it hard to press down. See this thread for more. Called tech support, guy I spoke with did not have an accent and seemed like a native English speaker. Happy to have someone I could understand on the phone. Backedout the keyboard screw about halfway and now I can type normally. Tech support is concerned that the keyboard may have been damaged by the screw, so they are sending a new keyboard and a screw kit. Scew kit is backordered, so for now I just have to wait.

 

I have been happy with the on-site service because it is much faster than having to ship off a machine to have it repaired. I am going to look into upgrading the depot warranty on my T400 to on-site. I am chalking up the problem with the system board and keyboard to the bathtub curve and I do not see these as major issues. I wish that they would have shipped both a keyboard and a system board.

 

Overall I am happy with my T420 and very happy with the warranty service. I would feel confident recommending this machine with the warranty to family and friends.

X1 Carbon 3rd Gen Type 20BT i7-5500U, 2560x1440 (non-touch), Win 10 Pro, 8GB RAM, 512 SSD, Intel 7625 WiFi, BT 4.0 | ThinkVision P24q-10 monitor

------------------------------------------
When asking for help, post your question in the forum. Remember to include your system type, model number, and OS. Do not post your serial number.

Did someone help you today? Thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help others with the same question in the future.
Reply
Options

987 Posts

06-03-2011

United States of America

591 Signins

14790 Page Views

  • Posts: 987
  • Registered: ‎06-03-2011
  • Location: United States of America
  • Views: 14790
  • Message 2 of 10

Re: My T420 Review + Warranty Experience + Accessories & Upgrades

2011-07-04, 22:37 PM

Update: so I did try to fit both a T420 and a T400 into the 14W sleeve and while it was a tight fit vertically, they both fit. This gives you an idea of how large the sleeve is. 

X1 Carbon 3rd Gen Type 20BT i7-5500U, 2560x1440 (non-touch), Win 10 Pro, 8GB RAM, 512 SSD, Intel 7625 WiFi, BT 4.0 | ThinkVision P24q-10 monitor

------------------------------------------
When asking for help, post your question in the forum. Remember to include your system type, model number, and OS. Do not post your serial number.

Did someone help you today? Thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help others with the same question in the future.
Reply
Options

2 Posts

12-31-2011

Florida, United States

8 Signins

19 Page Views

  • Posts: 2
  • Registered: ‎12-31-2011
  • Location: Florida, United States
  • Views: 19
  • Message 3 of 10

Re: My T420 Review + Warranty Experience + Accessories & Upgrades

2011-12-31, 20:20 PM

There are several companies that make the screens for this model. Which do you have?

 

If you are unsure, can you do the community a huge favor and run AIDA64 or a similar app to findout? If you go to the display section, it will show you the serial of the screen (not the Lenovo part number).

 

http://download.cnet.com/AIDA64-Extreme-Edition/3000-2094_4-75317065.html

Reply
Options

2 Posts

12-31-2011

Florida, United States

8 Signins

19 Page Views

  • Posts: 2
  • Registered: ‎12-31-2011
  • Location: Florida, United States
  • Views: 19
  • Message 4 of 10

Re: My T420 Review + Warranty Experience + Accessories & Upgrades

2011-12-31, 20:52 PM
HWiNFO is free and doesn't require installation. See http://www.hwinfo.com/download64.html. It shows as Monitor Name (Manuf) under monitor.
Reply
Options

8824 Posts

01-13-2008

United States of America

77618 Signins

2217450 Page Views

  • Posts: 8824
  • Registered: ‎01-13-2008
  • Location: United States of America
  • Views: 2217450
  • Message 5 of 10

Re: My T420 Review + Warranty Experience + Accessories & Upgrades

2012-01-01, 0:27 AM

Hi nibs,

 

Nice review.  Thanks.

 

That screw deal is very strange.  I wonder if the tech mixed up two screw sizes? Maybe there's a short one somewhere just barely hanging on.  Do the screw holes on your machine have a size # next to them.  Just curious.

 

@ seasidegator, your link doesn't work as is.  The "." at the end of the sentence got included in the link.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

987 Posts

06-03-2011

United States of America

591 Signins

14790 Page Views

  • Posts: 987
  • Registered: ‎06-03-2011
  • Location: United States of America
  • Views: 14790
  • Message 6 of 10

Re: My T420 Review + Warranty Experience + Accessories & Upgrades

2012-01-01, 21:17 PM

It shows as a Lenovo LEN40A1 under Monitor Name and a B140RW02 V1 under Monitor Name (Manuf). The panel was manufactured W1 of 2010. Let me know if there is anything else that would be useful.

 

I will note that I do have the matte coating effect on the screen, as in when looked at from the correct angle and if the correct color is showing (frequently white) it seems to sparkle a little. I've noticed this on every screen I've ever owned that wasn't usable as a mirror, so I've always assumed this was normal.

 

The screws holes on my machine do not have a # on them.

X1 Carbon 3rd Gen Type 20BT i7-5500U, 2560x1440 (non-touch), Win 10 Pro, 8GB RAM, 512 SSD, Intel 7625 WiFi, BT 4.0 | ThinkVision P24q-10 monitor

------------------------------------------
When asking for help, post your question in the forum. Remember to include your system type, model number, and OS. Do not post your serial number.

Did someone help you today? Thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help others with the same question in the future.
Reply
Options

8 Posts

12-26-2011

Israel

5 Signins

76 Page Views

  • Posts: 8
  • Registered: ‎12-26-2011
  • Location: Israel
  • Views: 76
  • Message 7 of 10

Re: My T420 Review + Warranty Experience + Accessories & Upgrades

2012-01-01, 22:28 PM

so you as well got this third grade quality display from AUO...

i thought that people who ordered thier laptop with Nvidia at least got Samsung display but probably not.

 

sorry for you that you have to accept such a low quality display

Reply
Options

1 Posts

01-09-2012

Cambridge, MA

1 Signins

6 Page Views

  • Posts: 1
  • Registered: ‎01-09-2012
  • Location: Cambridge, MA
  • Views: 6
  • Message 8 of 10

Re: My T420 Review + Warranty Experience + Accessories & Upgrades

2012-01-09, 5:25 AM

Hi, I wish to buy a slice to increase the battery life for my thinkpad t420 4177....

I already own a 9cell battery...

Can you please suggest me the specification for the battery slice....
It will be great if you could send any links to amazon, etc...

Reply
Options

987 Posts

06-03-2011

United States of America

591 Signins

14790 Page Views

  • Posts: 987
  • Registered: ‎06-03-2011
  • Location: United States of America
  • Views: 14790
  • Message 9 of 10

Re: My T420 Review + Warranty Experience + Accessories & Upgrades

2012-01-10, 19:23 PM

The display is good enough for what I use it for after I calibrated it with my Spyder3. I generally only use the display when I'm on battery and have the brightness below 3 or as my third display to show what music I currently have playing when I'm at my desk in a 3 display setup. The other two are Dell U2211h monitors with IPS panels and 100% sRGB coverage.

 

If I wanted a higher quality display I would have purchased an X220 with the IPS panel or the W520 with the 95% Gamut full HD panel. I expected nothing better than the panel in my T400 with the T420 and received a panel within my expectations. Do I wish Lenovo would have let me pay more to have an IPS panel? Yes, I would love an IPS panel on a 14" T-series. I'm more or less stuck with the 14" form factor due to display resolution, ports, expandability, and portability. I had a 15.6" laptop previously, and it was not ideal for how I use my machine.

 

@chinmayarjoshi

 

I'd buy any battery direct from Lenovo. I've heard of people having issues with non-direct batteries.

X1 Carbon 3rd Gen Type 20BT i7-5500U, 2560x1440 (non-touch), Win 10 Pro, 8GB RAM, 512 SSD, Intel 7625 WiFi, BT 4.0 | ThinkVision P24q-10 monitor

------------------------------------------
When asking for help, post your question in the forum. Remember to include your system type, model number, and OS. Do not post your serial number.

Did someone help you today? Thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help others with the same question in the future.
Reply
Options

13 Posts

09-20-2011

United Kingdom

17 Signins

97 Page Views

  • Posts: 13
  • Registered: ‎09-20-2011
  • Location: United Kingdom
  • Views: 97
  • Message 10 of 10

Re: My T420 Review + Warranty Experience + Accessories & Upgrades

2012-02-02, 11:57 AM

Hello - does the expresscard on the T420 give high enough speed for USB 3?? Is it Expresscard 1.0 or 2.0?? Thanks for advice

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms