Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

8 Posts

01-14-2019

Canada

15 Signins

80 Page Views

  • Posts: 8
  • Registered: ‎01-14-2019
  • Location: Canada
  • Views: 80
  • Message 1 of 3

My computer turns off immediately when Battery 2 reaches 0%, even if Battery 1 is 100%

2019-11-07, 19:55 PM

Hi,

 

There seems to be a problem with the power management on my T570. I have two batteries, and I think the main one to be used is the battery 2.

 

Sometimes, I'll be working unplugged, and my computer randomly turns off. Not the usual "Windows turning off" sequence, but an immediate blackout with no feedback.

 

When I turn the computer back on, I see that Battery 2 is at 0% and Battery 1 is now in use. It does seem to be a problem in the power management, no?

 

Thank you,

Fred

Reply
Options

12419 Posts

01-02-2010

United States of America

40569 Signins

428314 Page Views

  • Posts: 12419
  • Registered: ‎01-02-2010
  • Location: United States of America
  • Views: 428314
  • Message 2 of 3

Re: My computer turns off immediately when Battery 2 reaches 0%, even if Battery 1 is 100%

2019-11-07, 20:07 PM

Sounds like power management or battery reporting status wrong.  Are you still under warranty? If yes, call support first.  Can you get (borrow) another battery to try?


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Options

27 Posts

12-25-2018

United States of America

244 Signins

719 Page Views

  • Posts: 27
  • Registered: ‎12-25-2018
  • Location: United States of America
  • Views: 719
  • Message 3 of 3

Re: My computer turns off immediately when Battery 2 reaches 0%, even if Battery 1 is 100%

2019-11-09, 7:18 AM

Known issue to many except Lenovo...

Heres the thing, if you edit your power plan, put critical battery level to 3%, workaround in place

 

What happens is that when the first battery discharges, its not handled properly, and I have used Lenovo's power driver AND Microsoft's power driver its probably NOT a driver issue but a BIOS issue, and its not 100% always going to happen, like my system it doesnt happen most of the time unless I am activly using it (IE just watching a video, unless music starts to stress it, will flow just fine till both battery dead).

 

Took mine to a Lenovo Service, they couldnt replicate the problem despite I showed them right when I took it in, I have screenshots going back OVER A YEAR.

 

My system is an A485, but there are many other threads regarding this with many models, Lenovo Support / Service Centers have been no help

 

 

Ghetto workaround as said above, set cirtical level to 3%, that way once the first battery is taken offline (its not actually 0%) by the BIOS, when the mishandle of the power level happens it will drop down to 5% (or 255%/Unknown), and will stay there (sleep/wake or restart resolves) UNTIL it ACTUALLY hits 5%, then you get accurate reporting again.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All