Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

8095 Posts

11-19-2007

United States of America

10101 Signins

400183 Page Views

  • Posts: 8095
  • Registered: ‎11-19-2007
  • Location: United States of America
  • Views: 400183
  • Message 271 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-12-06, 18:54 PM
Reply
Options

8095 Posts

11-19-2007

United States of America

10101 Signins

400183 Page Views

  • Posts: 8095
  • Registered: ‎11-19-2007
  • Location: United States of America
  • Views: 400183
  • Message 272 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-12-07, 13:58 PM

All,

 

I moved all the discussions related to the NEW symptoms encountered with some application crashes and problems with browsers using GPU hardware acceleration while running on the Intel / integrated graphics mode to a new thread here.

 

The power consumption issues that this existing thread was about appear solved by the new drivers, so I've marked the new drivers as the solution.   Please continue any discussions related to installing those drivers here, but add your comments related to the new issues on the new thread.

 

I'm doing this to help sort out the conversation, and so that his thread doesn't drag on forever with various symptoms.  Also, we are opening a new case / issue with engineering that will be logged against the new drivers, so it makes sense to have a separate discussion about it.

 

Thanks for your help !

 

Best regards,

 

Mark

Reply
Options

15 Posts

09-02-2008

Singapore

292 Signins

864 Page Views

  • Posts: 15
  • Registered: ‎09-02-2008
  • Location: Singapore
  • Views: 864
  • Message 273 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-12-14, 7:21 AM

Just tried the latest Catalyst Mobility (10.12). It works like 10.10, with the same issues of not being able to change brightness in dedicated mode. However, switching works without the power issues, there is no app crashes (only IE9 beta tested), and there is still the blank screen during installation.

Tested on T400 2768-AA6. All latest BIOS and Power Manager. Now, please 'engineering team', come out with a proper driver. This is already 1+ year.

 

EDIT: A little update here... I did some experiment where I removed the dedicated graphics using device manager (with an option to remove the local copy of the driver too), then let Windows scan for new device and find a driver which should result in the older stable driver installed (Lenovo's 8.641 from last year). So, now I'm running a hybrid of the latest switchable Intel driver with the older ATI driver. So far, it runs great! Switching works without power issues, no crashes with new app, able to change brightness in dedicated mode, etc.

 

Can others try this method? It may come out with interesting findings.

 

EDIT2: Retracted previous statement: switchable does not solve the power issue.

 

http://img502.imageshack.us/img502/7752/ativ.png

 

Moderator edit: Image >50k converted to link, per the Community Rules.

Reply
Options

19 Posts

04-30-2008

Spain

55 Signins

632 Page Views

  • Posts: 19
  • Registered: ‎04-30-2008
  • Location: Spain
  • Views: 632
  • Message 274 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2011-01-05, 2:03 AM

Hi there,

 

I updated my W500 a few days ago and it looks to solve the battery problems. Yeeeeeeeeeepy!!!

 

One year later but better late than never.

 

EDIT: I updated ATI drivers, power manager and driver and a few other things so I don't really know what solved the problem but I guess it was the new graphic drivers. I updated through Toolbox or Thinkvantage and now I can work longer than 2 or 2 1/2 hours with the small battery, maybe more depending on what I'm doing.

Lenovo Thinkpad W500 4062-2XG (+2Gb RAM from Lenovo)
Windows 7 Ultimate x64 bits
No external monitors. No conflicting software.
Latest BIOS and drivers.
Reply
Options

24 Posts

08-08-2011

uk

52 Signins

113 Page Views

  • Posts: 24
  • Registered: ‎08-08-2011
  • Location: uk
  • Views: 113
  • Message 275 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2012-02-24, 17:43 PM

hello there please help with my similar switchable graphics issue!!!! http://forums.lenovo.com/t5/Lenovo-3000-and-Essential/G770-problems/m-p/685967/highlight/false#M35831

 

Lenovo aren't doing anything it seems so need to find other Lenovo users who have solved their problems...

 

=(

 

I just want a laptop that works, and for £700 you'd think it would...

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms