Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

40 Posts

08-28-2009

Germany

96 Signins

735 Page Views

  • Posts: 40
  • Registered: ‎08-28-2009
  • Location: Germany
  • Views: 735
  • Message 31 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-02-04, 18:25 PM

I also have the latest version of the power manager and BIOS installed and I still have the aforementioned problems...

Thinkpad T500 2082-7SG
Reply
Options

2 Posts

05-04-2009

Charlotte, NC

6 Signins

26 Page Views

  • Posts: 2
  • Registered: ‎05-04-2009
  • Location: Charlotte, NC
  • Views: 26
  • Message 32 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-02-14, 1:46 AM

When docked, I have two monitors - one DVI, one VGA. This is the behavior I get. Sometimes it's once every few minutes, sometimes it's multiple times within a minute.

 

Both monitors will blink to black

The 'removed hardware' sound plays

The DVI monitor comes back (VGA monitor black)

DVI goes back to black

'found hardware' sound plays

DVI & VGA monitors back on.

 

Whenever this happens, I don't get a bubble in the notification area, but I do get an event in the System event log (below).

 

Windows 7 Ultimate, x64. T500, 4gb ram. ATI 3650\Intel switchable. Using Oct 2009 drivers from Lenovo. I experience this behavior with Switchable Graphics turned on or off. I've tried setting to Discrete Only, Integrated Only, and neither mode works.

 

Log Name:      System
Source:        amdkmdag
Event ID:      43029
Task Category: DAL
Level:         Error
Keywords:      Classic

 
Description:
Display is not active
Event Xml:
  <System>
    <Provider Name="amdkmdag" />
    <EventID Qualifiers="49152">43029</EventID>
    <Level>2</Level>
    <Task>42</Task>
    <Keywords>0x80000000000000</Keywords>
    <EventRecordID>12426</EventRecordID>
    <Channel>System</Channel>

Reply
Options

89 Posts

12-04-2008

Germany

506 Signins

1587 Page Views

  • Posts: 89
  • Registered: ‎12-04-2008
  • Location: Germany
  • Views: 1587
  • Message 33 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-02-14, 7:43 AM
I really don't know why Lenovo needs half a year to fix our bugs but okay. I stopped to think about it as I might start to regret paying so much for my T400. When you set the machine to only Integrated or only Dedicated in BIOS, you can use the standard drivers from Intel or ATI, which are probably a lot more stable. Note, that the ATI ones have to be "adapter" for notebooks. Greetz! M.T.
Reply
Options

237 Posts

10-18-2008

Amsterdam

849 Signins

7066 Page Views

  • Posts: 237
  • Registered: ‎10-18-2008
  • Location: Amsterdam
  • Views: 7066
  • Message 34 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-02-18, 9:29 AM

ATI has just released their 10.2 drivers. And Lenovo is again many months behind. I would have thought that in times of crisis, one tries to get things right. Here is then my outburst of the day.

 

To whom it may concern at Lenovo: Get your act together, (i) elaborate on your support cycle and (ii) provide a sane driver support for your business line.

 

Just a few samples regarding my experience with a T400 under Win 7 x64:

 

  • I loose more than one hour of battery life under Win 7, apparently due to bugs in the switchable graphics driver.
  • Disabled devices in the BIOS still show up in the Windows device manager.
  • After resuming from standby or from hibernation, the display is sometimes black when on ATI. A hard power-off is the only way to get the machine in a working state again. Data loss anyone?
  • Under Win 7 x64, Skype video quality is much worse. No 640x480 calls are possible. Camera hangs every now and then. Image "flickers" or "recalibrates": When I use a video connection, my video goes off and comes back. This happens over and over.

I reported each of these issues through the forum here weeks and even months ago. Lenovo has not replied. Lenovo has not acted. Ti-for-tat advises me to buy next time elsewhere. It's simple as that. I really wonder why I've invested in a 4-year accidental damage protection plan. If I knew that Lenovo doesn''t deliver the quality they signal to deliver, then I would have taken another decision.

Reply
Options

35 Posts

09-02-2008

Singapore

1032 Signins

4369 Page Views

  • Posts: 35
  • Registered: ‎09-02-2008
  • Location: Singapore
  • Views: 4369
  • Message 35 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-02-18, 11:22 AM

Can Lenovo speed up the release cycle of their switchable graphics drivers? There is still the power issues after S3 sleep that is not yet resolved, and also the new monthly mobility drivers that I hope Lenovo can take part in.

Reply
Options

1 Posts

02-18-2010

Rockledge, Florida, USA

15 Signins

79 Page Views

  • Posts: 1
  • Registered: ‎02-18-2010
  • Location: Rockledge, Florida, USA
  • Views: 79
  • Message 36 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-02-18, 15:36 PM

I noticed that if I close my lid on my T400(2764-CTO, Win7Ult64, 4GB, switcheable graphics), it goes to sleep fine, and wakes up - no problem.  However, if the machine puts itself to sleep after a period of inactivity - when it wakes up, the display is very very dim and unreadable.

 

The only thing that fixes it is a restart.

 

Does anyone else have this? Will they address this with a driver update?

Reply
Options

7 Posts

02-26-2010

Germany

7 Signins

175 Page Views

  • Posts: 7
  • Registered: ‎02-26-2010
  • Location: Germany
  • Views: 175
  • Message 37 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-02-26, 22:10 PM

Hi.

I also have problems with the switchable graphics driver in win 7 Pro x64 installed on my T400. The problem seems to be nearly the same as others told before, but there might be some differences.

 

I use my T400 in two different configurations. It is either driven standalone (with no external monitor) or connected to a docking station with an external Eizo screen, which is connected via DVI.

 

In both configurations I get these amdkmdag errors in the windows system protocol. If the notebook ist docked theese errors only occur when the screen is switched (i. e. from intern to extern or clone sreen...). So far I never experienced a system crash following the error. There is just a small noisy line for not more than half a second on the sreen and then it works quite well. The only thing which causes the screen(s) not to turn on any more is if I close the lid of my notebook and open it again. (It is configured not to go to sleep mode if the lid is closed). The only thing to get the screen(s) working again is a hard reset.

 

If my notebook is not docked there is no real chance to work with, execpt I use windows safe mode, which of course isn't funny for working. If I just start it in the normal way it normaly crashes within the first five minutes after windows was started. Some time ago it at least threw a BSOD (7x bluescreen) but now the screen just turns black. Again it is only possible to do a hard reset. Same procedure occurs if I close the lid and open it again.

 

I contacted Lenovo via my reseller but they just told, that they don't support non lenovo recovery versions of windows (I bought windows as a non oem-version separately).

 

An interesting question would be, if anyone here who uses windows as a lenovo recovery version does also have theese switchable graphics issues? If not it might help us to find out, what is the difference to theese systems.

 

 

Hopefully our problem will be solved quickly by Lenovo

Greetings

Reply
Options

237 Posts

10-18-2008

Amsterdam

849 Signins

7066 Page Views

  • Posts: 237
  • Registered: ‎10-18-2008
  • Location: Amsterdam
  • Views: 7066
  • Message 38 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-03-11, 16:52 PM

Another user needs improved OpenGL support:

 

http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/Updated-Drivers-Proper-OpenGL-Support-for-T400-T500-Models-with/td-p/211128

Reply
Options

321 Posts

12-16-2008

Texarkana Texas

501 Signins

5306 Page Views

  • Posts: 321
  • Registered: ‎12-16-2008
  • Location: Texarkana Texas
  • Views: 5306
  • Message 39 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-03-11, 23:00 PM

I have the same high power usage after resume from sleep too...  t500 with latest updates..

Thinkpad T500 - Intel Core2 P8400 (2.26GHz), 4 gigs of ram, 160GB/7200rpm hard drive, ATI 3650 GPU, WSXGA+ panel
Reply
Options

321 Posts

12-16-2008

Texarkana Texas

501 Signins

5306 Page Views

  • Posts: 321
  • Registered: ‎12-16-2008
  • Location: Texarkana Texas
  • Views: 5306
  • Message 40 of 275

Re: R400/T400/T500/W500: Switchable graphics issues with Win 7

2010-03-18, 13:23 PM

Any update on this?  I need to know if I can turn my switchable graphics back on.  Right now, I have only my dedicated gpu turned on, so I dont have to switch back and forth just to avoid from using both cards.

Thinkpad T500 - Intel Core2 P8400 (2.26GHz), 4 gigs of ram, 160GB/7200rpm hard drive, ATI 3650 GPU, WSXGA+ panel
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms