Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

37 Posts

11-29-2008

Hungary, Pécs

132 Signins

840 Page Views

  • Posts: 37
  • Registered: ‎11-29-2008
  • Location: Hungary, Pécs
  • Views: 840
  • Message 401 of 464

Re: driver amdkmdap has stopped working!

2009-05-31, 9:43 AM
Hi there, i've tried the whole thing on windows 7rc with catalyst 9.5 modded drivers. The switch almost worked (the driver turned on the radeon card) then catalyst control center died in action and do so on every boot with the ati card on. The solution seems to be close (just shut down the intel card and fine :d)
Reply
Options

51 Posts

02-03-2009

California, USA

153 Signins

629 Page Views

  • Posts: 51
  • Registered: ‎02-03-2009
  • Location: California, USA
  • Views: 629
  • Message 402 of 464

Re: driver amdkmdap has stopped working!

2009-06-01, 0:34 AM

Hey,

 

Just thought I'd report in that I had an amdkmdap stopped responding followed by a system crash today.  I redocked my computer, went to reenable the second monitor (as I reported earlier, 8.56 doesn't always do that automatically), and when I hit "apply," I got screens flashing followed by the driver crash error.  I tried to apply the new settings again, I got the same issue.  On the third time I tried to apply the settings, this time with the resolution of the external cranked way down so as not to tax the graphics card, the screens flashed, the error popped up, then the system crashed.  Please note, I'm running the latest 8.56 Lenovo "supported" drivers on Vista 64 SP1.

 

Also, it seems that MS recently released Vista Service Pack 2 (not on auto updates yet, but you can get it from MS technet).  I was wondering if anyone had installed it and if it has had any effect on display performance?

Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 403 of 464

Re: driver amdkmdap has stopped working!

2009-06-01, 6:41 AM

Warning.

 

As you might have seen in the Thinkvantage forum Lenovo after all our complaints reinstated Thinkvantage System Update (TVSU). It now works as before except you can no longer schedule it to automatically run.

 

When  I just ran TVSU for the first time it tried to reinstall the old 8.52 switchable graphics driver over my manually installed 8.56 lenovo switchable graphics driver. So make sure you don't just select all updates when running TVSU. 

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 404 of 464

Re: driver amdkmdap has stopped working!

2009-06-03, 10:43 AM

Did you see this? Doesn't seem to be limited to switchable graphics only.

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

9 Posts

03-25-2009

Seattle

9 Signins

100 Page Views

  • Posts: 9
  • Registered: ‎03-25-2009
  • Location: Seattle
  • Views: 100
  • Message 405 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-06-08, 22:00 PM

Thanks for dogging this issue for us! I am concerned about the installation instructions to first UNinstall current video driver. How does the display work if video driver is uninstalled? How would I see anything to find and install the new driver? Thanks for help - Kathleen

Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 406 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-06-08, 22:26 PM

It will revert to the standard Microsoft driver. Your screen will be at a low resolution and not quite sharp but readable enough.

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

237 Posts

10-18-2008

Amsterdam

849 Signins

7066 Page Views

  • Posts: 237
  • Registered: ‎10-18-2008
  • Location: Amsterdam
  • Views: 7066
  • Message 407 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-06-16, 18:14 PM

Hi Mark!

 

Could you let us know about the status of the new driver?

Reply
Options

79 Posts

07-31-2008

USA - MA

324 Signins

1619 Page Views

  • Posts: 79
  • Registered: ‎07-31-2008
  • Location: USA - MA
  • Views: 1619
  • Message 408 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-06-16, 20:30 PM

Hello All,

 

Yes an updated status would be nice. I have just "discovered" a part on the Lenovo site which is a USB to DVI video adapter for $129 US Dollars. I am ordering one up to see how it works.

 

What I will do is simply disconnect the DVI connection from my dock and plug it into this USB dongle instead. They list that it works on switchable graphics ThinkPads.

 

I'll keep everyone posted.

 

Thanks in advance,

 

Brian G.

T430s (current), T420s, ThinkStation S20
Reply
Options

237 Posts

10-18-2008

Amsterdam

849 Signins

7066 Page Views

  • Posts: 237
  • Registered: ‎10-18-2008
  • Location: Amsterdam
  • Views: 7066
  • Message 409 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-06-29, 22:15 PM
Another two weeks passed without a status update. And I thought that we were through with this kind of communication strategy...
Reply
Options

8095 Posts

11-19-2007

United States of America

10101 Signins

400183 Page Views

  • Posts: 8095
  • Registered: ‎11-19-2007
  • Location: United States of America
  • Views: 400183
  • Message 410 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-07, 15:16 PM

Izmi,

 

Silence isn't my deliberate strategy. :smileywink:

 

It is just difficult at times to provide a valuable update when I sense that information I'm provided may be changing, and I'm faced with the question of whether to go out with information that I may have to retract or modify, say "stay tuned", or just wait.

 

In any event, I agree it's not good to leave you hanging out here.

 

Our engineer has reviewed all the discussion since we posted the revised tip with the 8.563 version and is looking into four issues discussed here:

 

1) That 8.563 may not replace all old files during an install over beta

 

2) FN+F7 switch behavior does not function consistently, or with same logic under all combinations of 32 or 64 Bit Vista and Power manager settings

 

3) Behavior of external DVI attached displays after resuming from suspend after docking.

 

4) Google earth support

 

I'll share further updates after he completes recreation / testing.   I don't have a timeline on a release of 8.59x version of the drivers right now.

 

Mark

 

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms