Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

237 Posts

10-18-2008

Amsterdam

849 Signins

7066 Page Views

  • Posts: 237
  • Registered: ‎10-18-2008
  • Location: Amsterdam
  • Views: 7066
  • Message 411 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-07, 15:30 PM

Dear Mark,

 

Thank you for the update. And in this case, I think that silence is not "gold". ;-)

Personally, I'd love to follow here usual team practice: Let's have an agreed schedule of announcements and deadlines where deviations are explained.

 

Please add to the list of issues these two:

 

  • If my T400* under Vista 32 SP2 is running on ATI graphics in condition undocked/after resume from standby, then the display flashes. I know that part of that is considered to be expected behavior under Vista. Though, first, running on Intel graphics does not have this effect (at least not so intensively). Second, it's annoying nevertheless and calling it "expected" is not going to make it go away.
  • If my T400* under Vista 32 SP2 is running on ATI, is docked via DVI to my Dell 2709W and both the internal display and the external monitor are used as an extended desktop, then a) sometimes, the screen is flickering (in particularly visible with black text on a white background - see video) and b) sometimes, the brightness jumps visibly in applications like Firefox 3.x (that is, the amount of "whiteness" goes up and down). Issue a) can be resolved by a reboot or suspend/resume-cycle. Issue b) seems to be hard to reproduce consistently.

 

*) I guess that this is true for all switchable models under both Vista 32 and 64.

 

 

Message Edited by Izmi on 07-07-2009 10:41 AM
Reply
Options

79 Posts

07-31-2008

USA - MA

324 Signins

1619 Page Views

  • Posts: 79
  • Registered: ‎07-31-2008
  • Location: USA - MA
  • Views: 1619
  • Message 412 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-15, 15:10 PM

Greetings All,

 

I have a  semi-unrelated question- has anyone tried the current drivers while running Win 7 Release Candidate?

I certainly understand the caveats and/or total incompatibilities of this, but seeing as I was on vaca and didn't get a chance to try it myself, I thought I'd ask. Perhaps the heavens will bless us with better performance when the new OS finally drops (although I won't hold my breath too long... :smileywink:)

 

Still living with my flashing screen after changing pc's on a KVM switch, otherwise stable.

 

NOTE: I had plenty of time to test switchable graphics undocked with no monitor attached while on vacation, and then and only then does it work great. (at least for me)

 

 

Regards,

 

Brian G.

 

T430s (current), T420s, ThinkStation S20
Reply
Options

79 Posts

07-31-2008

USA - MA

324 Signins

1619 Page Views

  • Posts: 79
  • Registered: ‎07-31-2008
  • Location: USA - MA
  • Views: 1619
  • Message 413 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-15, 20:39 PM

Greetings again everyone,

 

I'd like to post an important update. (At least it's groundbreaking for me!)

 

I mentioned a few weeks back that I was going to order up the Lenovo USB-to-DVI Monitor Adapter.

Well, it was waiting here on my desk after vaca and I hooked it up today.

 

FLAWLESS!! when changing between PC's on my KVM switch with the T500. Finally no more screens flashing and disoriented desktop icons, etc.

 

So far so good.

 

So here is my setup: only 1 monitor plugged into the dock now (VGA) and the 24" DVI monitor is using the Lenovo USB video adapter referenced above. I have been switching between my PC's now all afternoon and it is working great. Let's just hope I don't jinx myself. It was $129 I think but at least I am changing between PC's and not losing more time from my work.

 

I'll update again in a few days if anything changes. Else, perhaps this may do it for some of you. I know the fact of spending more $$ is not appealing but at this point I fugured it was worth a shot.

 

-BG

T430s (current), T420s, ThinkStation S20
Reply
Options

79 Posts

07-31-2008

USA - MA

324 Signins

1619 Page Views

  • Posts: 79
  • Registered: ‎07-31-2008
  • Location: USA - MA
  • Views: 1619
  • Message 414 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-15, 20:40 PM

Sorry, I neglected to include the Lenovo part #.

 

45K5296

 

UPC# 8- 84942-06122 -6

T430s (current), T420s, ThinkStation S20
Reply
Options

4169 Posts

11-20-2007

United States of America

23525 Signins

803315 Page Views

  • Posts: 4169
  • Registered: ‎11-20-2007
  • Location: United States of America
  • Views: 803315
  • Message 415 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-24, 1:40 AM
Message moved to Beta OS board.

keep-calm-it-s-a-thinkpad-sm2.jpg

English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество


Jane
nonnymouselenovoff1.gif

2015 X1 Carbon, ThinkPad Slate, T410s, X301, X200 Tablet, T60p, HP TouchPad, iPad Air 2, iPhone 5S, IdeaTab A2107A, Yoga Tablet, Yoga 3 Pro
I AM one of those crazy ThinkPad zealots!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

I am not a Lenovo employee

Reply
Options

4169 Posts

11-20-2007

United States of America

23525 Signins

803315 Page Views

  • Posts: 4169
  • Registered: ‎11-20-2007
  • Location: United States of America
  • Views: 803315
  • Message 416 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-24, 20:44 PM

keep-calm-it-s-a-thinkpad-sm2.jpg

English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество


Jane
nonnymouselenovoff1.gif

2015 X1 Carbon, ThinkPad Slate, T410s, X301, X200 Tablet, T60p, HP TouchPad, iPad Air 2, iPhone 5S, IdeaTab A2107A, Yoga Tablet, Yoga 3 Pro
I AM one of those crazy ThinkPad zealots!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

I am not a Lenovo employee

Reply
Options

4169 Posts

11-20-2007

United States of America

23525 Signins

803315 Page Views

  • Posts: 4169
  • Registered: ‎11-20-2007
  • Location: United States of America
  • Views: 803315
  • Message 417 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-27, 15:49 PM
Moved to Beta OS board.

keep-calm-it-s-a-thinkpad-sm2.jpg

English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество


Jane
nonnymouselenovoff1.gif

2015 X1 Carbon, ThinkPad Slate, T410s, X301, X200 Tablet, T60p, HP TouchPad, iPad Air 2, iPhone 5S, IdeaTab A2107A, Yoga Tablet, Yoga 3 Pro
I AM one of those crazy ThinkPad zealots!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

I am not a Lenovo employee

Reply
Options

2 Posts

07-28-2009

Wisconsin, USA

4 Signins

41 Page Views

  • Posts: 2
  • Registered: ‎07-28-2009
  • Location: Wisconsin, USA
  • Views: 41
  • Message 418 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-28, 17:28 PM

I wasn't sure if I should make a new post or just post here, but since it's related here we go.  I think I've read through the entire thread, but I may have missed something that applies to me, I apologize if I have.  

 

First, I want to be clear that this is Not the same issue with external display, as I am not using one, and that I am not running Aero and am only running Vista Basic, so this fix does not apply to my system.  

 

I am running a T500, 2081 model.  I'm not entirely sure what I was doing at the time, but I was either playing Civilization IV or installing Google Apps (including Google Earth, which may have caused the problem as I've seen others have had issues with that).  I did not write down the specific error, but remember it was something to the tune of "AMD Driver has crashed and attempts to restore it have been unsuccessful".  I rebooted my system, thinking the driver would restart on windows restart, but it did not.  Not only did the driver not restart, but when I go into my device manager I no longer see the ATI card listed under display adapters, I only see the Intel graphics.  

 

I thought maybe installing a new driver would fix it, so I found my most recent drivers, downloaded them, uninstalled my old drivers, extracted and ran the setup for the new driver.  On setup I receive the error: "Setup was unable to find components that can be installed on your current hardware or software configuration.  Please make sure you have the required hardware or software."  When I attempt to run the Catalyst Control Center I receive "ATI Catalyst Control Center cannot be started because the currently active GPU is not supported".  

 

I have called Lenovo tech support, they walked me through all of those previous steps with the same results.  We then ran a system diagnosis and found no hardware errors.  I called back after that had finished and spoke with a rather rude tech who told me to back up my files and call back after I had done that so they could walk me through a vista reinstall.  I am hoping that the great tech support hive-mind has a solution that does not involve reinstalling Vista, as I've already nested and had to deal with a multi-layer wireless card update that I really don't look forward to repeating.  Not to mention I use this laptop every day and have no backup computer.  

 

Please talk to me like an idiot, because I don't want to miss any little detail that I may have been overlooking.  I'm not very skilled in this area and I find myself a bit confused by some of the things people are talking about earlier :(   Here's to hoping I just accidentally stuck on Intel graphics and am not skilled enough to figure out how to turn it back to ATI.  

Reply
Options

453 Posts

12-26-2008

Sweden

14704 Signins

67019 Page Views

  • Posts: 453
  • Registered: ‎12-26-2008
  • Location: Sweden
  • Views: 67019
  • Message 419 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-28, 20:31 PM

Left or right click on power manager depending on release (the larger of the two battery icons) to find the switchable graphics menu to switch between integrated and discrete graphics.

 

If its not there go to bios (F1 while booting) and check config display is set to switchable graphics.

 

ps Your post isnt totally clear -- you dont install integrated graphics drivers at all on a machine with discrete graphics -- the switchable graphics driver supports both integrated, discrete and switchable modes in bios. it should be installed w bios set to switchable.

 

pps It is the April 28 driver you reference that you should install -- the earlier drivers did not work properly.

Message Edited by zilla on 2009-07-28 10:34 PM

T500: Vista 32, 2.8GHz, 4GB RAM, 15.4" 1680x1050, 500GB 7200rpm, ATI Radeon HD3650 + Intel 4500MHD. T42: XP, 1.7GHz, 2GB RAM, 14.1" 1024x768, 250GB PATA, ATI Radeon 7500.

Reply
Options

2 Posts

07-28-2009

Wisconsin, USA

4 Signins

41 Page Views

  • Posts: 2
  • Registered: ‎07-28-2009
  • Location: Wisconsin, USA
  • Views: 41
  • Message 420 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-07-28, 20:39 PM

I was just coming back to delete my post as I was just able resolve the issue.  I had no options in the power manager to switch between the two settings and I ended up playing in the BIOS config and disabling graphic switching and forcing discrete graphics.  Now all is well and I was able to get the proper drivers.  

 

Why this did not occur to me over the past week of tech support nonsense I do not know.  Also, why tech support did not suggest either of these things and recommended a vista reinstall is also a bit of a mystery.  

 

But thank you for taking the time to respond and I apologize for wasting it.  

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms