Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

237 Posts

10-18-2008

Amsterdam

849 Signins

7066 Page Views

  • Posts: 237
  • Registered: ‎10-18-2008
  • Location: Amsterdam
  • Views: 7066
  • Message 431 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-09-01, 7:03 AM

If only sarcasm made things better... I take it that it is your way of coping with it. :smileyhappy:

Reply
Options

79 Posts

07-31-2008

USA - MA

324 Signins

1619 Page Views

  • Posts: 79
  • Registered: ‎07-31-2008
  • Location: USA - MA
  • Views: 1619
  • Message 432 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-09-01, 14:51 PM

Yeah isn't this grand???

 

T500 gets announced August 2008, here we are it's September 1, 2009 (yep that's right, a whole year later...) and my system still runs like complete garbage.

 

I haven't had the time to swap HDD's and run the Windows 7 RTM yet. I do understand that I'd have to use discrete only for Win 7 (so far) but we;ll see if I can get around to it or not.

 

I had my new Lenovo regional rep come into our company earlier this month to go over the usual product roadmaps, etc. Looks like there's going to be a T510 coming up relatively soon. Probably going to be native Win 7.

 

I expressed to her that the T500 with Vista (esp. the video issue as we all know) has been a NIGHTMARE!!!!!:manmad:

 

Let's just keep everyone posted if you find something out.

 

-Brian G.

T430s (current), T420s, ThinkStation S20
Reply
Options

1 Posts

09-11-2009

ca

3 Signins

33 Page Views

  • Posts: 1
  • Registered: ‎09-11-2009
  • Location: ca
  • Views: 33
  • Message 433 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-09-11, 22:29 PM

Just wanted to add my 2 cents:

 

using both the April drivers, and a modded latest Catalyst (which makes the card appear as Radeon and not FireGL) - SketchUp crashes still, with that message. Photoshop also crashes, when OpenGL is enabled in it.

 

When will Lenovo release proper drivers for this blunder?? This is supposed to be a top of the line workstation, yet it cannot run the most common of design programs properly!

 

I really hope they are working on this!

Reply
Options

79 Posts

07-31-2008

USA - MA

324 Signins

1619 Page Views

  • Posts: 79
  • Registered: ‎07-31-2008
  • Location: USA - MA
  • Views: 1619
  • Message 434 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-09-14, 12:43 PM

Hey Gang,

 

Just wondering now if Levovo is even going to bother *trying* to get switchable working as it should on Vista when Win 7 officially drops on Oct. 22nd.

 

I'm betting no.

T430s (current), T420s, ThinkStation S20
Reply
Options

51 Posts

02-03-2009

California, USA

153 Signins

629 Page Views

  • Posts: 51
  • Registered: ‎02-03-2009
  • Location: California, USA
  • Views: 629
  • Message 435 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-09-14, 18:04 PM

On the one hand, given that Lenovo is pushing the Windows 7 upgrade program pretty hard to sell their T and W series laptops, I would think that they'd be finished with the Windows 7 driver work by the 24th and would then have plenty of time to make the Vista drivers functional.

 

On the other hand, Lenovo might just decide that any T-series not eligible for the free Windows 7 upgrade is already anywhere from a quarter to half way through a 2 year life-span and not worth supporting.

 

I'm hoping for the first option, but I have to agree that it's probably the second.

Reply
Options

8095 Posts

11-19-2007

United States of America

10101 Signins

400183 Page Views

  • Posts: 8095
  • Registered: ‎11-19-2007
  • Location: United States of America
  • Views: 400183
  • Message 436 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-09-15, 12:33 PM

bri0831,

 

Do you still have your escalation open?  If your system operation is still significantly impaired at this point, please press the issue through your rep.  See my PM for more details.

 

At this point, the perception is that the level of drivers  available provides stable operation for most customers.  Andy_7575 and Izmi, along with yourself are the core stakeholders on this discussion, although I do see some new members poping in over the last two months, expressing some general pain, and some specifics as in the case of qda.  

 

Last I was involved, I heard about 4 issues that were open.   I know this was 2 months ago, and it seems like we have been churning on approach to solve - which version of the driver is going to be updated.   

 

I'll check in with engineering on those 4 items to see what our present timetable looks like.

 

Mark

 

Reply
Options

15 Posts

09-02-2008

Singapore

292 Signins

864 Page Views

  • Posts: 15
  • Registered: ‎09-02-2008
  • Location: Singapore
  • Views: 864
  • Message 437 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-09-16, 7:11 AM

I actually don't really have much problems with the graphics driver apart from occasionaly 10-20s screen blackout when I am playing 3D games. Ever since I updated to the latest driver, there is almost no problem. I don't use external LCD. Switchable graphics have no problem. Despite that, I still have concerns....

 

My concerns are the update to the latest catalyst (I really want the proper switching under ATI, not under Lenovo PM.... Also switching upon power source change) and the Win7 compatibility. I have a Win7 RTM from my school, but switchable graphics so far held me back from switching....

Reply
Options

79 Posts

07-31-2008

USA - MA

324 Signins

1619 Page Views

  • Posts: 79
  • Registered: ‎07-31-2008
  • Location: USA - MA
  • Views: 1619
  • Message 438 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-09-17, 12:27 PM

Hi Mark,

 

I'm pretty sute there isn't a formal ticket open for me.

There are only a couple of us (IT guys, not end users) who are using the OEM Vista Biz 32 images on our T500's.

(Myself included)

 

The rest of our T500 users are on XP, so there are no graphics issues at all as XP can't "see" switchable.

 

When my laptop is undocked (on AC power or battery) switchable graphics works as it should. Sometimes my screen goes a little crazy on websites if there's a lot of Flash being used, but this is extrememly rare- and a reboot usually clears it up.

 

When my laptop is docked (as it is 5 days a week @ work) the lid is closed, and I have one 24" wide LCD on DVI and a 21" LCD on VGA attached to the mini-dock.

 

I also have a 4 port KVM switch at my desk, but I've changed the switch a few times & my issues still appear.

 

I can be logged in & working fine, but if I switch to another PC on my KVM, I should still see one screen of the T500 on my 24" LCD while the "other" PC shows up on my 21" LCD. Then when I switch back, I get both screens for the T500. However, when I switch to the other machine, the screens flash on and off, and the correct resolution is lost. When I switch back on the KVM to the T500, again the screens flash on and off, and it takesat least 10 seconds for the resolutions to go back to the way they should.

 

One note with the scenario above: if I have applications maximized on the T500 before switching on the KVM, then the windows don't resize correctly on the switch back. It's nuts.

 

I am considering posting another YouTube video (better video quality than my last post) which shows this. I probably sound like a nutcase, but "seeing really is beleiving."

T430s (current), T420s, ThinkStation S20
Reply
Options

237 Posts

10-18-2008

Amsterdam

849 Signins

7066 Page Views

  • Posts: 237
  • Registered: ‎10-18-2008
  • Location: Amsterdam
  • Views: 7066
  • Message 439 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-09-18, 7:51 AM

Hi Mark,

 

I still have three recurring issues: whiteness bumps, screen flickering, and Windows being unsure about the display settings after resuming from standby.

Reply
Options

51 Posts

02-03-2009

California, USA

153 Signins

629 Page Views

  • Posts: 51
  • Registered: ‎02-03-2009
  • Location: California, USA
  • Views: 629
  • Message 440 of 464

Re: R400/T400/T500/W500: display driver "amdkmdap" crashes

2009-09-18, 18:26 PM

I was having the issues of resolution resetting to the screen minimum, and windows resizing/losing maximized status between dock/undock cycles.

 

These days, I'm running Windows 7 RTM (i.e. the full version that will be on store shelves in October, not a release candidate or a beta), so I've had to disable switchable graphics altogether.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All