Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

10 Posts

12-16-2020

Canada

14 Signins

30 Page Views

  • Posts: 10
  • Registered: ‎12-16-2020
  • Location: Canada
  • Views: 30
  • Message 11 of 87

Re:T14s webcam performance issues

2020-12-18, 3:08 AM

Hi julesair, I came across your post after posting a message at the ThinkPad P & W series forum.

I have the new P14s (AMD) and have the same issue as yours with the IR 720 webcam. The image is very soft and unfocused, worse than my 6 year old Dell laptop's webcam, much to my disappointment for a ThinkPad.

After reading your post, I tried your approach to turn off Auto-Exposure from Camera Settings in Lenovo Vantage (I am running Windows 10 Pro). I started adjusting the exposure control manually (setting it to max) and for a moment, the image became quite a bit sharper. Then a few seconds later, it reverted back to the soft, unfocused image.

So I agree with you that the webcam is technically able to produce a sharp image but the firmware will mess it up automatically.
I would greatly appreciate it if Lenovo can correct this behaviour with a fix, because that soft, unfocused image is just not suitable for professional usage.

Reply
Options

3 Posts

12-18-2020

Sweden

3 Signins

15 Page Views

  • Posts: 3
  • Registered: ‎12-18-2020
  • Location: Sweden
  • Views: 15
  • Message 12 of 87

Re:T14s webcam performance issues

2020-12-18, 22:31 PM

Cant seem to find any vote buttons in this thread. However having the same problem on a brand new T14 running Win 10. Should I open a support case in addition to this thread to increase priority? Couldn't imagine that Lenovo would ship a laptop with these kind of issues. 

Reply
Options

9 Posts

06-26-2015

United States

13 Signins

63 Page Views

  • Posts: 9
  • Registered: ‎06-26-2015
  • Location: United States
  • Views: 63
  • Message 13 of 87

Re:T14s webcam performance issues

2020-12-18, 22:34 PM

I'm also seeing similar issues, and would love to get a fix or at least some help on managing this.

Reply
Options

10 Posts

12-16-2020

Canada

14 Signins

30 Page Views

  • Posts: 10
  • Registered: ‎12-16-2020
  • Location: Canada
  • Views: 30
  • Message 14 of 87

Re:T14s webcam performance issues

2020-12-19, 4:18 AM

I did some more experiments with Zoom and Hangout today.

 

I found that if I turned off Auto-Exposure from Camera Settings in Lenovo Vantage and manually set the exposure to max, the image became sharper and continued to stay that way, which makes it somewhat acceptable. But if I turned Auto-Exposure back on, the image will revert back to soft and unfocused.

Also, if I am in a bright room and toggle Auto-Exposure back on, the image does not seem to revert back to soft.

 

Reply
Options

12 Posts

09-01-2020

Germany

15 Signins

95 Page Views

  • Posts: 12
  • Registered: ‎09-01-2020
  • Location: Germany
  • Views: 95
  • Message 15 of 87

Re:T14s webcam performance issues

2020-12-19, 9:57 AM

Same problem on ThinkPad E14 Gen 2 - webcam image is very blurry as long as auto exposure is enabled. Workaround is to leave auto-exposure enabled so it adjusts the exposure for the current light conditions, then disable it to get a sharp image.

If you do a lot of video conferencing troughout the day with different light conditions that may get annoying quickly.

 

Reply
Options

2 Posts

12-20-2020

France

1 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎12-20-2020
  • Location: France
  • Views: 10
  • Message 16 of 87

Re:T14s webcam performance issues

2020-12-20, 23:08 PM

Hello

 

Just to say I've got the same issue on a brand new P14s AMD running Arch.

 

I must say the poor image quality is a deal-breaker for me: I will have to send back the unit if no solution is found.

In contrast, the image on my trusty x260 is crisp and clear with decent colours.

 

Please, please, fix this, professional video conferences are impossible with the current image quality.

 

 

Reply
Options

12 Posts

10-17-2020

United States of America

15 Signins

85 Page Views

  • Posts: 12
  • Registered: ‎10-17-2020
  • Location: United States of America
  • Views: 85
  • Message 17 of 87

Re:T14s webcam performance issues

2020-12-21, 12:14 PM

Since this thread is taking off, I think it's worth highlighting for future posters that folks appear to be having difficulties with each of two different camera hardware configurations. I presume one camera model comes with the Intel version of the Lenovo machines while the other comes with the AMD model, but it may also have to do with the trim level of the laptop in question.

 

At any rate, some users (presumably those on Intel models) are having issues with the Chicony Electronics Co.,Ltd. integrated camera, running firmware version 58.18.

 

Others (presumably those on AMD models) are having problems with the Azurewave integrated camera running firmware version 60.1.

 

It's probably worth distinguishing between the two in our posts, if not splitting the thread, so as to better assist any techs at Lenovo who are trying to sort these issues out. On a Linux machine, assuming you're using the Linux Vendor Firmware Service (LVFS) tools, you can find your integrated camera specs using the `fwupdmgr get-devices' command in the console or by bringing up one of its GUI interfaces, like GNOME Software or KDE Discover. If you're not using LVFS, the  camera model should also be listed in your machine's startup log—though if you're not using LVFS, you're probably also dual-booting Windows, so you can just check your model and firmware specs there, though I'm not sure on the exact details of that procedure.

 

 

Reply
Options

24 Posts

08-19-2020

Germany

47 Signins

295 Page Views

  • Posts: 24
  • Registered: ‎08-19-2020
  • Location: Germany
  • Views: 295
  • Message 18 of 87

Re:T14s webcam performance issues

2020-12-21, 13:10 PM

@ professed wrote:

 

At any rate, some users (presumably those on Intel models) are having issues with the Chicony Electronics Co.,Ltd. integrated camera, running firmware version 58.18.

 

Others (presumably those on AMD models) are having problems with the Azurewave integrated camera running firmware version 60.1.

 

Unfortunately it is not so easy: I have the issue with the Chicony camera (FW=58.18) on T14s(AMD)

Reply
Options

2 Posts

12-20-2020

France

1 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎12-20-2020
  • Location: France
  • Views: 10
  • Message 19 of 87

Re:T14s webcam performance issues

2020-12-21, 15:11 PM

My P14s AMD is also equipped with:

 

Current version:    58.18
Vendor:             Chicony Electronics Co.,Ltd. (USB:0x04F2)

Reply
Options

12 Posts

10-17-2020

United States of America

15 Signins

85 Page Views

  • Posts: 12
  • Registered: ‎10-17-2020
  • Location: United States of America
  • Views: 85
  • Message 20 of 87

Re:T14s webcam performance issues

2020-12-21, 21:38 PM

Unfortunately it is not so easy: I have the issue with the Chicony camera (FW=58.18) on T14s(AMD)

Sigh. Of course it couldn't be straightforward. Well, thanks @Iluha for the correction and clarification!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms