Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

11 Posts

03-24-2017

Ukraine

13 Signins

162 Page Views

  • Posts: 11
  • Registered: ‎03-24-2017
  • Location: Ukraine
  • Views: 162
  • Message 1 of 5

T14 Gen 1 BIOS update to 1.17 causes Intel i7-10510U Turbo Boost issues on AC?

2021-02-26, 17:48 PM
Hi,
 
Recently I've updated the BIOS of my T14 Gen 1 to the latest version - 1.17 (N2XET27W).
Right after the update, my fan started to work all the time at 80-100% when AC connected. With or without any load.
 
I've checked CPUID HWMonitor and found that there is a potential issue with Turbo Boost of Intel i7-10510U when connected to AC.
On battery, it's always between 0.9-1.8Ghz. Which is good. https://prntscr.com/107q3ay
(1) On AC it's always between 2-4.8Ghz. Which is too much. Plus, as I've mentioned, the fan works loud all the time at 80-100%. https://prntscr.com/107q2vw
On screenshots, you can see that the load is the same and it's not high for both cases.
 
(2) Also, in order to make a fan stop working all the time at 80-100% on a battery, after AC disconnected I need to trigger the power mode of Windows 10 back and forward: https://prnt.sc/107q93j
 
(3) Also, when on AC, after Windows Lock/Unlock, the CPU drops to 0.39Ghz: https://prnt.sc/107qdon.
And again, it can be fixed by explicitly triggering of Windows 10 power mode back and forward: https://prnt.sc/107q93j
 
(4) Also, BIOS was shown to me several times with old and then - with a new look, which is weird.
 
Actions were made:
(1) BIOS was reset to defaults. No result.
Version 1.17 of BIOS states it's impossible to downgrade.
 
BIOS default config:
 
Intel SpeedStep Technology: Enabled
Mode for AC: Maximum Performance
Mode for Battery: Battery Optimized
 
Adaptive Thermal Management:
Scheme for AC: Maximize Performance
Scheme for Battery: Balanced
 
(2) All the Windows and Lenovo Vantage updates were installed. No result.
 
(3) Lenovo System Update was uninstalled. No result.
 
(4) I'm going to reinstall Windows 10 from scratch in the nearest feature. Hope it will help somehow.
 
Would be really glad to hear suggestions.
 
Thanks.
 
P.S. Just for the reference. Here is my initial post which, I think, is not so relevant at this time:
Reply
Options

19 Posts

10-24-2019

Thailand

43 Signins

430 Page Views

  • Posts: 19
  • Registered: ‎10-24-2019
  • Location: Thailand
  • Views: 430
  • Message 2 of 5

Re:T14 Gen 1 BIOS update to 1.17 causes Intel i7-10510U Turbo Boost issues on AC?

2021-02-26, 19:01 PM

the 3rd one is similar to my T490 (the first one also)

My workaround is to install throttlestop and it stops doing 0.4GHz thing and over-turbo boosting thing.

this is my setting. I limit the PL1 & PL2 to 20w to make it run cooler and I don't need high clock speed anyway.

Reply
Options

6683 Posts

08-02-2018

Philippines

1006 Signins

33720 Page Views

  • Posts: 6683
  • Registered: ‎08-02-2018
  • Location: Philippines
  • Views: 33720
  • Message 3 of 5

Re:T14 Gen 1 BIOS update to 1.17 causes Intel i7-10510U Turbo Boost issues on AC?

2021-02-26, 21:03 PM


Hello budedub!


Welcome to community forums


Try downgrading the BIOS version here: https://download.lenovo.com/pccbbs/mobiles/n2xuj08w.exe

Before proceeding, disable the Secure Rollback Prevention in the BIOS. For you to boot to BIOS, follow the steps here: https://support.lenovo.com/us/en/solutions/ht500222-recommended-ways-to-enter-bios-boot-menu-thinkpad-thinkcentre-thinkstation

Please take time to read the text file before flashing the BIOS with its previous version: https://download.lenovo.com/pccbbs/mobiles/n2xuj08w.txt

 


Jwes_Lenovo



Did someone help you today? Press the thumbs-up icon below to thank them.!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.


Using Browser Search to find your answers in Lenovo and Moto Community

Reply
Options

11 Posts

03-24-2017

Ukraine

13 Signins

162 Page Views

  • Posts: 11
  • Registered: ‎03-24-2017
  • Location: Ukraine
  • Views: 162
  • Message 4 of 5

Re:T14 Gen 1 BIOS update to 1.17 causes Intel i7-10510U Turbo Boost issues on AC?

2021-02-26, 21:31 PM

Hi Jwes_Lenovo,

Thank you for the quick reply.

 

1. I think, my previous version of BIOS before the upgrade was 1.05 - the initial one for the laptop. So not sure what exact version can bring problems (1.17 or 1.09, for example).

2. There is a statement in 1.17 readme file: If the UEFI BIOS has been updated to version 1.17 or higher, it is no longer able to roll back to the version before 1.17. So I think it's just impossible to downgrade.

 

Could you please elaborate here a bit?

 

Thanks

Reply
Options

11 Posts

03-24-2017

Ukraine

13 Signins

162 Page Views

  • Posts: 11
  • Registered: ‎03-24-2017
  • Location: Ukraine
  • Views: 162
  • Message 5 of 5

Re:T14 Gen 1 BIOS update to 1.17 causes Intel i7-10510U Turbo Boost issues on AC?

2021-03-02, 19:39 PM

@Jwes_Lenovo can I ask you to assist further, please?

 

Thanks,

Vitalii

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms