Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

1 Posts

07-21-2021

Canada

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎07-21-2021
  • Location: Canada
  • Views: 5
  • Message 1 of 3

T14s Gen 2 (Intel) - ThinkPad USB-C Docking Station Issues

2021-07-21, 2:00 AM

Hi -

 

We recently purchased several T14s Gen 2 (Intel) laptops with ThinkPad USB-C Docking Stations and have had constant issues with our external monitors. Both of the monitors connected to the dock would randomly lose connection and flash (via displayport or hdmi). The laptops and docks are fully updated with the most recent drivers and firmware.

 

Are there any known compatibility issues with these devices? Any help would be appreciated as the same issue is occurring on all three laptops and docks.

 

Thanks.

Reply
Options

2834 Posts

03-11-2020

Greece

332 Signins

14366 Page Views

  • Posts: 2834
  • Registered: ‎03-11-2020
  • Location: Greece
  • Views: 14366
  • Message 2 of 3

Re:T14s Gen 2 (Intel) - ThinkPad USB-C Docking Station Issues

2021-07-21, 9:58 AM

Hi xvulcan26,

 

Welcome to the Community Forums.

 

 

Could you please provide the community with the Machine Type & Model (MTM ex: 90DG0023US) of your device. This will help us track down the configuration and specs of your specific machine so that we can better assist you.
https://support.lenovo.com/ph/en/videos/vid100751-how-to-locate-serial-number-and-machine-type-model-number-may-2020-update

 

 

Meanwhile, try the following:

Do the monitors work normally when connecting directly to the laptop ? If yes, then the problem lies with the docking station.

 

Firstly, doublecheck that everything is updated. Drivers & Firmware.

 

Step 1. Static Discharge
- Remove all cables attached to the laptop (ac adapter/power, hdmi, external mouse/keyboard, etc)
- Ensure device is switched OFF
- Hold down power button for 60 seconds
- Re-attach all cables
- Connect the AC Adapter, then let the device charge for about 2 minutes (if it does) then start up as usual.
- Try this a couple of times in case it doesn't solve the issue the first time (2-3)

 

 

Step 2. Reset the Dock/Hub (If it has it's own power button).

- Unplug the dock from power, computer and external devices.
- Hold the power button on the dock down for 45 seconds. 
- Plug everything back in.

 

 

Hope this helps

 

Regards

 

Voithos



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Private Message; questions belong in the forums.

Reply
Options

30 Posts

05-28-2020

Norway

28 Signins

385 Page Views

  • Posts: 30
  • Registered: ‎05-28-2020
  • Location: Norway
  • Views: 385
  • Message 3 of 3

Re:T14s Gen 2 (Intel) - ThinkPad USB-C Docking Station Issues

2021-08-04, 7:00 AM

Hi, 

Are your devices on a display driver newer than 27.20.100.9616 for Intel Iris Xe? 

 

We encountered some issues with 27.20.100.9778 pushed by Windows update, you might want to downgrade to the latest released by Lenovo if that is the case. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms