Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

4 Posts

11-17-2011

Sarajevo

12 Signins

50 Page Views

  • Posts: 4
  • Registered: ‎11-17-2011
  • Location: Sarajevo
  • Views: 50
  • Message 1 of 8

T420 w/ Intel graphics no image via displayport

2011-11-17, 9:59 AM

I've just got a T420 and a ThinkVision 24" monitor. If I connect the monitor via displayport (no converters - straight DP-DP cable), windows gives me a "new device" sound and I can see the ThinkVision display in the "screen resolution" and display settings, but I'm unable to get any picture on external monitor.

It just identifies the DP input and it goes straight to "power saving mode".

When i select clone displays, i get 1024x768 resolution on the laptop display and no image on the ext display.

I also used Lenovo sys update, and BIOS and drivers are the newest.

Reply
Options

315 Posts

02-21-2008

Singapore

577 Signins

3826 Page Views

  • Posts: 315
  • Registered: ‎02-21-2008
  • Location: Singapore
  • Views: 3826
  • Message 2 of 8

Re: T420 w/ Intel graphics no image via displayport

2011-11-17, 11:08 AM

You have a monitor that accepts displayport? ie you are using a DP to DP cable.....

 

Anyway, my guess is that either your displayport cable or monitor are not compatible. I have 2x samsung 24 inch (different model), one will accept a displayport to DVI but if the same cable is plugged to the other monitor, there is no display. Changing another cable will show up the display on both monitors.

 

So my suggestion is use the intel graphics program to play with the settings, like changing the frequency to 50Hz or 60Hz, minmal resoluton. or even go to Bios, change the bootup display to the external monitor to see if it works. Other then that, try another cable or try another monitor to see which has the incompatibility or failure

 

 

Reply
Options

4 Posts

11-17-2011

Sarajevo

12 Signins

50 Page Views

  • Posts: 4
  • Registered: ‎11-17-2011
  • Location: Sarajevo
  • Views: 50
  • Message 3 of 8

Re: T420 w/ Intel graphics no image via displayport

2011-11-17, 12:15 PM
it's a lenovo thinkvision with displayport, original cable, no shananigans: dp-dp
a friend has a same t420 and it worked OK
Reply
Options

315 Posts

02-21-2008

Singapore

577 Signins

3826 Page Views

  • Posts: 315
  • Registered: ‎02-21-2008
  • Location: Singapore
  • Views: 3826
  • Message 4 of 8

Re: T420 w/ Intel graphics no image via displayport

2011-11-17, 13:51 PM

No idea why it shouldn't work then, I always had problem with lenovo graphics driver and window network, both have weird problems once in a while.

 

I notice that the thinkvision has anlaog input? ie VGA, have you tried that and see if it was driver problem or displayport problem?

 

suggesion:

 

a) Have you tried the monitor inf file at http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/79oi26ww.exe  ?

b) And the intel chipset update

 

c) Also, you can try download from intel their device checker http://www.intel.com/p/en_US/support/detect   and perhaps install a non lenovo driver and see if it show the

 

 

Reply
Options

2483 Posts

04-08-2011

United States of America

5471 Signins

46460 Page Views

  • Posts: 2483
  • Registered: ‎04-08-2011
  • Location: United States of America
  • Views: 46460
  • Message 5 of 8

Re: T420 w/ Intel graphics no image via displayport

2011-11-17, 17:08 PM

wrote:
it's a lenovo thinkvision with displayport, original cable, no shananigans: dp-dp
a friend has a same t420 and it worked OK

When you say your friends T420 works, are you literally using the same cable and monitor?

Reply
Options

9644 Posts

12-27-2009

Canada

3314 Signins

95288 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95288
  • Message 6 of 8

Re: T420 w/ Intel graphics no image via displayport

2011-11-17, 17:22 PM
Do you have the NVS 4200M graphics adapter?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

4 Posts

11-17-2011

Sarajevo

12 Signins

50 Page Views

  • Posts: 4
  • Registered: ‎11-17-2011
  • Location: Sarajevo
  • Views: 50
  • Message 7 of 8

Re: T420 w/ Intel graphics no image via displayport

2011-11-18, 14:04 PM

I'm not sure if I can be any clearer:

I'm not using an adapter to connect the monitor. It's a Lenovo monitor with DP port and I'm using the original DP-DP cable. A friend has the same configuration of his T420 and it works.

I have Intel HD 3000 integrated graphics, and all the latest drivers.

I think I'll restore Windows and then see if it works. If not, I'm returning it

Reply
Options

2483 Posts

04-08-2011

United States of America

5471 Signins

46460 Page Views

  • Posts: 2483
  • Registered: ‎04-08-2011
  • Location: United States of America
  • Views: 46460
  • Message 8 of 8

Re: T420 w/ Intel graphics no image via displayport

2011-11-18, 16:13 PM

wrote:

I'm not sure if I can be any clearer:

I'm not using an adapter to connect the monitor. It's a Lenovo monitor with DP port and I'm using the original DP-DP cable. A friend has the same configuration of his T420 and it works.

I have Intel HD 3000 integrated graphics, and all the latest drivers.

I think I'll restore Windows and then see if it works. If not, I'm returning it


Well, you still didn't answer my question so yes, you could be clearer.  But it sounds like you know what you are doing.

 

I was under the impression the Intel HD 3000 only machines couldn't use DisplayPort for some reason.  I don't recall what the issue was but it might have been on Optimus configs and how the mux works.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms