Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

107 Posts

06-28-2011

Italia

2191 Signins

3793 Page Views

  • Posts: 107
  • Registered: ‎06-28-2011
  • Location: Italia
  • Views: 3793
  • Message 1021 of 1217

Re: T420s Fan noise Issue

2012-04-10, 21:53 PM

Apparently Lenovo doesn't care, and without help we cannot solve the issue, apart from a kind and super skilled soul who feels like reverse engineering that piece of stinking rubbish which is the T420s BIOS.

 

Our only hope is that, at some point, somebody at Lenovo realises how stupid this situation is and how badly they have broken the user experience with this machine and decides to put an end to it.

 

Lenovo, are you still there?

Reply
Options

16 Posts

11-15-2008

Saskatoon

162 Signins

704 Page Views

  • Posts: 16
  • Registered: ‎11-15-2008
  • Location: Saskatoon
  • Views: 704
  • Message 1022 of 1217

Re: T420s Fan noise Issue

2012-04-11, 1:41 AM

My T420S with intel GPU has a noisy fan even when the computer is idle.

 

Interesting fact: I use my laptop with an additional monitor attached to it.

When I remove the monitor, the fan becomes silent when the computer is idle.

 

I wonder how many of the people with problems are using the computer with and external display...

Reply
Options

10 Posts

07-17-2008

United States

27 Signins

190 Page Views

  • Posts: 10
  • Registered: ‎07-17-2008
  • Location: United States
  • Views: 190
  • Message 1023 of 1217

Re: T420s Fan noise Issue

2012-04-11, 1:55 AM

For what it may be worth, my fan didn't spin so consistently until I installed more memory.  All drives are SSD and fan operation seems completely independent of what I am doing. 

Does anyone know anyone at Lenovo???

Reply
Options

107 Posts

06-28-2011

Italia

2191 Signins

3793 Page Views

  • Posts: 107
  • Registered: ‎06-28-2011
  • Location: Italia
  • Views: 3793
  • Message 1024 of 1217

Re: T420s Fan noise Issue

2012-04-11, 10:11 AM

wrote:

Does anyone know anyone at Lenovo???



Unfortunately not. I'll test the memory thing when my laptop gets back from the repair centre. I reported that running without the hard drive made a difference before sending it for maintenance, however I also removed some memory, which might as well have been the reason for the improved quietness.

Reply
Options

62 Posts

06-08-2011

USA

74 Signins

339 Page Views

  • Posts: 62
  • Registered: ‎06-08-2011
  • Location: USA
  • Views: 339
  • Message 1025 of 1217

Re: T420s Fan noise Issue

2012-04-11, 16:45 PM
Same issue here. The problem is most apparent with an external display connected to my Lenovo dock. I have the nvidia gpu and on external display it runs warm enough on idle (47c and higher) for the fan to be consistently on high speed.
Reply
Options

17 Posts

01-18-2012

United States of America

24 Signins

211 Page Views

  • Posts: 17
  • Registered: ‎01-18-2012
  • Location: United States of America
  • Views: 211
  • Message 1026 of 1217

Re: T420s Fan noise Issue

2012-04-11, 23:13 PM

Hi guys, Lenove is on sale of Thinkpad Laptop: 30% off T420s, X220, W520, 25% off T420 (http://dealsea.com/view-deal/62445 ). For us, may be bad news. I am afraid the old versions will be gone, so will our hope.

Reply
Options

2 Posts

04-10-2012

United States

2 Signins

11 Page Views

  • Posts: 2
  • Registered: ‎04-10-2012
  • Location: United States
  • Views: 11
  • Message 1027 of 1217

Re: T420s Fan noise Issue

2012-04-12, 1:08 AM

What did everyone decide on TPFC.62?

 

I downloaded it (I know nothing about computers) and didn't touch any of the settings.  I hope it's working on it's own.  The fan stopped (it says under State at 0, and under Speed at 0RPM) but I'm nervous my computer will break or something.  Is that all I had to do?  It was a great fix (I think?)

 

For the computer savvy, just let me know if what I did is very stupid.  If it isn't, I totally recommend it.  No more horrible headache-inducing sound.

Reply
Options

14 Posts

10-24-2011

Germany

17 Signins

94 Page Views

  • Posts: 14
  • Registered: ‎10-24-2011
  • Location: Germany
  • Views: 94
  • Message 1028 of 1217

Re: T420s Fan noise Issue

2012-04-12, 7:24 AM

Those are my settings:

 

Level=48 0       
Level=55 2       
Level=58 3             
Level=60 4       

Level=65 128

 

The goal is to get this machine nearly silent for daily tasks (internet, office), but let the bios control the fan under high load.

Reply
Options

22 Posts

10-26-2011

United States

28 Signins

238 Page Views

  • Posts: 22
  • Registered: ‎10-26-2011
  • Location: United States
  • Views: 238
  • Message 1029 of 1217

Re: T420s Fan noise Issue

2012-04-12, 7:37 AM

How do you enter the temp-fan speed settings as you have suggested? I opened the program "edit TPfancontrol.ini" and scrolled down to: profile "Smart Mode 1"
// change values and number of items for your needs
// Celsius:             // Fahrenheit:

 

I changed the temp-fan speed settings, and closed the notepad page, but it doens't seem to have taken effect.  Do I need to change the slash '/"

 

Here is what I have:

 

profile "Smart Mode 1"
// change values and number of items for your needs
// Celsius:             // Fahrenheit:

MenuLabelSM1=Smart Mode 1/  Label for Icon Menu, must be terminated by '/'

Level=50 2        // Level=140 0
Level=55 3        // Level=150 1
Level=60 4              // Level=165 3
Level=65 5        // Level=175 7
Level=70 7        // Level=195 64

 

Any advice? '

Reply
Options

14 Posts

10-24-2011

Germany

17 Signins

94 Page Views

  • Posts: 14
  • Registered: ‎10-24-2011
  • Location: Germany
  • Views: 94
  • Message 1030 of 1217

Re: T420s Fan noise Issue

2012-04-12, 8:10 AM

You did everything right, as far as I can tell. Below are the settings from my TPfancontrol.ini. I let everything else unchanged.

 

MenuLabelSM1=Smart Mode 1/  Label for Icon Menu, must be terminated by '/'

Level=48 0              // Level=140 0
Level=55 2              // Level=150 1
Level=58 3              // Level=165 3
Level=60 4              // Level=175 7
Level=65 128         // Level=195 64

 

Could please try to log off and log on on your computer? This should bring those settings into effect.

I have to point out, that with the above settings, the fan is not completely silent, but it doesn't sound like a vaccum cleaner either.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms