Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

3538 Posts

07-12-2010

Malaysia

5065 Signins

104816 Page Views

  • Posts: 3538
  • Registered: ‎07-12-2010
  • Location: Malaysia
  • Views: 104816
  • Message 361 of 1217

Re: T420s Fan noise Issue

2011-09-12, 2:29 AM
@flyflyflyol,

You can download the previous drive via this page.

http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS014992

Scroll to the end of the page.

@Others,

Appreciate everyone taking the time to post back the results, also I've dropped an email to Wihoutwax to get his laptop shipped in. I am yet to receive his reply.

//JameZ
Reply
Options

3 Posts

09-10-2011

Hong Kong S.A.R of China

18 Signins

60 Page Views

  • Posts: 3
  • Registered: ‎09-10-2011
  • Location: Hong Kong S.A.R of China
  • Views: 60
  • Message 362 of 1217

Re: T420s Fan noise Issue

2011-09-12, 9:19 AM

@JameZ

         Thanks for the info,  but Only 1.25 available. My problem is I couldnt find 1.26, which originally came with the machine

 

@All

 

         You may try diferent combinations between BIOS and EC. I tested a few combinations last weekend. The BIOS 1.28 with EC 1.09 seems fine to work on my machine so far, but I still feel the 1.26 (orginal one) works smoother. I hope this information may help you guys

Reply
Options

20 Posts

08-13-2011

Germany

32 Signins

184 Page Views

  • Posts: 20
  • Registered: ‎08-13-2011
  • Location: Germany
  • Views: 184
  • Message 363 of 1217

Re: T420s Fan noise Issue

2011-09-12, 19:14 PM

JameZ schrieb:
@All,

Appreciate everyone's prompt feedback on this. Please boot into BIOS and check the BIOS version and EC version is correct after flashing BIOS 1.28

BIOS version 1.28 (8CET48WW)
EC version 1.10 (8CHT23WW)

Check the 8CET48WW and 8CHT23WW

Thank you
James

@ JameZ,

 

I followed your instructions, but unfortunately there is again no improvement of the fan behaviour. :smileysad:

Reply
Options

11 Posts

09-13-2011

Denmark

182 Signins

492 Page Views

  • Posts: 11
  • Registered: ‎09-13-2011
  • Location: Denmark
  • Views: 492
  • Message 364 of 1217

Re: T420s Fan noise Issue

2011-09-13, 7:22 AM

Hi,

 

I have a t420s with the noisy fan problem too... Its so annoying that Im considering returning the laptop, and go for a HP8460p instead! 

Lenovo has offered me to come and change the cpu fan, because that might be the faulty part? Any comments on that?

 

I see this thread is marked as solved... Guess thats a mistake!

 

Thanks for your time

-Stefan

Reply
Options

119 Posts

06-12-2009

Norway

1184 Signins

4696 Page Views

  • Posts: 119
  • Registered: ‎06-12-2009
  • Location: Norway
  • Views: 4696
  • Message 365 of 1217

Re: T420s Fan noise Issue

2011-09-13, 7:26 AM

Marking it as solved is a bit deceiving. 

 

I would not recommend anyone to buy a T420s at the moment, and if you can, just return it. 

 

To change language, go to my settings, and profile. (don't know the german words for it, sorry)

http://forums.lenovo.com/t5/user/myprofilepage/tab/user-preferences

Reply
Options

3 Posts

09-08-2011

Germany

3 Signins

94 Page Views

  • Posts: 3
  • Registered: ‎09-08-2011
  • Location: Germany
  • Views: 94
  • Message 366 of 1217

Re: T420s Fan noise Issue

2011-09-13, 10:03 AM

Hello everyone,

 

I was just administrating my system, when I discovered some ACPI-Alerts in Windows 7's 'Event Viewer' which seem to happen everytime the system boots up. According to the log-message, the bios tries to access the EC (Embedded Controller) - which is among other things responsible for fan-control - without synchronizing with Windows and therefore this data will be ignored. Maybe that's a hint of what's going wrong.

 

Perhaps some of you could check, if this occurs on every t420. To do so, open the 'Event Viewer', go to 'Custom View' and select 'Administrative Events'. Here's a screenshot (i am using a german windows): http://s7.directupload.net/file/d/2646/rvhjbase_png

 

Greetings

 

 

Reply
Options

207 Posts

08-28-2008

Israel

7095 Signins

16925 Page Views

  • Posts: 207
  • Registered: ‎08-28-2008
  • Location: Israel
  • Views: 16925
  • Message 367 of 1217

Re: T420s Fan noise Issue

2011-09-13, 10:17 AM

wrote:

Hello everyone,

 

I was just administrating my system, when I discovered some ACPI-Alerts in Windows 7's 'Event Viewer' which seem to happen everytime the system boots up. According to the log-message, the bios tries to access the EC (Embedded Controller) - which is among other things responsible for fan-control - without synchronizing with Windows and therefore this data will be ignored. Maybe that's a hint of what's going wrong.

 

Perhaps some of you could check, if this occurs on every t420. To do so, open the 'Event Viewer', go to 'Custom View' and select 'Administrative Events'. Here's a screenshot (i am using a german windows): http://s7.directupload.net/file/d/2646/rvhjbase_png

 

Greetings

 

 


 

I think you are onto something!

From my T420s:

http://imageshack.us/f/684/unlednkv.png/

___________________________________________________________
Lenovo Thinkpad T420s
Reply
Options

143 Posts

11-15-2009

Stockholm

822 Signins

2288 Page Views

  • Posts: 143
  • Registered: ‎11-15-2009
  • Location: Stockholm
  • Views: 2288
  • Message 368 of 1217

Re: T420s Fan noise Issue

2011-09-13, 10:20 AM
This is very interesting - but it doesn't really explain why the engineers have been unable to duplicate this problem. They run a Windows 7 machine in their labs, and if Windows 7 was having problems accessing their ECP also they should also be seeing high fan speeds.

The only variable that I've seen that actually affects the fan spinning seems to be the ambient temperature. Right now Stockholm is in a cooler period so my fan does regulate properly - I don't know how cold it is in my apartment, but it feels about 22-23 C.
Reply
Options

3 Posts

09-09-2011

Wolfsburg

6 Signins

26 Page Views

  • Posts: 3
  • Registered: ‎09-09-2011
  • Location: Wolfsburg
  • Views: 26
  • Message 369 of 1217

Re: T420s Fan noise Issue

2011-09-13, 12:08 PM

Hi JameZ,

 

I have just installed the new BIOS-Version 1.28 on my T420s, Win 7, 64bits, but the fan noise issue is NOT solved.

 

What should I do now?

Best regards

Hoa Nam

Reply
Options

62 Posts

05-26-2011

Switzerland

71 Signins

400 Page Views

  • Posts: 62
  • Registered: ‎05-26-2011
  • Location: Switzerland
  • Views: 400
  • Message 370 of 1217

Re: T420s Fan noise Issue

2011-09-13, 12:47 PM
Yep, same here, also got a bunch of ACPI Warnings after booting the PC. They are EC related as Wander wrote!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms