Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

107 Posts

06-28-2011

Italia

2191 Signins

3793 Page Views

  • Posts: 107
  • Registered: ‎06-28-2011
  • Location: Italia
  • Views: 3793
  • Message 671 of 1217

Betreff: T420s Fan noise Issue

2011-11-22, 10:17 AM

wrote:

 


$ sudo cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq
1800000

 


Works sanely on mine,

 

alessandro at alessandro-thinky in ~
$ sudo cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq
800000

 

I've also tried checking the real frequencies with i7z and I see clocks around 800-900 MHz, so my CPU scales ok.

Despite that, my fan is still stuck at 4000RPMs.

Reply
Options

49 Posts

08-10-2011

Germany

132 Signins

405 Page Views

  • Posts: 49
  • Registered: ‎08-10-2011
  • Location: Germany
  • Views: 405
  • Message 672 of 1217

Betreff: T420s Fan noise Issue

2011-11-22, 11:09 AM

Yesterday I using google maps the fan spinns up to 4K at a CPU temp of 50-55°C. back too 3.5k only at CPU temp ~45°C 

I think 1.30 do not solve the fan problem for all Machines.

 

So please fix that.

Reply
Options

7 Posts

11-21-2011

Paris

46 Signins

224 Page Views

  • Posts: 7
  • Registered: ‎11-21-2011
  • Location: Paris
  • Views: 224
  • Message 673 of 1217

Betreff: T420s Fan noise Issue

2011-11-22, 13:13 PM

@alexcriss : So perhap's I have a bug in the OS... Which version of your kernel?

 

For Linux users: in order to fix the fan noise, I use thinkfan 0.7.3 (version 0.8 alpha2 doesn't work). Usefull information here.

 

I use the following configuration file:

# run with: sudo ./thinkfan-0.7.3 -n -b 0 -c thinkfan-0.7.3.conf

sensor /sys/class/hwmon/hwmon0/temp1_input sensor /sys/class/hwmon/hwmon2/device/temp1_input sensor /sys/class/hwmon/hwmon2/device/temp2_input sensor /sys/class/hwmon/hwmon2/device/temp3_input fan /proc/acpi/ibm/fan (0, 0, 43) (1, 40, 49) (2, 44, 55) (3, 49, 57) (128, 52, 32767) # [TM] Nota. 128 is auto

Nota. - This needs to disable the bios management of ventilation. It's quite dangerous.

Reply
Options

107 Posts

06-28-2011

Italia

2191 Signins

3793 Page Views

  • Posts: 107
  • Registered: ‎06-28-2011
  • Location: Italia
  • Views: 3793
  • Message 674 of 1217

Betreff: T420s Fan noise Issue

2011-11-22, 13:42 PM

wrote:

: So perhap's I have a bug in the OS... Which version of your kernel?

 


Some info on packages installed here (on Arch Linux), if it may help. Pacman -Q reads as "what package have I installed?"

 

alessandro at alessandro-thinky in ~
$ pacman -Q linux
linux 3.1.1-1

 

alessandro at alessandro-thinky in ~
$ pacman -Qs mesa
local/intel-dri 7.11.1-1
Mesa DRI drivers for Intel
local/libgl 7.11.1-1
Mesa 3-D graphics library and DRI software rasterizer
local/libglapi 7.11.1-1
free implementation of the GL API -- shared library. The Mesa GL API module is responsible for dispatching all the
gl* functions
local/mesa 7.11.1-1
Mesa 3-D graphics libraries and include files

 

alessandro at alessandro-thinky in ~
$ pacman -Qs xf86-video
local/xf86-video-intel 2.17.0-1 (xorg-drivers xorg)
X.org Intel i810/i830/i915/945G/G965+ video drivers

Reply
Options

163 Posts

07-02-2011

USA

950 Signins

2954 Page Views

  • Posts: 163
  • Registered: ‎07-02-2011
  • Location: USA
  • Views: 2954
  • Message 675 of 1217

Betreff: T420s Fan noise Issue

2011-11-22, 14:07 PM
I applied the 1.30 patch, and I think it improved the situation. I occasionally get a situation where the fan is stuck at 4K and won't spin down, but the fan almost always spins down when the CPU cools now. However, to definitively determine if the problem has been resolved, I will have to wait until the summer when room temperatures rise and the CPU is at its hardest to cool. 

wrote:

Yesterday I using google maps the fan spinns up to 4K at a CPU temp of 50-55°C. back too 3.5k only at CPU temp ~45°C 

I think 1.30 do not solve the fan problem for all Machines.

 

So please fix that.


Hello Julian_Think,

 

That sounds like normal behavior. The fan spins up to 4K at high temperatures and slows down when your processor cools. I do not think you have a fan problem anymore.

 

There seem to be quite a few reports like these on this thread -- people who are reporting that they are having the "fan noise problem" even though their fan speed varies with the system temperature. The real fan noise problem occurs when the fan spins at 4000RPM for all eternity, regardless of system workload.

Reply
Options

49 Posts

08-10-2011

Germany

132 Signins

405 Page Views

  • Posts: 49
  • Registered: ‎08-10-2011
  • Location: Germany
  • Views: 405
  • Message 676 of 1217

Betreff: T420s Fan noise Issue

2011-11-22, 14:31 PM

You are right the big problem is solved.

But sometimes my fan works different (spinn down at ~45°C and not at *55°C) and to bring the CPU under 45°C is only Posible wenn there is no work for the CPU. 

So there are some points they are not Idle in 1.30

Reply
Options

87 Posts

01-25-2010

Canada

388 Signins

3631 Page Views

  • Posts: 87
  • Registered: ‎01-25-2010
  • Location: Canada
  • Views: 3631
  • Message 677 of 1217

Betreff: T420s Fan noise Issue

2011-11-22, 16:30 PM

So after a week of giving 1.30 the benefit of the doubt, I'm going back to 1.29 (thanks @ReneW)...  I could handle the fact that fan would spin constant at 4k, but when on battery and in the lowest power state, the fan stayed at ~4k which ate up my battery.  With 1.29, on battery in the lowest power state, the fan spins at 1800rpm or less at times! 

_______________________________________________________
T420s, i5-2520M @2.5, nVidia 4200m, 8GB DDR3, OCZ Vertex 3 Max IOPS 240GB SSD, Hitachi 320GB @7200rpm ulrabay, 8Pro x64
T61, Centrino Duo @1.8, GM965, 4GB PC2-5300 DDR2 @667MHz, OCZ Agility 120GB SSD, 7Pro x64
Reply
Options

332 Posts

12-01-2009

Czech Republic

378 Signins

2497 Page Views

  • Posts: 332
  • Registered: ‎12-01-2009
  • Location: Czech Republic
  • Views: 2497
  • Message 678 of 1217

Re: T420s Fan noise Issue

2011-11-22, 16:57 PM
Well, my experience is, there is no real reliable glue or rule, when it works and when it comes noisy. Some days it works correctly and then whole night in idle the fan is on 4000 RPM whole night, with cold CPU. Another day it works again and after that after some who knows things it comes again to make noise fan problem. My experience is , that this is really 50:50 correct versus noise functionality. Have no idea after what condition the fan starts to make problem. Really annoying.
----------------------------------------------------
Lenovo T440s, 20AQ0067MC, Windows 8.1 Pro x64 UEFI, Samsung 840 EVO SSD 250 GB, 8 GB RAM
Lenovo T430s, 2356LQG, Windows 8.1 Pro x64 UEFI, Intel 520 SSD 180 GB, 8 GB RAM
Lenovo T420s, 4171-6SG, Windows 8 Pro x64 UEFI, Intel 320 SSD 120 GB, 8 GB RAM
Lenovo T400s, 2808-CYG, Windows 7 Ultimate x64
Reply
Options

22 Posts

10-26-2011

United States

28 Signins

238 Page Views

  • Posts: 22
  • Registered: ‎10-26-2011
  • Location: United States
  • Views: 238
  • Message 679 of 1217

Betreff: T420s Fan noise Issue

2011-11-22, 17:53 PM

Peednus- I think I will also try BIOS 1.29. Can you tell where I can download it?

 

1.30 has actually made my fan problem worse than the original BIOS that was loaded on my new laptop.

 

Stuck at 4000 Rpm, even at 45c.

 

All those posting: All of our input has clearly been important, as it garnered the attention of Lenovo staff. But I have to say, after 6 months and almost 70 pages of threads, at this point we are all grasping for straws as one of the recent posts mentioned. The reality is that this problem can not be fixed through a BIOS upgrade. The T420s has fundamental design flaws, and short of Lenovo agreeing to recall and partially rebuild the cooling system, the problem is not going to get fixed.

Reply
Options

9 Posts

11-16-2011

USA

41 Signins

249 Page Views

  • Posts: 9
  • Registered: ‎11-16-2011
  • Location: USA
  • Views: 249
  • Message 680 of 1217

Betreff: T420s Fan noise Issue

2011-11-22, 21:34 PM

For me BIOS 1.30 did not show any improvements at all. My fan is stuck at 4000 RPM all the time no matter what I do on my laptop. Right now my CPU is at 38 degrees celcius but still spinning and spinning at 4000 RPM. 

 

Lenovo please do something!!! 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms