Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2483 Posts

04-08-2011

United States of America

5471 Signins

46460 Page Views

  • Posts: 2483
  • Registered: ‎04-08-2011
  • Location: United States of America
  • Views: 46460
  • Message 781 of 1217

Re: re: T420s Fan noise Issue

2012-01-05, 6:44 AM

wrote:
this may be asked before in this. Is there any windows tools to measure fan rpm, temps etc. I have a t420 optimus with i5 2540,
After playing games for 30 mins, the cpu(video) gets awfully. i cant even touch the serial port next to the cpu fan exhaust.

hwinfo.com

 

They have 32bit and 64bit versions. 

Reply
Options

3538 Posts

07-12-2010

Malaysia

5065 Signins

104816 Page Views

  • Posts: 3538
  • Registered: ‎07-12-2010
  • Location: Malaysia
  • Views: 104816
  • Message 782 of 1217

Re: T420s Fan noise Issue

2012-01-05, 8:05 AM
@jasona,

replied your PM

//JameZ
Reply
Options

143 Posts

11-15-2009

Stockholm

822 Signins

2288 Page Views

  • Posts: 143
  • Registered: ‎11-15-2009
  • Location: Stockholm
  • Views: 2288
  • Message 783 of 1217

Re: T420s Fan noise Issue

2012-01-05, 16:08 PM
@jasona:

Under which circumstances does your computer fan stay at 4000 rpm even when idle?

The weird thing is I was able to get mine to stay at 4000 rpm after simply watching a video in VLC... but engineering wasn't able to duplicate that the test. However, as far as I know, they did not test a video via VLC.

Maybe you could give them directions on exactly what to test on your computer (i.e. leave a note on the Windows desktop) so they could simulate it exactly...

Reply
Options

8 Posts

01-04-2012

USA

114 Signins

489 Page Views

  • Posts: 8
  • Registered: ‎01-04-2012
  • Location: USA
  • Views: 489
  • Message 784 of 1217

Re: T420s Fan noise Issue

2012-01-05, 16:53 PM
@calkenneth

I run Ubuntu Linux 11.10, and previously 11.04, on my T420s with integrated graphics. JameZ said the system may not be acceptable to engineering as it is not running Windows with Lenovo Power Manager and Power Management. I recently sent a followup inquiring into other options, but have not received a response.

For me, on a mostly idle system, the fan will spin up to 4000 RPMs after ~9-10 minutes. Last night, I was just browsing some websites in Firefox without the system doing much else. CPU temperature was reported as ~40C for one core and ~33C for the second. Like always, it ramped up to 4000 RPMs after 9-10 minutes and remained there until I shutdown the system. It always happens regardless of how little I am doing on the system.

I am disheartened that JameZ says engineering wants Win7 + Lenovo Power Manager and Power Management. It seems to me the ECP should manage the fans without requiring additional Windows only software. I would still like this issue resolved regardless of the fact that I run Linux.
Reply
Options

107 Posts

06-28-2011

Italia

2191 Signins

3793 Page Views

  • Posts: 107
  • Registered: ‎06-28-2011
  • Location: Italia
  • Views: 3793
  • Message 785 of 1217

Re: T420s Fan noise Issue

2012-01-05, 17:50 PM
JameZ, can you tell Lenovo's engineering group to consider accepting jasona's laptop. This is a BIOS issue, Linux or Windows don't matter that much, neither does the Power Manager.

Saying no, we want Windows, when many users do not get what they expect from their (expensive) purchase seems a quite arrogant behaviour on their part. Not only they didn't fix this issue in a reasonable amount of time, they refuse machines for further testing. This is really irritating!
Reply
Options

207 Posts

08-28-2008

Israel

7095 Signins

16925 Page Views

  • Posts: 207
  • Registered: ‎08-28-2008
  • Location: Israel
  • Views: 16925
  • Message 786 of 1217

Re: T420s Fan noise Issue

2012-01-05, 18:40 PM

My motherboard and fan were replaced by IBM repair center in Israel- no change, still very loud (3500RPM) and annoying.

This will be my last Thinkpad.

 

___________________________________________________________
Lenovo Thinkpad T420s
Reply
Options

7 Posts

10-07-2011

Germany

18 Signins

71 Page Views

  • Posts: 7
  • Registered: ‎10-07-2011
  • Location: Germany
  • Views: 71
  • Message 787 of 1217

Re: T420s Fan noise Issue

2012-01-06, 12:39 PM

@jasona:

 

Do you use thinkfan?  

Reply
Options

8 Posts

01-04-2012

USA

114 Signins

489 Page Views

  • Posts: 8
  • Registered: ‎01-04-2012
  • Location: USA
  • Views: 489
  • Message 788 of 1217

Re: T420s Fan noise Issue

2012-01-06, 12:49 PM
@mackie:

No, I don't use thinkfan. I just rely on the embedded controller & BIOS.
Reply
Options

16 Posts

10-26-2011

Canada

240 Signins

425 Page Views

  • Posts: 16
  • Registered: ‎10-26-2011
  • Location: Canada
  • Views: 425
  • Message 789 of 1217

T420s Fan noise Issue

2012-01-06, 20:29 PM

Now I've been hit with it!!

 

Mine is always @ 4000 RPM.

 

Even after turning it on, or waking if from sleep.

 

I use tpfancontrol to monitor it, not to control the fax speed..

 

This sucks..

Reply
Options

7 Posts

10-07-2011

Germany

18 Signins

71 Page Views

  • Posts: 7
  • Registered: ‎10-07-2011
  • Location: Germany
  • Views: 71
  • Message 790 of 1217

Re: T420s Fan noise Issue

2012-01-06, 21:02 PM

@jasona

 

There is a pretty good wikipage for the newer T-Series. Originally in German but Google Translator is doing well:

http://translate.google.de/translate?sl=de&tl=en&js=n&prev=_t&hl=de&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Fthinkpad-wiki.org%2FThinkfan

 

This is my data for the /etc/thinkfan.conf  config file:

 

 ------------------------------------------

sensor /sys/devices/platform/coretemp.0/temp1_input
sensor /sys/devices/platform/coretemp.0/temp2_input
sensor /sys/devices/platform/coretemp.0/temp3_input
sensor /sys/devices/virtual/hwmon/hwmon0/temp1_input

(0,     0,     36)
(1,     32,    62)
(2,     52,    66)
(3,     56,    70)
(4,     58,    74)
(5,     60,    76)
(7,     63,    32767)

---------------------------------------------------------

 

Additional activate the Intel RC6 options if you have Intel Graphics (Don't know if it works with Optimus).

Change /etc/default/grub :


 --------------------------------------------------------

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.i915_enable_rc6=1"

--------------------------------------------------------

 

Then update grub:

 

sudo update-grub

 

 

About 4 steps and your T420s is running on MBP levels (checked with my brothers late 2011 model). :-)

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All