Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

8 Posts

04-19-2017

Germany

7 Signins

52 Page Views

  • Posts: 8
  • Registered: ‎04-19-2017
  • Location: Germany
  • Views: 52
  • Message 1 of 7

T420s slows down CPU to minimum 0.76 GHz when docked

2017-04-19, 7:16 AM

We still have several T420s at work and one of these has a strange behaviour: when it is put into a dock (the "advanced" port replicator) it slows down its CPU to 0.76 GHz and does not let it run at higher speed no matter how much load you put on it. Once I remove it from the dock and put some (even light) load on it, it perfectly increased the CPU speed, up to its maximum of 2.8 GHz. It is not a problem of a specific dock, I already tried a couple of these. It is a problem of that T420s. The other T420s we have do not have this problem. I did also already reset all BIOS settings to default. Does anyone have an idea what may cause this strange behaviour? Is it a hardware problem and I am out of luck (warranty period has long been exceeded)?

Reply
Options

1597 Posts

05-29-2010

Singapore

2876 Signins

58997 Page Views

  • Posts: 1597
  • Registered: ‎05-29-2010
  • Location: Singapore
  • Views: 58997
  • Message 2 of 7

Re: T420s slows down CPU to minimum 0.76 GHz when docked

2017-04-20, 12:33 PM

Hi kai_uwe_rommel,

1. Have you installed the latest BIOS and updates using Lenovo System Updates? (Control Panel > Lenovo - Update and Drivers)

2. Have you tried to change the Power Plans? (Control Panel > Power Options)

Peter

ThinkPad X40 | ThinkPad W520 | ThinkPad T560 | ThinkCentre E73 SFF | Yoga 11s | Yoga 3 Pro | Yoga 900 | Yoga Home 900 | Yoga Tablet 2 Pro | Miix 2 10" | IdeaPad Y460p | IdeaPad K1 | 3000 Y300 | Vibe K5 Plus

Give kudos to reward people for their assistance | Mark thread solved if the solution works | I am an active volunteer, not an Lenovo employee

=====================================

List of Sound Enhancement Thread

T520 | W520 ; Dolby ; IdeaPad Slate Tablet ; Yoga 3 Pro ; X100e ; Vibe Shot ; Yoga 900 ; P50 ; P40 Yoga | Yoga 14 | Yoga 460 ; T560 | P50s ; Vibe K5 | K5 Plus ; M0620 Speaker Mod ; Windows 10 / Windows Server 2016

Reply
Options

8 Posts

04-19-2017

Germany

7 Signins

52 Page Views

  • Posts: 8
  • Registered: ‎04-19-2017
  • Location: Germany
  • Views: 52
  • Message 3 of 7

Re: T420s slows down CPU to minimum 0.76 GHz when docked

2017-04-20, 12:37 PM

Yes to both.

Reply
Options

1597 Posts

05-29-2010

Singapore

2876 Signins

58997 Page Views

  • Posts: 1597
  • Registered: ‎05-29-2010
  • Location: Singapore
  • Views: 58997
  • Message 4 of 7

Re: T420s slows down CPU to minimum 0.76 GHz when docked

2017-04-20, 12:46 PM

Hi kai_uwe_rommel,

You may try to download and install a newer version of firmware for the dock replicator to see if it resolves the issue you are facing.

Peter

ThinkPad X40 | ThinkPad W520 | ThinkPad T560 | ThinkCentre E73 SFF | Yoga 11s | Yoga 3 Pro | Yoga 900 | Yoga Home 900 | Yoga Tablet 2 Pro | Miix 2 10" | IdeaPad Y460p | IdeaPad K1 | 3000 Y300 | Vibe K5 Plus

Give kudos to reward people for their assistance | Mark thread solved if the solution works | I am an active volunteer, not an Lenovo employee

=====================================

List of Sound Enhancement Thread

T520 | W520 ; Dolby ; IdeaPad Slate Tablet ; Yoga 3 Pro ; X100e ; Vibe Shot ; Yoga 900 ; P50 ; P40 Yoga | Yoga 14 | Yoga 460 ; T560 | P50s ; Vibe K5 | K5 Plus ; M0620 Speaker Mod ; Windows 10 / Windows Server 2016

Reply
Options

8 Posts

04-19-2017

Germany

7 Signins

52 Page Views

  • Posts: 8
  • Registered: ‎04-19-2017
  • Location: Germany
  • Views: 52
  • Message 5 of 7

Re: T420s slows down CPU to minimum 0.76 GHz when docked

2017-04-20, 12:53 PM

Please re-read my original post. Other identical T420s do not have that problem in the same dock.

This T420s has this problem in any of the docks we tried (quite a few).

And as far as I know, the docks for the T420/T430 series do not have any updatable firmware at all.

The docks for the T440 and newer have an updateable firmware ...

Reply
Options

1597 Posts

05-29-2010

Singapore

2876 Signins

58997 Page Views

  • Posts: 1597
  • Registered: ‎05-29-2010
  • Location: Singapore
  • Views: 58997
  • Message 6 of 7

Re: T420s slows down CPU to minimum 0.76 GHz when docked

2017-04-22, 9:22 AM

Hi kai_uwe_rommel,

1. Does other identical T420s without problems with the dock used the same version of BIOS as the T420s with problems with the dock?

2. For the T420s with problems with the dock, try to Restore Defaults settings on all Power Plans.

3. If No. 2 does not work, try to download and reinstall the Power Manager (for Windows 7 only) and the Power Management Driver.

4. If No. 3 does not work, try to change on another power adapter to see if it works.

5. If No. 4 does not work, try to download and flash older version of BIOS to see if it helps to resolve the issue.

Peter

ThinkPad X40 | ThinkPad W520 | ThinkPad T560 | ThinkCentre E73 SFF | Yoga 11s | Yoga 3 Pro | Yoga 900 | Yoga Home 900 | Yoga Tablet 2 Pro | Miix 2 10" | IdeaPad Y460p | IdeaPad K1 | 3000 Y300 | Vibe K5 Plus

Give kudos to reward people for their assistance | Mark thread solved if the solution works | I am an active volunteer, not an Lenovo employee

=====================================

List of Sound Enhancement Thread

T520 | W520 ; Dolby ; IdeaPad Slate Tablet ; Yoga 3 Pro ; X100e ; Vibe Shot ; Yoga 900 ; P50 ; P40 Yoga | Yoga 14 | Yoga 460 ; T560 | P50s ; Vibe K5 | K5 Plus ; M0620 Speaker Mod ; Windows 10 / Windows Server 2016

Reply
Options

5 Posts

03-09-2019

Chile

5 Signins

51 Page Views

  • Posts: 5
  • Registered: ‎03-09-2019
  • Location: Chile
  • Views: 51
  • Message 7 of 7

Re: T420s slows down CPU to minimum 0.76 GHz when docked

2019-03-09, 0:13 AM

THIS IS THE SOLUTION I DISCOVERED

 

I see this is an old thread, but today I had a similar problem at a client with a Dell Celeron running Windows 10.

The CPU usage locked at 30% maximum utilization at 0.48Ghz, and the laptop was terribly slow.
It took 30 minutes just to open Outlook, to give you an idea...

I noted the following:
1. Although it was connected to power, the battery icon said: "Not Charging" 
2. Battery level was at 1%
3. All battery settings for "Pressing the Power button", "Pressing the Sleep button" and "Closing the lid" was set to SLEEP

Client would close the lid at 5pm and put the laptop away, only to reconnect the next day. SLEEP mode drained the battery totally and since the battery power would then fall below 20% by the next morning, the Battery Saving setting in Windows 10 kicked in and FORCE the laptop to SUPER SLOW mode (locking CPU usage at 30% max).

This problem of SUPER slowness and CPU lock can thus only occur on LAPTOPS or devices with batteries in my view.

To fix this (temporary or permanently), do this:

1. Click the battery icon in the tray (next to the date, right bottom of the screen) - NB: NOT Right-Click
2. Click "Battery settings"
3. Un-tick "Turn battery saver on automatically if power falls below..."
4. Disable "Battey saver status until next charge"
5. Unplug the power cable and re-plug.

The CPU Usage should now go up to 100% again and the battery icon should say "Charging"

PS. Make sure your charger works and is the right type for your laptop.
Also, change the settings for "What the power button does" etc to Hibernate or Shutdown rather, if you know the laptop will be turned off for long periods of time to avoid draining the battery.

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms